Search found 20 matches

by intrax
Sat May 11, 2013 7:07 pm
Forum: Xtreamer
Topic: OpenMediaVault on eTrayz needs uBoot mod...
Replies: 25
Views: 14708

Re: OpenMediaVault on eTrayz needs uBoot mod...

There must be an easier way of installing debian without surgically opening etrayz and tinkering with the serial cable. right... you find it? Is it possible for you to create an image of your system partition so the rest of us non-experts can simply write it on our drives? sorry... you do it! Xtrea...
by intrax
Tue Mar 26, 2013 1:23 pm
Forum: Xtreamer
Topic: OpenMediaVault on eTrayz needs uBoot mod...
Replies: 25
Views: 14708

Re: OpenMediaVault on eTrayz needs uBoot mod...

Done !!! :D Thanks im going to dump uboot and change cmdline to try to boot from sda... No possibile! You will have to compile a fresh uBoot from source (see title of this thread), because the current uBoot has no usb support... I'm still trying to get hold of uBoot sources for oxnas... You're welc...
by intrax
Sat Mar 23, 2013 7:43 pm
Forum: Xtreamer
Topic: Crashplan and Symform arm install on eTrayz...
Replies: 0
Views: 2718

Crashplan and Symform arm install on eTrayz...

I have successfully installed crashplan http://www.crashplan.com/ on eTrayz nas. You can follow http://www.opticality.com/blog/2011/07/16/installing-crashplan-on-a-pogoplug-pro/ description for a howto... Now I would like to try to install symform http://www.symform.com/download/netgear/ on eTrayz n...
by intrax
Wed Mar 20, 2013 1:51 am
Forum: Xtreamer
Topic: OpenMediaVault on eTrayz needs uBoot mod...
Replies: 25
Views: 14708

Re: OpenMediaVault on eTrayz needs uBoot mod...

Rufuss wrote: export CROSS_COMPILE=arm-linux-gnueabihf-
I'm using Debian 6 emdebian toolchain
ARCH=arm
CROSS_COMPILE=arm-linux-glibcgnueabi
by intrax
Mon Mar 18, 2013 8:13 pm
Forum: Xtreamer
Topic: OpenMediaVault on eTrayz needs uBoot mod...
Replies: 25
Views: 14708

Re: OpenMediaVault on eTrayz needs uBoot mod...

Thanks your reply. After "reload-etrayz.sh /dev/sdc1" looks like hdd read/write a couple of seconds at insmod command and etrayzs usb led start blinking and stay unresponsive... Is that correct usb device ? Look at my remarks earlier... Usb stick ext3 formatted with debian-6.07-armel rootfs with ud...
by intrax
Mon Mar 18, 2013 2:45 pm
Forum: Xtreamer
Topic: OpenMediaVault on eTrayz needs uBoot mod...
Replies: 25
Views: 14708

Re: OpenMediaVault on eTrayz needs uBoot mod...

Ok, I attach my reloaded.ko for etrayz kernel 2.6.24.4 and my reload.sh script. Make sure you put your own mac_address in and your correct usb boot device! Also pay attention to the fact that reloaded.ko will boot a 'zImage' kernel... suc6! ;) edit: seems I'm not allowed to upload these files. I wil...
by intrax
Thu Mar 07, 2013 7:32 pm
Forum: Xtreamer
Topic: OpenMediaVault on eTrayz needs uBoot mod...
Replies: 25
Views: 14708

Re: OpenMediaVault on eTrayz needs uBoot mod...

A few weeks ago i have read that minimum requirement for udev 164 is kernel 2.6.31 :cry: I am trying to run squeezy on etrayz booting from its own hdd without raid. I have got the patch againts native 2.6.24.4 using diff on 2.6.24.4 from etrayz sources. Patched 2.6.27 seem to be ok but i could not ...
by intrax
Tue Mar 05, 2013 11:18 pm
Forum: Xtreamer
Topic: OpenMediaVault on eTrayz needs uBoot mod...
Replies: 25
Views: 14708

Re: OpenMediaVault on eTrayz needs uBoot mod...

Looks like I'll have to patch the kernel for 'signalfd' to have the latest udev working...
Anyone ?
by intrax
Sat Mar 02, 2013 11:45 pm
Forum: Xtreamer
Topic: OpenMediaVault on eTrayz needs uBoot mod...
Replies: 25
Views: 14708

Re: OpenMediaVault on eTrayz needs uBoot mod...

Finally ! :) Got OMV running on eTrayz from usb stick using reload.ko and reload.sh to reboot kernel from usb. Running on eTrayz kernel 2.6.24.4 and using udev from lenny. Installed OMV required packages from squeeze. For more info on installing omv look here: http://forums.openmediavault.org/viewto...
by intrax
Sat Feb 23, 2013 10:02 pm
Forum: Xtreamer
Topic: OpenMediaVault on eTrayz needs uBoot mod...
Replies: 25
Views: 14708

Re: OpenMediaVault on eTrayz needs uBoot mod...

SUCCES! :lol: Got firmware loaded and eth0 running... I installed the wrong udev package to the rootfs... after correction can now start udevd and its loading the gmac_copro_firmware ! Sure you could. But what is the fun in it? I know but I'm fed up with xTreamer company as they made many promises b...
by intrax
Fri Feb 22, 2013 2:00 pm
Forum: Xtreamer
Topic: OpenMediaVault on eTrayz needs uBoot mod...
Replies: 25
Views: 14708

Re: OpenMediaVault on eTrayz needs uBoot mod...

@Mijzelf Thanks your reply. Have you ever looked at the board? My HMNHD is basically only a SoC and memory. Not much to document. For people who are interested picture of serial console on eTrayz board: https://picasaweb.google.com/lh/photo/QsqCOWMx4FPkeJ0ZpXXlrOoONmx9_p977wwub69XIpA?feat=directlink...
by intrax
Thu Feb 21, 2013 6:18 pm
Forum: Xtreamer
Topic: OpenMediaVault on eTrayz needs uBoot mod...
Replies: 25
Views: 14708

Re: OpenMediaVault on eTrayz needs uBoot mod...

I've put in a significant effort over the last few weeks to get this to work, but I seem to get stuck on all fronts: - uBoot sources for eTrayz are nowhere to be found and xTreamer is not cooperating. I found some github repositories containing oxnas810 source but usb support was never implemented a...
by intrax
Thu Feb 14, 2013 11:54 pm
Forum: Other
Topic: Can a NAS device factory reset and performa a wipe on itself
Replies: 8
Views: 4951

Re: Can a NAS device factory reset and performa a wipe on it

Tough luck, but try to reassemble your raid arrays md0 and md1 by using mdadm... see http://www.iceteks.com/articles.php/linuxmdadmraid/1
by intrax
Mon Feb 11, 2013 4:35 pm
Forum: Xtreamer
Topic: OpenMediaVault on eTrayz needs uBoot mod...
Replies: 25
Views: 14708

Re: OpenMediaVault on eTrayz needs uBoot mod...

Still trying to get hold of u-Boot sources and board config for oxnas-810 to implement usb support... edit: I have contacted u-Boot development and they say sources, driver and board config for eTrayz u-Boot 1.1.2 were never published and merged into their source tree, so I asked xTreamer (again) to...
by intrax
Thu Jan 31, 2013 8:21 pm
Forum: Other
Topic: Conrad NAS Enclosure problem formatting HD
Replies: 6
Views: 4797

Re: Conrad NAS Enclosure problem formatting HD

Thanks guys for all the help , but after 4 days , 3 drives , 2 enclosures I am still no further on so I guess thats it for me. Sad as I wanted this set up but its well beyond me. I have formatted in fat32 , ntfs , etc,etc and still the enclosure reports it as 0.00kb. Time for the bin.!!!!! Have you...