General NAS-Central Forums

Welcome to the NAS community
It is currently Fri Sep 22, 2017 8:38 pm

All times are UTC




Post new topic Reply to topic  [ 23 posts ]  Go to page 1, 2  Next
Author Message
PostPosted: Fri Jul 12, 2013 10:19 am 
Offline

Joined: Fri Jul 12, 2013 12:17 am
Posts: 9
Hi There

I tried to install the ffp on my Zyxel NAS 220 plus. But with all the tutorials I not get any right solution.

I have the FirmWare 3.25 on the NSA-220 plus.

It not boot from the usb stick. In the end, I like to have plex server on it, cause this is the only nice solution to use all the movies and audios on my Samsung TV.

The problem I have is, if I use the normal internal Media Server, the TV shows me "File not supported -> then disconnect".

Any issues or sugesstions I can check?

Kindly Simon


Top
 Profile  
 
PostPosted: Fri Jul 12, 2013 1:07 pm 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 6039
When your stick meets the requirements (Only one partition, FAT formatted) then the only remaining option is to try another stick. Some sticks just don't work.

Plex will not run on your box. The available plex package is for 0.7/arm, and your box will install 0.7/oabi, due to kernel incompatibility.


Top
 Profile  
 
PostPosted: Fri Jul 12, 2013 1:33 pm 
Offline

Joined: Fri Jul 12, 2013 12:17 am
Posts: 9
Hi Mijzelf

And if I try to install Debian Lenny?

About the stick, I will try it again... maybe with a smalle stick than 16GB.

BTW: what is the different between arch and oabi?

I think I read somewhere that I have arch.

Kindly Simon


Top
 Profile  
 
PostPosted: Fri Jul 12, 2013 1:51 pm 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 6039
You mean the Lenny from this thread? Might work. That kernel is compiled with EABI support, so the calling convention is OK, but further it's the same, outdated, kernel. Don't know if plex relies on some new kernel functions.

Quote:
what is the different between arch and oabi?
The actual terms are arm and oabi, it are the names Fonz gave to the diffent FFP versions. 0.7/arm is compiled to run on an EABI kernel, and oabi on an OABI kernel.
EABI stands for Enhanced Application Binary Interface, and OABI for Old ABI. (Of course it had no specific name before EABI popped up).

It's about the way userland passes it's function parameters to the kernel, and back. An EABI program just cannot 'talk' to an OABI kernel and vv.


Top
 Profile  
 
PostPosted: Sat Jul 13, 2013 2:02 am 
Offline

Joined: Fri Jul 12, 2013 12:17 am
Posts: 9
Hi Mijzelf

I tried nearly the hole night to boot from the usb stick. But no chance to do it.

Again - I have the Zyxel NSA-220 Plus - what is the possibilities to install instead of the "out of the box"?

I have the FirmWare 3.25 on it.

I tried all the step by step. But not worked.

Kindly Simon


Top
 Profile  
 
PostPosted: Sat Jul 13, 2013 7:49 am 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 6039
Which directions are you following? Any logfiles on the stick?


Top
 Profile  
 
PostPosted: Sat Jul 13, 2013 8:14 am 
Offline

Joined: Fri Jul 12, 2013 12:17 am
Posts: 9
Hi Mijzelf

It would be nice, if I get any logfile. But I not have. Even not on the USB stick. Also no booting from the stick. If You have any idea, how I can get the way to the logfiles, it would be nice.

Could it be a network issue? I tried to see some things on the lan (with wireshark). But I don't...

Maybe something wich the router block? If I use an external harddisk by usb, the Samsung TV can see it.

Kindly Simon


Top
 Profile  
 
PostPosted: Sat Jul 13, 2013 11:53 am 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 6039
Mijzelf wrote:
Which directions are you following?


Top
 Profile  
 
PostPosted: Sat Jul 13, 2013 12:15 pm 
Offline

Joined: Fri Jul 12, 2013 12:17 am
Posts: 9
Hi Mijzelf

I just bought me a D-Link DNS 320 L. Installed there a Twonky Server - and it works fine. As I like to have...

Kindly Simon


Top
 Profile  
 
PostPosted: Tue Dec 10, 2013 10:13 am 
Offline

Joined: Tue Dec 10, 2013 10:05 am
Posts: 9
I have the same problem, NSA 220+ not booting from USB stick. It is FAT formatted and after starting no log files appear on the stick.
I tried Lenny version but it still did not work.
Is there a limitation on USB stick, like it should not be more than 4GB besides it being FAT formatted?
Thanks


Top
 Profile  
 
PostPosted: Tue Dec 10, 2013 1:03 pm 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 6039
tridy wrote:
Is there a limitation on USB stick, like it should not be more than 4GB besides it being FAT formatted?

According to the firmware script it should work as long as the stick can be mounted by the system. So if the stick is mounted normally by the firmware, and it is FAT formatted according to the webinterface, it should be fine.

Yet I have found that (sometimes?) on a 300 series the stick needs to have a partition table, although the script checks for that, and handles it correctly. But USB sticks without partititon table are rare, as Windows doesn't like it.

A more likely problem is the timing issue. This thread covers it. Unfortunately the solution there doesn't work on a NSA220. The only option is another stick.

Or the use of the zypkg, of course.


Top
 Profile  
 
PostPosted: Tue Dec 10, 2013 11:58 pm 
Offline

Joined: Tue Dec 10, 2013 10:05 am
Posts: 9
I managed to get through the boot, enable ssh, disable telnet and change the password.
now I would like to install mysql, and before that I think I will need nano text editor.
I took the command like from this thread:

create installation folder:
Code:
mkdir /ffp/install
cd /ffp/install


install nano text editor:
Code:
wget http://www.superkikim.com/files/nano-2.0.9.tar.gz
tar xvzf nano-2.0.9.tar.gz
cd nano-2.0.9
./configure --prefix /ffp
make
make install


the ./configure --prefix /ffp line gives some trouble:

Code:
checking build system type... armv5tejl-unknown-linux-gnu
checking host system type... armv5tejl-unknown-linux-gnu
checking target system type... armv5tejl-unknown-linux-gnu
checking for a BSD-compatible install... /ffp/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /ffp/bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... no
checking for gcc... no
checking for cc... no
checking for cl.exe... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.


and config.log contains:
Code:
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by GNU nano configure 2.0.9, which was
generated by GNU Autoconf 2.61.  Invocation command line was

  $ ./configure --prefix /ffp

## --------- ##
## Platform. ##
## --------- ##

hostname = nsa220plus
uname -m = armv5tejl
uname -r = 2.6.18.6
uname -s = Linux
uname -v = #1 Thu Oct 6 16:45:33 CST 2011

/usr/bin/uname -p = unknown
/bin/uname -X     = unknown

/bin/arch              = unknown
/usr/bin/arch -k       = unknown
/usr/convex/getsysinfo = unknown
/usr/bin/hostinfo      = unknown
/bin/machine           = unknown
/usr/bin/oslevel       = unknown
/bin/universe          = unknown

PATH: /ffp/sbin
PATH: /usr/sbin
PATH: /sbin
PATH: /ffp/bin
PATH: /usr/bin
PATH: /bin


## ----------- ##
## Core tests. ##
## ----------- ##

configure:1840: checking build system type
configure:1858: result: armv5tejl-unknown-linux-gnu
configure:1880: checking host system type
configure:1895: result: armv5tejl-unknown-linux-gnu
configure:1917: checking target system type
configure:1932: result: armv5tejl-unknown-linux-gnu
configure:1975: checking for a BSD-compatible install
configure:2031: result: /ffp/bin/install -c
configure:2042: checking whether build environment is sane
configure:2085: result: yes
configure:2113: checking for a thread-safe mkdir -p
configure:2152: result: /ffp/bin/mkdir -p
configure:2165: checking for gawk
configure:2181: found /ffp/bin/gawk
configure:2192: result: gawk
configure:2203: checking whether make sets $(MAKE)
configure:2228: result: no
configure:2472: checking for gcc
configure:2502: result: no
configure:2569: checking for cc
configure:2616: result: no
configure:2672: checking for cl.exe
configure:2702: result: no
configure:2731: error: no acceptable C compiler found in $PATH
See `config.log' for more details.

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_build=armv5tejl-unknown-linux-gnu
ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=
ac_cv_env_CFLAGS_value=
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_LDFLAGS_set=
ac_cv_env_LDFLAGS_value=
ac_cv_env_LIBS_set=
ac_cv_env_LIBS_value=
ac_cv_env_build_alias_set=
ac_cv_env_build_alias_value=
ac_cv_env_host_alias_set=
ac_cv_env_host_alias_value=
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_host=armv5tejl-unknown-linux-gnu
ac_cv_path_install='/ffp/bin/install -c'
ac_cv_path_mkdir=/ffp/bin/mkdir
ac_cv_prog_AWK=gawk
ac_cv_prog_make_make_set=no
ac_cv_target=armv5tejl-unknown-linux-gnu

## ----------------- ##
## Output variables. ##
## ----------------- ##

ACLOCAL='${SHELL} /ffp/install/nano-2.0.9/missing --run aclocal-1.10'
AMDEPBACKSLASH=''
AMDEP_FALSE=''
AMDEP_TRUE=''
AMTAR='${SHELL} /ffp/install/nano-2.0.9/missing --run tar'
AUTOCONF='${SHELL} /ffp/install/nano-2.0.9/missing --run autoconf'
AUTOHEADER='${SHELL} /ffp/install/nano-2.0.9/missing --run autoheader'
AUTOMAKE='${SHELL} /ffp/install/nano-2.0.9/missing --run automake-1.10'
AWK='gawk'
CC=''
CCDEPMODE=''
CFLAGS=''
CPP=''
CPPFLAGS=''
CURSES_LIB=''
CYGPATH_W='echo'
DEFS=''
DEPDIR=''
ECHO_C=''
ECHO_N='-n'
ECHO_T=''
EGREP=''
EXEEXT=''
GLIB_CFLAGS=''
GLIB_GENMARSHAL=''
GLIB_LIBS=''
GLIB_MKENUMS=''
GMSGFMT=''
GOBJECT_QUERY=''
GREP=''
INSTALL_DATA='${INSTALL} -m 644'
INSTALL_PROGRAM='${INSTALL}'
INSTALL_SCRIPT='${INSTALL}'
INSTALL_STRIP_PROGRAM='$(install_sh) -c -s'
INTLLIBS=''
LDFLAGS=''
LIBICONV=''
LIBINTL=''
LIBOBJS=''
LIBS=''
LN_S=''
LTLIBICONV=''
LTLIBINTL=''
LTLIBOBJS=''
MAKEINFO='${SHELL} /ffp/install/nano-2.0.9/missing --run makeinfo'
MKINSTALLDIRS=''
MSGFMT=''
MSGMERGE=''
OBJEXT=''
PACKAGE='nano'
PACKAGE_BUGREPORT='nano-devel@gnu.org'
PACKAGE_NAME='GNU nano'
PACKAGE_STRING='GNU nano 2.0.9'
PACKAGE_TARNAME='nano'
PACKAGE_VERSION='2.0.9'
PATH_SEPARATOR=':'
PKGDATADIR=''
PKG_CONFIG=''
POSUB=''
SET_MAKE='MAKE=make'
SHELL='/ffp/bin/sh'
STRIP=''
USE_COLOR_FALSE=''
USE_COLOR_TRUE=''
USE_NANORC_FALSE=''
USE_NANORC_TRUE=''
USE_NLS=''
USE_NLS_FALSE=''
USE_NLS_TRUE=''
VERSION='2.0.9'
XGETTEXT=''
ac_ct_CC=''
am__fastdepCC_FALSE=''
am__fastdepCC_TRUE=''
am__include=''
am__isrc=''
am__leading_dot='.'
am__quote=''
am__tar='${AMTAR} chof - "$$tardir"'
am__untar='${AMTAR} xf -'
bindir='${exec_prefix}/bin'
build='armv5tejl-unknown-linux-gnu'
build_alias=''
build_cpu='armv5tejl'
build_os='linux-gnu'
build_vendor='unknown'
datadir='${datarootdir}'
datarootdir='${prefix}/share'
docdir='${datarootdir}/doc/${PACKAGE_TARNAME}'
dvidir='${docdir}'
exec_prefix='NONE'
host='armv5tejl-unknown-linux-gnu'
host_alias=''
host_cpu='armv5tejl'
host_os='linux-gnu'
host_vendor='unknown'
htmldir='${docdir}'
includedir='${prefix}/include'
infodir='${datarootdir}/info'
install_sh='$(SHELL) /ffp/install/nano-2.0.9/install-sh'
libdir='${exec_prefix}/lib'
libexecdir='${exec_prefix}/libexec'
localedir='${datarootdir}/locale'
localstatedir='${prefix}/var'
mandir='${datarootdir}/man'
mkdir_p='/ffp/bin/mkdir -p'
oldincludedir='/usr/include'
pdfdir='${docdir}'
prefix='/ffp'
program_transform_name='s,x,x,'
psdir='${docdir}'
sbindir='${exec_prefix}/sbin'
sharedstatedir='${prefix}/com'
sysconfdir='${prefix}/etc'
target='armv5tejl-unknown-linux-gnu'
target_alias=''
target_cpu='armv5tejl'
target_os='linux-gnu'
target_vendor='unknown'

## ----------- ##
## confdefs.h. ##
## ----------- ##

#define PACKAGE_NAME "GNU nano"
#define PACKAGE_TARNAME "nano"
#define PACKAGE_VERSION "2.0.9"
#define PACKAGE_STRING "GNU nano 2.0.9"
#define PACKAGE_BUGREPORT "nano-devel@gnu.org"
#define PACKAGE "nano"
#define VERSION "2.0.9"
#define _GNU_SOURCE 1

configure: exit 1


cold someone please tell me what I am missing.

thanks


Top
 Profile  
 
PostPosted: Wed Dec 11, 2013 8:59 am 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 6039
Did you install FFP 0.7? In that case installing mysql and nano can be as simple as
Code:
slacker -Ui nano mysql
But maybe you first have to configure the site definitions.

BTW, your build fails because you didn't install a compiler and friends yet.


Top
 Profile  
 
PostPosted: Wed Dec 11, 2013 10:07 am 
Offline

Joined: Tue Dec 10, 2013 10:05 am
Posts: 9
Mijzelf wrote:
Did you install FFP 0.7? In that case installing mysql and nano can be as simple as
Code:
slacker -Ui nano mysql
But maybe you first have to configure the site definitions.

BTW, your build fails because you didn't install a compiler and friends yet.


Thanks for your help.
Yes, I have installed FFP 0.7. The problem there was that I was formatting the stick from Windows and copying files and then trying to reboot, while one must do mounting of the volume and formatting via nas web ui. (btw I was not able to mount a 32GB (is it the size limitation of FAT?) usb thumb drive but 4GB worked as expected)

I will try slacker thing later today when I get home.

- as far as I understand I do not need to compile nano if I can install it directly from slacker, or do I?
- how do I install a compiler actually?
- why do I need to configure the site definitions? is it needed for mysql and/or apache?

thanks!


Top
 Profile  
 
PostPosted: Wed Dec 11, 2013 12:15 pm 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 6039
tridy wrote:
- as far as I understand I do not need to compile nano if I can install it directly from slacker?
Right.
Quote:
- how do I install a compiler actually?
Code:
slacker -Ui binutils gcc make mpfr

Quote:
- why do I need to configure the site definitions? is it needed for mysql and/or apache?
Nano is available, but I don't know if it is in the default repository (site). Mysql is, and AFAIK there is no Apache available at all. But there is lighttpd (which is already installed, BTW).


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 23 posts ]  Go to page 1, 2  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group