General NAS-Central Forums

Welcome to the NAS community
It is currently Sat Oct 25, 2014 1:24 am

All times are UTC




Post new topic Reply to topic  [ 23 posts ]  Go to page 1, 2  Next
Author Message
PostPosted: Thu Feb 23, 2012 11:23 am 
Offline

Joined: Thu Feb 23, 2012 9:16 am
Posts: 12
Hello everyone! Newbie here :P

Actually I planned to buy new NAS, because I need a normal torrent client, but as I understood, I can install torrent client on ihmn as well.

Unfortunately I didn't find in forum detailed instructions to perform this. Could you help me with detailed step by step instructions? Thank you!


Top
 Profile  
 
PostPosted: Thu Feb 23, 2012 11:33 am 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 4546
The information is in the Wiki.

First enable a telnet daemon, then get apt-get to work, and finally install transmission:
Code:
apt-get update
apt-get install transmission


Top
 Profile  
 
PostPosted: Thu Feb 23, 2012 11:40 am 
Offline

Joined: Thu Feb 23, 2012 9:16 am
Posts: 12
Thank you for reply! One question, will I lose existing data on NAS?


Top
 Profile  
 
PostPosted: Thu Feb 23, 2012 11:58 am 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 4546
Normally not. But by gaining root access on your box (through telnet), you get the possibility to destroy anything. It's in your own hands.


Top
 Profile  
 
PostPosted: Fri Feb 24, 2012 9:39 pm 
Offline

Joined: Thu Feb 23, 2012 9:16 am
Posts: 12
I did everything. Installed MC file manager as well, but I can't find Transmission forder for editing config file. I checked each folder, but there is no anything relate to Transmission. When I trying to reinstall it - I receiving info that I already have installed Transmission. Any ideas where can I find it?

Thank you!


Top
 Profile  
 
PostPosted: Sat Feb 25, 2012 10:26 am 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 4546
Your box is actually running Debian Lenny, so you should look at the Transmission Debian docs:
https://trac.transmissionbt.com/wiki/UnixServer/Debian


Top
 Profile  
 
PostPosted: Sun Feb 26, 2012 10:21 am 
Offline

Joined: Thu Feb 23, 2012 9:16 am
Posts: 12
After around 8 hours of struggling, I bricked my NAS :) Thanks to guide in WiKi, I successfully restored it without losing data. Now, I'm came back to track and still full of desire to install Transmission :)

As I understood (after reading tons of materials in Google), the main problem that via apt-get install transmission we are receiving old version of Tranmission 1.22, which don't have a lot of scripts and config.json file. I edited source list and tried to install from other locations, but all of them trying to install 2.x version which is required new kernel for Debian Lenny. I tried to update it as well via aptitude update, but it was unsuccessful. System offered to install with -f command for removing dependencies and I agreed. Actually this action bricked my NAS.

Well, as I know now, latest version compatible with libc6 is Transmission v.1.77, I tried to install it from backdoors, but there are also 2.x version :(

Is there any users who successfully using Transmission from such NAS? I hope that they can help me. Or is there any manual way to install Transmission 1.77?

Thanks!


Top
 Profile  
 
PostPosted: Sun Feb 26, 2012 12:25 pm 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 4546
I suppose you could build it yourself.

Code:
cd /nethdd/some/place
wget http://download.transmissionbt.com/files/transmission-2.50.tar.bz2
tar xjf transmission-2.50.tar.bz2
cd transmission-2.50
./configure
make
su
make install-strip


Top
 Profile  
 
PostPosted: Sun Feb 26, 2012 1:12 pm 
Offline

Joined: Thu Feb 23, 2012 9:16 am
Posts: 12
Now I stuck in apt-get update command on "Getting apt-get to work" step. When I'm trying to apt-get update, I keep receiving message:


W: GPG error: http://security.debian.org lenny/updates Release: The following signatures were invalid: BADSIG 9AA38DCD55BE302B Debian Archive Automatic Signing Key (5.0/lenny) <ftpmaster@debian.org>
W: You may want to run apt-get update to correct these problems

I tried all possible solutions from WiKi, but without success so far. When I first time did (before bricking) the same step, I didn't face with such problem. I tried to edit sources.list from shell, but "nano" not available. Also, it's not possible to install mc or other editor without apt-get udpate command...

Is there any solution for me relate to this? Thank you.


Top
 Profile  
 
PostPosted: Sun Feb 26, 2012 1:32 pm 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 4546
AFAIK vi is available. Have a google for the manual, it's a nasty editor.


Top
 Profile  
 
PostPosted: Sun Feb 26, 2012 2:15 pm 
Offline

Joined: Thu Feb 23, 2012 9:16 am
Posts: 12
Somehow I realized how to work with vi :) Thank you with this. I tried a lot of sources and there are no sig errors, but same time there are no updates as well. Everytime it stops on "Reading package lists... Done":

Get:1 http://ftp.uk.debian.org lenny Release.gpg [1034B]
Get:2 http://ftp.uk.debian.org lenny Release [85.6kB]
Get:3 http://ftp.uk.debian.org lenny/main Packages [5040kB]
Get:4 http://ftp.uk.debian.org lenny/contrib Packages [64.0kB]
Get:5 http://ftp.uk.debian.org lenny/non-free Packages [71.3kB]
Fetched 5262kB in 43s (122kB/s)
Reading package lists... Done

Update's procedure not starting. Just cursor appear.


Top
 Profile  
 
PostPosted: Sun Feb 26, 2012 2:20 pm 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 4546
That is the update procedure. Just updating it's database. Now you can start to install.


Top
 Profile  
 
PostPosted: Sun Feb 26, 2012 2:46 pm 
Offline

Joined: Thu Feb 23, 2012 9:16 am
Posts: 12
I'm scaring a little bit :) When I trying to install MC, message is:
==================
The following packages were automatically installed and are no longer required:
libgtk2.0-common libxcb-render-util0 libx11-data perl libxcb-render0
hicolor-icon-theme readline-common libxcb1 libxau6 libgdbm3 netbase
libxdmcp6 net-tools ucf perl-modules libxcb-xlib0 libthai-data x11-common
libx11-6 xfonts-encodings libxext6
Use 'apt-get autoremove' to remove them.
Suggested packages:
mime-support perl zip unzip bzip2 links w3m lynx arj file xpdf dbview
odt2txt
The following packages will be REMOVED:
apt apt-utils libatk1.0-0 libbz2-1.0 libcairo2 libcomerr2 libcups2 libcurl3
libdatrie0 libdirectfb-1.0-0 libexpat1 libfontconfig1 libfontenc1
libfreetype6 libfribidi0 libgcrypt11 libgnutls26 libgtk2.0-0 libidn11
libkeyutils1 libkrb53 libmagic1 libnewt0.52 libpango1.0-0 libpixman-1-0
libpng12-0 libpopt0 libreadline5 libsasl2-2 libssh2-1 libssl0.9.8 libsysfs2
libtasn1-3 libthai0 libtiff4 libts-0.0-0 libusb-0.1-4 libxcomposite1
libxcursor1 libxdamage1 libxfixes3 libxfont1 libxft2 libxi6 libxinerama1
libxrandr2 libxrender1
The following NEW packages will be installed:
mc
WARNING: The following essential packages will be removed.
This should NOT be done unless you know exactly what you are doing!
apt
0 upgraded, 1 newly installed, 47 to remove and 0 not upgraded.
51 not fully installed or removed.
Need to get 0B/3611kB of archives.
After this operation, 23.2MB disk space will be freed.
You are about to do something potentially harmful.
To continue type in the phrase 'Yes, do as I say!'
==========

Am I need to continue? Last time after "yes, do as I say" I started from fresh install :) That's why I decided to re-check with Guru once again. Thanks.


Top
 Profile  
 
PostPosted: Sun Feb 26, 2012 3:16 pm 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 4546
Hm. Do you mean me with Guru? I have second thoughts.


Try if 'apt-get install --no-list-cleanup mc' behaves less scary.


Top
 Profile  
 
PostPosted: Sun Feb 26, 2012 4:12 pm 
Offline

Joined: Thu Feb 23, 2012 9:16 am
Posts: 12
Okay, I did it per your advice. Same question appeared and I agreed. MC finally installed and my NAS still alive :)

After that I tried to install transmission per your instruction. System showed error after ./configure command

configure: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.
See `config.log' for more details
root@Lomega:/usr/local/transmission-2.50# make
make: *** No targets specified and no makefile found. Stop.
root@Lomega:/usr/local/transmission-2.50# su
root@Lomega:/usr/local/transmission-2.50# make install-strip
make: *** No rule to make target `install-strip'. Stop.

Any ideas? :)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 23 posts ]  Go to page 1, 2  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group