General NAS-Central Forums

Welcome to the NAS community
It is currently Thu Nov 23, 2017 8:28 pm

All times are UTC




Post new topic Reply to topic  [ 9 posts ] 
Author Message
 Post subject: Boot from another disk
PostPosted: Tue Jul 21, 2009 2:12 pm 
Offline

Joined: Sun Jul 19, 2009 11:39 pm
Posts: 16
It seems that the hacks without disassembly don't work for this device.


So I will have to disassemble.

The reason is:
I want to spin-down the disk automatically.


This is only possible, if the system is on another media (e.g. microdrive on CFII)


My questions:
Is it possible to boot from a CFII (usb card reader/writer) ?
Is it possible to spin down the hard disk?


Top
 Profile  
 
PostPosted: Wed Sep 23, 2009 6:29 pm 
Offline

Joined: Thu May 08, 2008 11:23 am
Posts: 112
Location: near Toulouse, France
gerdich wrote:
Is it possible to boot from a CFII (usb card reader/writer) ?

AFAIK the stock U-Boot does not support this (and neither does Albert's (aaribaud) modified version).
However you can boot via the network.
Obviously to do this you must have access to U-Boot (via a serial console).

gerdich wrote:
Is it possible to spin down the hard disk?

I have never done this but I am pretty sure it is possible (with hdparm IIRC).
However it may depend on the model of your hard disk.
Note that repeatedly spinning down and up 3.5" disks may wear them out.
2.5" disks are generally better for this.

Cheers,
Chris


Top
 Profile  
 
PostPosted: Wed Sep 23, 2009 11:49 pm 
Offline

Joined: Sun Jul 19, 2009 11:39 pm
Posts: 16
Code:
I have never done this but I am pretty sure it is possible (with hdparm IIRC)


I have already done it on another box (AsusWl500gp mipsel: My WD 250GB harddisk is down most of the time and starts only when it is accessed. It goes down after 20 minutes of rest time.)
And I have done it with the same optware packages that are installed on my edmin now (but in a different architecture armel).
I've even got a script to spin down automatically.

That's not the problem.


The problem is:
The system is on the hard disk. If I spin down the hard disk the system will crash. And even if it wouldn't crash, it would restart quickly because the system accesses to the hard disk very often.

So I want to put the system off of the harddisk (on a usb e.g.) and then spin down the hard disk.




But my real problem is:
The wake on lan doesn't work. I would like to wake up my edmini.

Perhaps there is another solution: A sleep mode, in which the system is unmounted but still listening to the network for a magic package?


Top
 Profile  
 
PostPosted: Thu Sep 24, 2009 4:26 am 
Offline

Joined: Thu May 08, 2008 11:23 am
Posts: 112
Location: near Toulouse, France
gerdich wrote:
But my real problem is:
The wake on lan doesn't work. I would like to wake up my edmini.

I have never tried WOL but I think Albert got it to work.
In a private mail he wrote:
aaribaud wrote:
When the power button is pressed (or the ED Mini is WOL'ed), U-boot resumes execution and boots into the kernel etc.

I don't know whether this was with the stock LaCie U-Boot or with his modified U-Boot.


Top
 Profile  
 
PostPosted: Thu Sep 24, 2009 11:58 am 
Offline

Joined: Sun Jul 19, 2009 11:39 pm
Posts: 16
Quote:
I have never tried WOL but I think Albert got it to work.


Can you give me more information? That would be a solution for all my problems!!!
Is it necessary to flash?
Can a copy of the flash memory be mounted on the file system to be "committed" ?

ethtool writes
Quote:
LacieData /root # ethtool egiga0
Settings for egiga0:
Supported ports: [ TP ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: Not reported
Advertised auto-negotiation: No
Speed: 100Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 8
Transceiver: internal
Auto-negotiation: on
Current message level: 0x00000000 (0)
Link detected: yes


I don't see any option:
Quote:

Supports Wake-on: g
Wake-on: d


Top
 Profile  
 
PostPosted: Thu Sep 24, 2009 7:53 pm 
Offline

Joined: Thu May 08, 2008 11:23 am
Posts: 112
Location: near Toulouse, France
gerdich wrote:
rosbif wrote:
I have never tried WOL but I think Albert got it to work.

Can you give me more information? That would be a solution for all my problems!!!

Sorry, I don't know any more.
Albert? Anyone?
Otherwise you could try looking in the LaCie U-Boot source code for information ;)

gerdich wrote:
ethtool writes
Quote:
LacieData /root # ethtool egiga0
...

I don't see any option:

No, AFAIK it is not Linux which responds to the WOL but U-Boot.
AIUI WOL is like pressing the power button (which is also handled by U-Boot).


Top
 Profile  
 
 Post subject: Not uboot but hardware
PostPosted: Fri Sep 25, 2009 6:10 pm 
Offline

Joined: Sun Jul 19, 2009 11:39 pm
Posts: 16
I thought that WOL was first of all a problem of the hardware.

ethtool lists the hardware options available/enabled of the ethernet card.

WOL support is not available.

Perhaps uboot can enable this hardware option.

In any case ethtools seems to me the right application to find relevant information.


Top
 Profile  
 
PostPosted: Sat Sep 26, 2009 3:13 pm 
Offline

Joined: Thu May 08, 2008 11:23 am
Posts: 112
Location: near Toulouse, France
gerdich wrote:
I thought that WOL was first of all a problem of the hardware.

You may well be right.
However what Albert mentioned may not be "real" hardware WOL. (I'm afraid I am only guessing :( )

When the EDmini v2 is "powered off", it is not really off at all :( (unless you unplug the power adapter).
In fact a "power off" is actually the start of a reboot.
U-Boot takes control and reads a reboot/power off flag from an I2C EEPROM.
If this flag says "power off" U-Boot sits there waiting for you to press the power button before it continues rebooting.
U-Boot might also continue rebooting if it receives a WOL type packet (or possibly a LUMP packet).
But as I said I'm only guessing here and I am afraid that I cannot help you any further on this point :(


Top
 Profile  
 
PostPosted: Sat Sep 26, 2009 9:24 pm 
Offline

Joined: Sun Jul 19, 2009 11:39 pm
Posts: 16
Quote:
U-Boot might also continue rebooting if it receives a WOL type packet


That's what WOL should do. But it doesn't and that's my big problem.
If Albert has solved this problem: Please help me!!!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC


Who is online

Users browsing this forum: Bing [Bot] and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group