EDMini not booting any more: glibc/Kernel too old issue

Ethernet disk mini v2
Post Reply
aquila
Posts: 5
Joined: Sat Feb 14, 2009 11:49 am

EDMini not booting any more: glibc/Kernel too old issue

Post by aquila » Sat Feb 14, 2009 12:00 pm

Hello all,

First of all thanks to have created this usefull forum for NAS equipement.

I have hacked my LaCie ED mini V2 500 Gb using the tutorial from Jebimony:
http://jebimony.com/blog/content/add-ss ... -edmini-v2

This works well and SSH connection was ok.

I plan then to install HTTPhost (in order to create SSH over HTTP tunnel connection... from outside) and I got sources of HTTPhost that I needed to compile on my EDMini so I saw that some packages were missing and I tried to install them, when installing glibc-2.6.1.tbz2 from:
http://downloads.buffalo.nas-central.or ... x-gnueabi/

After this I got FATAL: Kernel too old and I was not able to execute any command.
I rebooted my LaCie and I was not able to connect to it (of course...)

My question is: how to recover my lacie?

I saw on Internet that chroot from another distribution could solve this but what can be the step do perform?
1 - From a linux OS connect my hard drive with an SATA-USB adapter.
2 - ?

Thanks by advance for your help.

Regards,

giarrettu
Posts: 16
Joined: Tue Jun 17, 2008 8:34 am

Re: EDMini not booting any more: glibc/Kernel too old issue

Post by giarrettu » Sat Feb 14, 2009 2:45 pm

Hello,

if your EDMINI V2 doesn't start up anymore you have to open it and to put your HD on another linux box (I have used " SATA to USB" adapater with my notebook). if it is necessary you can to restore the the partitions 6,7,8 "/dev/sda6 /dev/sda7/dev/sda8"

you can dawnload the original from here

http://gpl.nas-central.org/LACIE/ethern ... on_images/

You need to decompress them with (sda6.baz2 is the kernel, I think it is not necessary to restore it)

bzip2 -d sda6.bz2
bzip2 -d sda7.bz2
bzip2 -d sda8.bz2

then restore the partitions with

WARNING: pay attention to choose the correct partition !!!!!!

dd if=sda6 of=/dev/sdb6
dd if=sda7 of=/dev/sdb7
dd if=sda8 of=/dev/sdb8

hope this help

Giarrettu

aquila
Posts: 5
Joined: Sat Feb 14, 2009 11:49 am

Re: EDMini not booting any more: glibc/Kernel too old issue

Post by aquila » Sun Feb 22, 2009 1:07 pm

Many thanks for your reply.

I had restored the 3 partitions but unfortunately I can not access it.
After the restore I reboot it and try to use the LaCie IP Configurator to set an IP address but no success to join the NAS.

As well when I try to swithoff the NAS by keeping the button pushed during more than 10 sec nothing happens.

Any new idea to investiguate on this issue?

Regards,

giarrettu
Posts: 16
Joined: Tue Jun 17, 2008 8:34 am

Re: EDMini not booting any more: glibc/Kernel too old issue

Post by giarrettu » Mon Feb 23, 2009 1:48 pm

aquila wrote:Many thanks for your reply.

I had restored the 3 partitions but unfortunately I can not access it.
After the restore I reboot it and try to use the LaCie IP Configurator to set an IP address but no success to join the NAS.

As well when I try to swithoff the NAS by keeping the button pushed during more than 10 sec nothing happens.

Any new idea to investiguate on this issue?

Regards,
maybe the problem is the partion 9... unfortunately I haven't that partition anymore.

aquila
Posts: 5
Joined: Sat Feb 14, 2009 11:49 am

Re: EDMini not booting any more: glibc/Kernel too old issue

Post by aquila » Wed Feb 25, 2009 10:46 pm

For what is dedicated partition 9?
And does anyone has it in possesion?

Thanks by advance,

aquila
Posts: 5
Joined: Sat Feb 14, 2009 11:49 am

Re: EDMini not booting any more: glibc/Kernel too old issue

Post by aquila » Sun Apr 26, 2009 5:09 pm

Finally I find out that I just needed to format partition 9 using:

# mke2fs -j /dev/sda9

So for those who want to restore their Edmini v2:

Download the 3 archives and unzip them:
http://gpl.nas-central.org/LACIE/ethern ... on_images/

# bzip2 -d sda6.bz2
# bzip2 -d sda7.bz2
# bzip2 -d sda8.bz2

Then restore each partition:

# dd if=sda6 of=/dev/sda6
# dd if=sda7 of=/dev/sda7
# dd if=sda8 of=/dev/sda8

Then format partition 9:
# mke2fs -j /dev/sda9

Start you NAS it should boot now...

amid
Posts: 3
Joined: Fri Nov 05, 2010 8:53 am

Re: EDMini not booting any more: glibc/Kernel too old issue

Post by amid » Fri Nov 05, 2010 9:09 am

Hi guys,

I hope someone is still using his edmini v2 and can help me out.
I have a edmini v2 750GB. Unfortunatey the disk was taken outside and formatted for windows. So all the data and partitions were lost.

I've done all steps as described in this thread and the ones below using ubuntu:
viewtopic.php?f=151&t=176
and
viewtopic.php?f=146&t=131&start=15

Now edmini boots up fine, I can access the administration page, setup shares and users etc. I can see it in the network.
But it seems like edmini does not 'see' the largest sda2 partition where I assume all the data must be stored. If I check the 'Disk' tab in the administration web page - it does not show any disks at all!
Another weird thing is that I can upload data to the created shares (but no more that around 600mb) after that system says that there is no space left.
If I upload a small file - I can't read it back - system says I do not have permissions???

I feel like edmini tries to store the data in the wrong (small/system) partition (sda1?) and the large one (sda2) it just does not see.

What can be the cause for such behavior?

Any help will be appreciated. Thanks in advance.

amid
Posts: 3
Joined: Fri Nov 05, 2010 8:53 am

Re: EDMini not booting any more: glibc/Kernel too old issue

Post by amid » Fri Nov 05, 2010 11:43 am

It seems like I have fixed the issue myself.

By analyzing the system log I have found that edmini tried to load sda2 as ext3 or ext2 formatted. But never tries XFS.
So I have formatted sda2 using mke2fs -j /dev/sda2 command in ubuntu. After that the disk appeared under the disks tab and everything went fine.

P.S.
One strange thing though. When I have formatted the disk afterwards from within the administration utility it shows now that the disk is in XFS format. And that is strange cause before that I have tried formatting in as XFS from ubuntu and that did not work out.

Anyway thank all of you for such a nice forum that helped me ressurect otherwise lost NAS.

paso1971
Posts: 1
Joined: Fri Nov 12, 2010 4:28 pm

Re: EDMini not booting any more: glibc/Kernel too old issue

Post by paso1971 » Sat Nov 13, 2010 2:43 pm

hello everybody,
I write from italy, sorry for my english.
I have a edmini v2 oviously, after some trouble I had to restore the partitions (windows xp sp3/partition magic 8 and ghost) and start well and I can go into administration, but I don't see the disk inside the tab disk. there's anything. I've tryed to format the data partition in ntfs, fat ext2 ext3 and after every format I restore the edmini to fabric status. the same anything.
I never used linux, so I ask if there is a way to restore without enter by linux.
If not, can someone saint write very deep all the passage i have to do?
thanks for any kind of help.
Paso

amid
Posts: 3
Joined: Fri Nov 05, 2010 8:53 am

Re: EDMini not booting any more: glibc/Kernel too old issue

Post by amid » Thu Nov 18, 2010 10:00 am

Hi Paso.

I will try to guide you through the process. This was my first time usage of the unix based OS too - and I found it to be quite easy. So I believe you will not have any problems with that:
1) Download Ubuntu from http://www.ubuntu.com/desktop/get-ubuntu/download and burn it to CD following steps desribed in there
2) Disconnected all you windows based drives from PC (just to be safe). Connect just one for lacie.
2) Boot from the created ubuntu live CD without installing it.
3) Using fdisk command partition your lacie drive. Follow the steps described in the following topic: viewtopic.php?f=151&t=176
4) Follow the steps suggested by aquila in this topic just above my first message.
5) You may need to format sda2 partition like I have done as the last step (see my message above).

Thats it. Hope it helps.

Post Reply