HELP : My EBD 1T became an ED mini V2 without raid support

TOTOleCabo
Posts: 2
Joined: Wed Aug 04, 2010 8:37 pm

HELP : My EBD 1T became an ED mini V2 without raid support

Post by TOTOleCabo » Wed Aug 04, 2010 8:47 pm

Hello,

After some problems on my EDB, I decide to restore the system directly with this partitions disk images : http://gpl.nas-central.org/LACIE/ethern ... ion_images

But since this recover my EDB was view as ED mini V2 Bios 1.0.6

I cannot use upgrade firmware system to convert it into the good version.

Where can i found the good partitions for EBD ? or how to convert my false ED mini V2 into a real EBD 1Towith raid 1 ?


Regards

Thomas

kbmorris
Posts: 1
Joined: Sun Aug 22, 2010 12:44 am

Re: HELP : My EBD 1T became an ED mini V2 without raid suppo

Post by kbmorris » Sun Aug 22, 2010 2:07 am

Thomas,

I'd love to help you out. I just imaged my drive before applying the SSH hack to my Lacie EBD. I'll see about posting these in the files area.

~Kevin

IAmATeaf
Posts: 16
Joined: Sun Mar 06, 2011 9:45 pm

Re: HELP : My EBD 1T became an ED mini V2 without raid suppo

Post by IAmATeaf » Mon Mar 07, 2011 3:48 pm

I've had exactly the same result. Copied the partitions onto my EDB and it only sees the space on sda2. I've had a look around and to me, not an expert though, it looks like the problem may be related to the fact that mdadm isn't being used when the lacie starts up.

Also fstab mounts sda2 when it should really be mounting md0.

I've managed to track somebody who is willing to dump off sda6, sda7 and sda8 from a EBD, could somebody confirm that they are the only partitions I'll need? Also how do I upload the dumps assuming I actually get them?

Mijzelf
Posts: 6251
Joined: Mon Jun 16, 2008 10:45 am

Re: HELP : My EBD 1T became an ED mini V2 without raid suppo

Post by Mijzelf » Mon Mar 07, 2011 7:15 pm

IAmATeaf wrote:I've managed to track somebody who is willing to dump off sda6, sda7 and sda8 from a EBD, could somebody confirm that they are the only partitions I'll need?
Unless the partitions of the the ebd are totally different from the edmini, these partitions are sufficient indeed.
Also how do I upload the dumps assuming I actually get them?
You can ask for an upload account, or you can upload them to my private ftp server (PM me for details) then I'll upload them to my upload area.

IAmATeaf
Posts: 16
Joined: Sun Mar 06, 2011 9:45 pm

Re: HELP : My EBD 1T became an ED mini V2 without raid suppo

Post by IAmATeaf » Mon Mar 07, 2011 8:04 pm

OK thanks, as and when I get the dumps I'll try and get them uploaded.

I have a fileserve account, could I put them there and provide links?

Mijzelf
Posts: 6251
Joined: Mon Jun 16, 2008 10:45 am

Re: HELP : My EBD 1T became an ED mini V2 without raid suppo

Post by Mijzelf » Tue Mar 08, 2011 1:57 pm

Sure. If I can download it, I'll put it on the Nas-Central server.

IAmATeaf
Posts: 16
Joined: Sun Mar 06, 2011 9:45 pm

Re: HELP : My EBD 1T became an ED mini V2 without raid suppo

Post by IAmATeaf » Thu Mar 10, 2011 12:42 pm

Right, sorry for the delay but I had to guide somebody over messenger on how to do dump the partitions, have not had the chance yet to try them out but will tonight and report back.

The dumps were taken from a Lacie Ethernet BigDisk 1Tb which has 2 500gb drives set up in linear mode, as far as I know.

You can get the zip from here www.fileserve.com/file/xJ4URBP

Zip contains text file showing fdisk -l of the boot HDD and sda6, sda7 and sda8 partition dumps.

As I said I've not had the chance to try them out so can't report them as working but will hopefully post an update later on tonight.

IAmATeaf
Posts: 16
Joined: Sun Mar 06, 2011 9:45 pm

Re: HELP : My EBD 1T became an ED mini V2 without raid suppo

Post by IAmATeaf » Thu Mar 10, 2011 8:07 pm

Right I've dumped the partitions onto my drive and although the drive is now reported as a Big Disk whereas before it was reporting itself as an Ethernet Mini.

But I still get nothing being shown under the Disks tab, so no size or type and there is no format button either.

So it looks like it doesn't like the /dev/md0 partition I created when booted up off ubuntu.

Anybody have any words of wisdom as to how I need to create the partitions so that the firmware correctly picks up the disk?

chross
Posts: 1
Joined: Tue Apr 12, 2011 2:19 pm

Re: HELP : My EBD 1T became an ED mini V2 without raid suppo

Post by chross » Tue Apr 12, 2011 2:24 pm

So I can convert my broken (harddrives failed) Ethernet Big Disk into a EDMini v2 with the above mentioned images?
Because that is what I need. I have one other SATA spare and want to use the Ethernet Big Disk as a single drive device now. The EDmini v2 is single drive by default (?) so I won't need any changes (concerning RAID, which I want to avoid at all costs).

Is that right?

Cheers,
chross

jjr74
Posts: 19
Joined: Sun Jul 20, 2008 8:46 am

Re: HELP : My EBD 1T became an ED mini V2 without raid suppo

Post by jjr74 » Sun Nov 11, 2012 9:24 pm

Hi,

I am having the same issue, trying to repair an EBD (v1).
Used the partition images from the ED Mini and managed to have it working albeit with only one drive recognised.

The above link to the partitions of the EBD do not seem to work anymore.
Would anyone be kind enough to point to a source for the EBT partitions ?
Or alternatively tell if there is a possibility to tweak the setting to have the second disk recognised ?

Thanks in advance


jjr74
Posts: 19
Joined: Sun Jul 20, 2008 8:46 am

Re: HELP : My EBD 1T became an ED mini V2 without raid suppo

Post by jjr74 » Sun Nov 11, 2012 11:42 pm

Many thanks for the images.

I rebuild the EBD with those images and using the procedure defined for the ED Mini : having the exact same partition structure, I assumed the only difference would be the images content.
It restored the EBD and it is now able to boot and shows up correctly in IP configurator as EBD.

However the data partition do not seem to be properly recognised.
It shows like there would be no disk ...

What could I possibly miss ?
Anything to do to those partition apart from formatting them as xfs ?

Thanks in advance

jjr74
Posts: 19
Joined: Sun Jul 20, 2008 8:46 am

Re: HELP : My EBD 1T became an ED mini V2 without raid suppo

Post by jjr74 » Mon Nov 12, 2012 12:08 am

I re read a few guides on the EBD and mainly the "Ethernet Big Disk:Data recovery"
I had assumed that both disks should be prepared identical but now I am not sure ...
Or is there something to do in terms of raid configuration ?

Would it be necessary to create the raid on a linux box and then install it back on the Lacie copying the UUID from the Linux box to the Lacie ?

Thanks in advance

Mijzelf
Posts: 6251
Joined: Mon Jun 16, 2008 10:45 am

Re: HELP : My EBD 1T became an ED mini V2 without raid suppo

Post by Mijzelf » Mon Nov 12, 2012 8:28 am

The EBD has a JBOD array, consisting of partition 2 of the OS disk, and the whole 2nd disk. (The 2nd disk is not even partitioned).

I don't know if it will work if you just create this array externally. The 2Big2 has a construction which prevents this to work. But, assuming this construction is not pure evil, I think it's to know which disk is the disk when one dies and is exchanged. On the EBD this is no issue.

I think that when you create the array manually, you should use the '--metadata=0.90' flag on mdadm. It is needed for the 2Big2.

jjr74
Posts: 19
Joined: Sun Jul 20, 2008 8:46 am

Re: HELP : My EBD 1T became an ED mini V2 without raid suppo

Post by jjr74 » Mon Nov 12, 2012 12:26 pm

Many thanks again for the prompt answer.
I starting to get a sense of hope that the solution may be at hand !

This may also mean that it is actually not necessary to have 2 same size disks in the EBD. Or not ?
That would actually be good to be able to recycle old drives !

I will try creating the array externally and then moving it in (and adjusting the mdadm.conf on the 130Mo partition = /dev/sda8)
Let's see what happens

Post Reply