[?] 2Big Network, partition size

allenpan
Posts: 18
Joined: Sun Oct 28, 2012 1:31 am

Re: [?] 2Big Network, partition size

Post by allenpan » Sun Nov 04, 2012 7:29 pm

hummm, when the NAS is not connected i have 9 active IP, with NAS connected, i still go "9" Active IP... is there other way to find out?

allenpan
Posts: 18
Joined: Sun Oct 28, 2012 1:31 am

Re: [?] 2Big Network, partition size

Post by allenpan » Sun Nov 04, 2012 7:30 pm

i dont think it boot properly, i move the NAS and a laptop to another isolated network, and my DHCP table only shows 2 active IP,

192.168.1.1 <- router
192.168.1.111 <- laptop

is there a way i can realtime monitor the boot on NAS? i read there is serial port on it right? or is there other easier way?

if is serial, i am assuming RS232, 9600, 0, 0, 0, ?

Mijzelf
Posts: 6196
Joined: Mon Jun 16, 2008 10:45 am

Re: [?] 2Big Network, partition size

Post by Mijzelf » Sun Nov 04, 2012 8:53 pm

Have a look at clunc.

And no, it's not rs232, but 3.3V TTL, 115200-N-8-1 (assuming the 2Big isn't that different from other Lacie's)

allenpan
Posts: 18
Joined: Sun Oct 28, 2012 1:31 am

Re: [?] 2Big Network, partition size

Post by allenpan » Mon Nov 05, 2012 4:11 pm


__ __ _ _
| \/ | __ _ _ ____ _____| | |
| |\/| |/ _` | '__\ \ / / _ \ | |
| | | | (_| | | \ V / __/ | |
|_| |_|\__,_|_| \_/ \___|_|_|
_ _ ____ _
| | | | | __ ) ___ ___ | |_
| | | |___| _ \ / _ \ / _ \| __|
| |_| |___| |_) | (_) | (_) | |_
\___/ |____/ \___/ \___/ \__| ** LOADER **
** MARVELL BOARD: DB-88F5182-EDmini-V2 LE

U-Boot 1.1.1 (Jun 15 2007 - 08:56:23) Marvell version: 1.7.3 - LaCie version: 1.4.alpha_3

DRAM CS[0] base 0x00000000 size 64MB
DRAM Total size 64MB
Flash: flashStructGet manu 0xff id 0xff
[0kB@fff80000] ## Unknown FLASH at fff80000: Size = 0x00000000 = 0 MB
Flash: 0 kB
Addresses 20M - 0M are saved for the U-Boot usage.
Mem malloc Initialization (20M - 16M): Done
*** Warning - bad CRC, using default environment


Soc: MV88F5182 Rev 2
CPU: ARM926 (Rev 0) running @ 400Mhz
SysClock = 200Mhz , TClock = 166Mhz


USB 0: host mode
USB 1: host mode
PCI 0: PCI Express Root Complex Interface
PCI 1: Conventional PCI, speed = 33000000
Net: egiga0 [PRIME]
Hit any key to stop autoboot: 0
egiga0 no link
Waiting for LUMP (2)
Using egiga0 device
no lump receive; continuing

Reset IDE:
Marvell Serial ATA Adapter
wait Sata0 & Sata1 power-up

SATA power is present on SATA 0 & 1
Intergrated Sata device found
Device 0: OK
Model: ST3750640NS Firm: 3.BJG Ser#: 3QD0CX0Q
Type: Hard Disk
Supports 48-bit addressing
Capacity: 715404.8 MB = 698.6 GB (1465149168 x 512)
Device 1: OK
Model: ST3750528AS Firm: CC38 Ser#: 9VP9Y6YA
Type: Hard Disk
Supports 48-bit addressing
Capacity: 715404.8 MB = 698.6 GB (1465149168 x 512)


Loading from IDE device 1, partition 6: Name: hdb6
Type: U-Boot
Image Name: Linux-2.6.22.7
Created: 2009-04-09 14:07:48 UTC
Image Type: ARM Linux Kernel Image (uncompressed)
Data Size: 1780216 Bytes = 1.7 MB
Load Address: 00008000
Entry Point: 00008000
## Booting image at 00400000 ...
Image Name: Linux-2.6.22.7
Created: 2009-04-09 14:07:48 UTC
Image Type: ARM Linux Kernel Image (uncompressed)
Data Size: 1780216 Bytes = 1.7 MB
Load Address: 00008000
Entry Point: 00008000
Verifying Checksum ... OK
OK

Starting kernel ...

Uncompressing Linux......................................................................................................... done, booting the kernel.
ok, i got the TTL working, but after it boot, it just stop @ booting the kernel....

Mijzelf
Posts: 6196
Joined: Mon Jun 16, 2008 10:45 am

Re: [?] 2Big Network, partition size

Post by Mijzelf » Mon Nov 05, 2012 6:24 pm

Uhm. Normally I would say the kernel is incompatible, or misconfigured. But now... Your u-boot states it has a Soc: MV88F5182 Rev 2. I did a grep on the kernel:

Code: Select all

3$ strings kernel  | grep 88F
MV88F
88F5181 A0
88F5181 A1
88F5181 B0
88F5181 B1
88F5281 A0
88F5281 B0
88F5281 C0
88F5281 C1
88F5281 D0
88F5082 A2
88F5182 A0
88F5182 A1
88F5182 A2
88F5181L A0
88F5181L A1
88F1281 A0
88F6082 A0
88F6082L A0
88F6082 A1
DB-88F5182-LaCie
So it seems to me this SoC is supported. The kernel cannot be corrupted. U-boot checks the checksum, and it decompressed well. Then remains either a hardware problem (the kernel could be decompressed to bad ram), or the kernel doesn't output to the serial port.
Have you tried your other 2Big? Have you tried clunc?

allenpan
Posts: 18
Joined: Sun Oct 28, 2012 1:31 am

Re: [?] 2Big Network, partition size

Post by allenpan » Mon Nov 05, 2012 6:29 pm

is there a way to check if ram is bad?

also, do you mean my image is good? and might be hardware issue?

Mijzelf
Posts: 6196
Joined: Mon Jun 16, 2008 10:45 am

Re: [?] 2Big Network, partition size

Post by Mijzelf » Mon Nov 05, 2012 6:46 pm

u-boot might have an option to check the memory. Try <enter> as soon as the Marvell logo shows up.
allenpan wrote:also, do you mean my image is good? and might be hardware issue?
U-boot doesn't complain about the image checksum. So I think you can count on the image being undamaged. So yes, a hardware issue comes in mind.

allenpan
Posts: 18
Joined: Sun Oct 28, 2012 1:31 am

Re: [?] 2Big Network, partition size

Post by allenpan » Tue Nov 06, 2012 12:14 am

hummm, another question, i follows the wiki page for 2Big Network 2, is that why?, is there anything i need to add to the steps?

i follows the:

http://lacie.nas-central.org/wiki/Categ ... _Network_2

also i put those 2 HDD to another 2Big Network 1, and same result, however, i jsut realize that the other 2Big Network is 2TB version, instead of 1 TB version, and the warranty stickers on the HDD still intact, so i might ship it for RMA for them to restore it...

also i am stupid enough to remove the 4 screws to attached the TTL cable....and the stickers on the screws (not the one on the HDD, but the one on the case) is damaged, do u think they will still RMA it?

Mijzelf
Posts: 6196
Joined: Mon Jun 16, 2008 10:45 am

Re: [?] 2Big Network, partition size

Post by Mijzelf » Tue Nov 06, 2012 8:10 am

The firmware install way for the 2Big and 2Big2 are equal, only the partition images differ. (At least the 2Big2 has a different kernel, it has a Kirkwood SoC, and the 2Big an Orion) You was using the 2Big images, wasn't you?
allenpan wrote: i jsut realize that the other 2Big Network is 2TB version, instead of 1 TB version
That doesn't matter. The only difference is the disks.
allenpan wrote:do u think they will still RMA it?
I really don't know. Are you sure the nas is still under warranty? AFAIK Lacie doesn't sell 2Big's for 2 or 3 years anymore.

allenpan
Posts: 18
Joined: Sun Oct 28, 2012 1:31 am

Re: [?] 2Big Network, partition size

Post by allenpan » Wed Nov 21, 2012 6:14 pm

hummm, ok, i jsut dig up my another 2TB version of 2Big, and restart the whole process... and following the "http://lacie.nas-central.org/wiki/Insta ... s_(2Big_2)" step by step..

however, i ran into another problem during creation process, after made the 1st disk and pug in the 2nd, when i do "mdadm --create /dev/md0 --level=1 --raid-devices=2 /dev/sdb5 missing --metadata=0.90"

it tells me md0 already created...

so i reboot it and the md0 is gone, so i can redo the process...(the ubuntu is off usb disk.), does it effecting anything? do i need to create both disk in 1 session without rebooting?

Mijzelf
Posts: 6196
Joined: Mon Jun 16, 2008 10:45 am

Re: [?] 2Big Network, partition size

Post by Mijzelf » Wed Nov 21, 2012 6:47 pm

allenpan wrote:hummm, ok, i jsut dig up my another 2TB version of 2Big, and restart the whole process... and following the "http://lacie.nas-central.org/wiki/Insta ... s_(2Big_2)" step by step..
Can't you just plug over the disks from the 'dead one'?
do i need to create both disk in 1 session without rebooting?
No, that doesn't matter.

allenpan
Posts: 18
Joined: Sun Oct 28, 2012 1:31 am

Re: [?] 2Big Network, partition size

Post by allenpan » Wed Nov 21, 2012 6:59 pm

well, the 2TB version has 2x 1TB, and those 1TB are identical and pass all the test, while the other one is 750GB x2 but both 750GB is different venders...i am trying to elimated possiblity of problems.

allenpan
Posts: 18
Joined: Sun Oct 28, 2012 1:31 am

Re: [?] 2Big Network, partition size

Post by allenpan » Wed Nov 28, 2012 6:13 pm

blah same result,

it stop @ booting the kernal,

if it is successful will it display anything else? or that is it?

ok, i intrupted the boot and type "dhcp" and it got an ip, and trying to load a image "3D0100A.ing" why is that?

is there other way i can restore the image using this console?... tftp? i am very new to this...

Mijzelf
Posts: 6196
Joined: Mon Jun 16, 2008 10:45 am

Re: [?] 2Big Network, partition size

Post by Mijzelf » Thu Nov 29, 2012 10:21 am

allenpan wrote:if it is successful will it display anything else?
Normally yes. You should see the kernel bootlog. Here you can see a bootlog of the 2Big2. But as I said before, there is no law which compels the kernel to log to the serial port. The messages you see are from the bootloader, and from the zImage 'piggyback', which decompresses the kernel. But the kernel itself seems silent. (Or doesn't boot at all).
On the other hand, the smaller cousin of the 2Big (the EdminiV2) boots verbosely. I wouldn't know why Lacie changed that.

BTW, where did you connect your serial port? I'm only aware of one set of pins, but the Orion SoC has two ports. If you managed to use 'the other one', I can imaging uboot uses both, while the kernel uses just one.

You could try the edminiV2 kernel (sda6). It won't be able to boot the 2Big, I think, at least not as 2Big, but I'm sure that kernel is verbose, and should show something, before ending in a kernel panic.

A third option is that the commandline has to specify which serial port to use for logging, and doesn't do so for some reason. Have a look in the uboot settings. Try 'printenv'. Somewhere the commandline is specified, it contains something like 'root=/dev/sda7', and you could try to add 'console=ttyS0,115200n8', if it isn't there already. After that boot with 'bootd'. You cannot just reset the box, as the environment isn't (and will not be) saved in flash:

Code: Select all

*** Warning - bad CRC, using default environment
ok, i intrupted the boot and type "dhcp" and it got an ip, and trying to load a image "3D0100A.ing" why is that?
Don't know. How do you know it's trying to load that image?
is there other way i can restore the image using this console?... tftp? i am very new to this...
Probably not. 'Restoring the image' involves writing to disk, and I don't think u-boot has that possibility. In your case connecting the disk to another system is easier anyway. But you are right, u-boot *can* have advanced ways to upload a kernel (or anything) using tftp or serial. Something like this. (BTW, in that example the kernel is flashed to nand. Do NOT try to do that, in the Lacie the nand only contains the bootloader. Overwriting that will kill the box forever)

allenpan
Posts: 18
Joined: Sun Oct 28, 2012 1:31 am

Re: [?] 2Big Network, partition size

Post by allenpan » Thu Nov 29, 2012 9:29 pm

thank you so much, please upload the serial pinout image for it, it will be great,

i am going to start all over again, i am going to completely null out the HDD, just incase.

Post Reply