General NAS-Central Forums

Welcome to the NAS community
It is currently Fri Sep 22, 2017 8:37 pm

All times are UTC




Post new topic Reply to topic  [ 45 posts ]  Go to page 1, 2, 3  Next
Author Message
 Post subject: Lost Original image
PostPosted: Tue May 19, 2009 9:42 am 
Offline

Joined: Tue May 19, 2009 9:40 am
Posts: 3
Hi, everyone have a original image of network space disk for restore the factory settings?

thank you

Ghido


Top
 Profile  
 
 Post subject: Re: Lost Original image
PostPosted: Tue May 19, 2009 12:21 pm 
Offline

Joined: Sun Apr 19, 2009 9:44 pm
Posts: 16
hi

if you give me command to do that, i can do it,
but i'm not expert in linux and i am no sure for commands.

belese


Top
 Profile  
 
 Post subject: Re: Lost Original image
PostPosted: Tue May 19, 2009 1:28 pm 
Offline

Joined: Tue May 19, 2009 9:40 am
Posts: 3
Hi, the procedure is a bit longe:
- open your nas and put the sata disk in a normal pc.
- boot the system with a live cd (knoppix ... )
- control the name of the disk and the partition with fdisk -l
- mount the share partition
mkdir /mnt/sdb2
mount -t xfs /dev/sdb2 /mnt/sdb2
- then copy the 3 partition with dd:
dd if=/dev/sdb7 of=/mnt/sdb2/openshare/sdb7.img
dd if=/dev/sdb8 of=/mnt/sdb2/openshare/sdb8.img
dd if=/dev/sdb9 of=/mnt/sdb2/openshare/sdb9.img
- put the image in a ftp server or share it with a p2p software

Thanks

Ghido


Top
 Profile  
 
 Post subject: Re: Lost Original image
PostPosted: Tue May 19, 2009 3:02 pm 
Offline

Joined: Sun Apr 19, 2009 9:44 pm
Posts: 16
ouh,

i don't want to open it. Theres is no way to do it with ssh?


Top
 Profile  
 
 Post subject: Re: Lost Original image
PostPosted: Tue May 19, 2009 4:23 pm 
Offline

Joined: Tue May 19, 2009 9:40 am
Posts: 3
i think it's possible to do this trought ssh.

can you try please?

Thanks

Ghido


Top
 Profile  
 
 Post subject: Re: Lost Original image
PostPosted: Wed May 20, 2009 11:16 am 
Offline

Joined: Sun Apr 19, 2009 9:44 pm
Posts: 16
Hello,

ok, i done it,

the partiition is a little bit modified, but if you do a reset you must have a clean config (except i remove S12Cleanconf from original partition to avoid lost my data if i have to do a restore)

if you have a ftp, you cans send me the adress, i'll upload the files

belese


Top
 Profile  
 
 Post subject: Re: Lost Original image
PostPosted: Mon Jul 06, 2009 5:00 pm 
Offline

Joined: Sat Jul 04, 2009 10:20 am
Posts: 11
This site has a lot of very interesting infos, thanks to whoever made this site and to contributors.
I'm newbie on linux, with the same problem as ghido

I've saved partitions 7, 8 and 9 before the HD totally crashed :?
I bought an identical HD, rebuild partition table with fdisk and restored partition 7, 8, and 9.
with no success: the nas won't start (predictable indeed :| maybe the boot sector is in sdb1?)

Code:
/dev/sdb1               1         125     1004031    5  Extended
/dev/sdb2             126      121601   975755970   83  Linux
/dev/sdb5               1          16      128457   82  Linux swap / Solaris
/dev/sdb6              17          17        8001   83  Linux
/dev/sdb7              18          18        8001   83  Linux
/dev/sdb8              19          40      176683+  83  Linux
/dev/sdb9              41         124      674698+  83  Linux
/dev/sdb10            125         125        8001   83  Linux


Is it really possible to restore partitions one by one with a partimage file (or similar) and get it worked?
If yes, has anyone the missing files?

Thanks to anyone will help
Bye
klooride


Top
 Profile  
 
 Post subject: Re: Lost Original image
PostPosted: Wed Jul 08, 2009 1:02 pm 
Offline

Joined: Sun Mar 08, 2009 10:19 pm
Posts: 27
Hi,
yep, you need all the partitions as a) you miss certain info (boot loader) and b) otherwise partition ID's are different (hda3 becomes hda1).

Furthermore: hda2 contains all your data. So that is the most important one to rescue. To be able to revive your nice black box, you need the other partitions of course. I think there was some article in the edmini section where someone described how it was done...

Good luck...
Theike


Top
 Profile  
 
 Post subject: Re: Lost Original image
PostPosted: Mon Jul 20, 2009 9:56 am 
Offline

Joined: Sat Jul 04, 2009 10:20 am
Posts: 11
Hi theike, thanks a lot for your reply. :)

So I need all patitions... in fact i tried restoring 7, 8 and 9 but with n o success.
Can you please provide me the missing ones (i saved images of partitions 7, 8 and 9); so what i miss are 2, 6 and 10. 5 is swap. I suppose 1 is made of 5 to 10 so it won't be necessary as a simgle image idf i have all the other ones. For the 2nd i obviously need only directory structure and not personal datas inside (of yours or of whoever will be so kind to provde it).

Following your hint, I found this discussion (Restore EDmini v2) here viewtopic.php?f=146&t=131&start=0 which led me to this http://gpl.nas-central.org/LACIE/ethern ... on_images/.
Even if I have a NSpace, I'll try restoring partition 6 from an EDmini, just in case... (even if I still miss nr. 10, that in EDmini doesn't exist, and nr. 2) and let you know.

Browsing that site, I saw that in http://gpl.nas-central.org/LACIE/ doesn't exists a section for Network Space images: i can provide the ones i have (saved before my HD crashed :( ), if needed. Let me know, admin!

Thanks for help!
klooride


Top
 Profile  
 
 Post subject: Re: Lost Original image
PostPosted: Fri Oct 09, 2009 7:12 am 
Offline

Joined: Fri Oct 09, 2009 6:17 am
Posts: 1
Hi guys,
I'm new! so need your help!! could someone explain how get original lost images of Lacie Network Space 1T ?

I've tryed to put the images of lacie ethernet mini V2 founded in download pages (sda6, sda7, sda8) but after boot, it spin down :cry: :cry:

coud someone give me the original images?

thankyou a lot

bye
luca


Top
 Profile  
 
 Post subject: Re: Lost Original image
PostPosted: Thu Jan 21, 2010 10:15 pm 
Offline

Joined: Sat Jul 11, 2009 10:20 pm
Posts: 61
Has anyone got images of the original drives available?

Perhaps they can go on this sites upload pages?
Or if not I can put them on my Rapidshare pages.

Let me know.

Thank you.

_________________
Dumb Windows user & 500gb Network Store owner.
I'm not compatible with Linux :(


Top
 Profile  
 
 Post subject: Re: Lost Original image
PostPosted: Sat Jan 23, 2010 3:24 pm 
Offline

Joined: Sat Jul 04, 2009 10:20 am
Posts: 11
Hi all,
I've finally brought my NetworkSpace back online... :) 8-)

I had as said saved 7, 8 and 9 and found image of the 6th partition needed for boot.
I used another drive: 1Gb, the original was 500 and has definitely crashed :(, so ti possible to use another drive with different capacity.
Basically I rebuilded the partition table accordingly to wiki pages.
With partimage I restored 7, 8 and 9, with dd the 6th. Then created openshare and myshare folders on the 2nd, put the HD back in the case not before having put the webshell. Then following the istruction finded in wiki and links mentioned I added ssh, rsync, nano, gzip.

I'm so happy I got it worked. :)
@Mattylad PM me and tell me how i can put images in your rapidshare pages

bye


Top
 Profile  
 
 Post subject: Re: Lost Original image
PostPosted: Sat Jan 23, 2010 5:13 pm 
Offline

Joined: Sat Jul 11, 2009 10:20 pm
Posts: 61
Excellent news.

How big are the files likely to be?

What about the server bits?
The FTP access, Twonky server etc - is this all restored?

So does anyone know if we can do this and put a 1TB drive in it?

Looking at the prices of 1TB bare drives, and comparing them to a Lacie 1TB USB external drive from Asda
for the couple of quid extra I might as well buy the Lacie USB drive, whip the drive out & put it in the network box :D

_________________
Dumb Windows user & 500gb Network Store owner.
I'm not compatible with Linux :(


Top
 Profile  
 
 Post subject: Re: Lost Original image
PostPosted: Sat Jan 23, 2010 8:57 pm 
Offline

Joined: Sat Jul 04, 2009 10:20 am
Posts: 11
mattylad wrote:
How big are the files likely to be?


the 3 files i own are about 40gb
you can find the other here: http://www.xup.in/dl,79571248/sda6_l...ace_500gb.bz2/

mattylad wrote:
What about the server bits?
The FTP access, Twonky server etc - is this all restored?


everything was restored. "was" because later I disabled twonky and mt-daapd.

And yes, you can do this using a 500Gb or 1Tb (i suppose 750 or 2Tb as well) changing only the parameters when you are partitioning the drive you use.
Only one thing i can't remember: partition nr. 2: mapped to /home directory. I haven't that image, adn what I did was simply recreate the 2 directory myshare and openshare. I can't remember if there was another directory such as EDMINI with other stuff (if there is, it isnt obviously strict necessary, since the nas works well anyway).

let me know
bye


Top
 Profile  
 
 Post subject: Re: Lost Original image
PostPosted: Sun Jan 24, 2010 8:31 am 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 6039
klooride wrote:
the 3 files i own are about 40gb

40GB! I think you did something inefficiently. The OS partitions of a LaCie are about 1GB uncompressed.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 45 posts ]  Go to page 1, 2, 3  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group