Possible to turn AFP on/off?

Post Reply
User avatar
PartisanEntity
Posts: 34
Joined: Sat Dec 27, 2008 11:12 pm
Location: Vienna, Austria
Contact:

Possible to turn AFP on/off?

Post by PartisanEntity » Sun Dec 13, 2009 4:20 pm

Hey all,

I can't seem to connect to the Network Space using the AFP protocol anymore which is causing some applications to freeze.

When I click on NetworkSpace AFP (under "Shared" in Finder), it attempts to connect and then I get an error the that the server is not responding.

SMB connections to the Network Space work, but this has not fixed the issue since for example iPhoto keeps crashing because the photos on the Network Space were referenced using the AFP protocol.

What can I do?

Can I turn reset the AFP feature somehow?
Web: cognitivecombine.com - OS's: Ubuntu 9.04 & Mac OSX 10.5

Daan
Posts: 98
Joined: Thu Feb 05, 2009 8:46 pm

Re: Possible to turn AFP on/off?

Post by Daan » Sun Dec 13, 2009 9:06 pm

If you have terminal access to the NAS, you can use the edmini.sh script in /usr/bin to disable any service, or do other things with it:

Code: Select all

# service:
#   ./edmini.sh service enable AFP|SMB|FTP|HTTP|BJR|MDS|MTD|ALL
#   ./edmini.sh service disable AFP|SMB|FTP|HTTP|BJR|MDS|MTD|ALL
#   ./edmini.sh service get AFP|SMB|FTP|HTTP|BJR|MDS|MTD|ALL
#   ./edmini.sh service start|stop|reload [ALL]
#       ./edmini.sh service refresh MDS
Check the actual code of the script to see what these commands do.

User avatar
PartisanEntity
Posts: 34
Joined: Sat Dec 27, 2008 11:12 pm
Location: Vienna, Austria
Contact:

Re: Possible to turn AFP on/off?

Post by PartisanEntity » Mon Dec 14, 2009 8:18 pm

I found the problem I am having, I also found a solution related to the Edmini. But I cannot find the folder /share as mentioned in the tutorial:
http://www.burchwords.com/archives/99

Any ideas?

I have tried stopping and starting the AFP service, but that didn't help. It seems I have to find the .AppleDB file and delete it.
Web: cognitivecombine.com - OS's: Ubuntu 9.04 & Mac OSX 10.5

Post Reply