General NAS-Central Forums

Welcome to the NAS community
It is currently Wed Sep 20, 2017 2:09 am

All times are UTC




Post new topic Reply to topic  [ 7 posts ] 
Author Message
PostPosted: Tue Nov 01, 2011 10:55 pm 
Offline

Joined: Tue Nov 01, 2011 10:45 pm
Posts: 8
Hi everyone,

firsrt of all thanks for a great forum, ive been learning linux,
from this forum ive managed to ssh into my Lacie NAS and very happy with it now!
ive had it sat for two years unused because it was so limited in its standard form.
Im very happy with the rsync guide i followed, now my server pc and laptop all rsync to the lacie.

My problem is with the sharing from windows, and i think its something to do with my folder permissions in linux.
Image

Ive been messing arround with my samba config too all day but that hasnt got it working either.
It currently looks like this:
Code:
[global]
    workgroup = WORKGROUP
    server string = LaCie Network Space
    security = user
    map to guest = bad user
    guest account = nobody
    log file = /var/log/samba/log.%m
    max log size = 50
    log level = 1
    socket options = TCP_NODELAY 
    interfaces = egiga0 
    dns proxy = no
    local master = yes
    os level = 20
    veto files = /lost+found/Network Trash Folder/TheVolumeSettingsFolder/Temporary Items/
    unix charset = UTF-8
    dos charset = CP437
    use sendfile = yes
    use mmap = yes
    Wide links = no
    unix extensions = no
    encrypt passwords = yes
    smb passwd file = /etc/samba/private/smbpasswd
    usershare owner only = false
    printcap name = /dev/null
    load printers = no
    printing = bsd
[myshare]
    path = /home/myshare
    valid users = admin,root
    write list = admin,root
    read only = no
    create mask = 0777
    directory mask = 0777
[openshare]
    path = /home/openshare
    guest ok = yes
    read only = no
    valid users = admin,root,nobody,guest
    write list = admin,root,nobody,guest
    writeable = yes
    vfs object = netatalk
[MP3]
    path = /home/share/twonkymedia/music
    guest ok = yes
    read only = no
    valid users = admin,root,nobody,guest
    write list = admin,root,nobody,guest
    writeable = yes
    vfs object = netatalk
[video]
    path = /home/share/twonkymedia/videos
    guest ok = yes
    read only = no
    writeable = yes
    vfs object = netatalk


If anyone can send me your folder permissions for your 'myshare' and your 'openshare', and possibly your samba config it would really help me, FTP doesnt work either.

thank you :)


Top
 Profile  
 
PostPosted: Wed Nov 02, 2011 7:22 pm 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 6039
Code:
NetworkSpace samba # cat smb.conf
[global]
    workgroup = Workgroup
    server string = LaCie Network Space
    security = user
    map to guest = bad user
    guest account = nobody
    log file = /var/log/samba/log.%m
    max log size = 50
    log level = 1
    socket options = TCP_NODELAY 
    interfaces = egiga0 
    dns proxy = no
    local master = yes
    os level = 20
    veto files = /lost+found/Network Trash Folder/TheVolumeSettingsFolder/Temporary Items/
    unix charset = UTF-8
    dos charset = CP437
    use sendfile = yes
    use mmap = yes
    Wide links = no
    unix extensions = no
[myshare]
    path = /home/myshare
    vfs object = netatalk
    browseable = yes
    force user = root
    force group = users
    create mode = 0777
    write list = admin
    valid users = admin,
[openshare]
    path = /home/openshare
    vfs object = netatalk
    browseable = yes
    force user = root
    force group = users
    create mode = 0777
    guest ok = yes
     writeable = yes
    valid users = admin,ftp,,nobody
    write list = admin,ftp,nobody


Top
 Profile  
 
PostPosted: Wed Nov 02, 2011 7:59 pm 
Offline

Joined: Tue Nov 01, 2011 10:45 pm
Posts: 8
thank you for posting this!
the only two differences i can see on yours for the openshares is:

browseable = yes
create mode = 0777

ill add that to mine and see if it helps


hope you dont mind me asking, but what are your permissions on your actual folders? 0777?
and are they owned by Root, group = users?

thanks :)


Top
 Profile  
 
PostPosted: Wed Nov 02, 2011 8:06 pm 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 6039
Code:
NetworkSpace /home # ls -l
drwxrwxrwx    3 root     users          76 Dec 16  2010 myshare
drwxrwxrwx    7 root     users        4096 Jan  1 01:21 openshare
(And no, I'm not doing much with that box, as you see)


Top
 Profile  
 
PostPosted: Wed Nov 02, 2011 8:24 pm 
Offline

Joined: Tue Nov 01, 2011 10:45 pm
Posts: 8
Perfect thank you mijzelf i will copy your settings and hopefully get this working! ive tried everything, setting up new accounts, other peoples settings. even matching my windows login and password to the admin account on the nas.

it worked until a few days ago because windows 7 did a backup. I was messing arround with the file structure, i think i must have got these permissions wrong, i hope so anyway, ive just looked up your permissions http://www.elated.com/articles/understa ... rmissions/ and see you have 777 so ill set that for my share folders, and ill replace my samba config with yours. fingers crossed hope this works! i can see all the files, just not edit them.

thanks for taking the time to help :)
james


Top
 Profile  
 
PostPosted: Wed Nov 02, 2011 9:22 pm 
Offline

Joined: Tue Nov 01, 2011 10:45 pm
Posts: 8
Unfortunately that didnt work for me :(

even with your config, and restarting the nas, i still could see a share called "mp3" for some reason.

after hunting arround, i find that i have played with the "/etc/edshares.list"

Code:
myfiles:/home/myshare:SMB,AFP,HTTP,FTP,BJR:admin=rw:disable:no
freeshare:/home/openshare:SMB,AFP,HTTP,FTP,BJR:admin=rw,guest=rw:enable:no
MP3s:/home/MP3:SMB,AFP,HTTP,FTP,BJR:admin=rw,guest=rw:enable:no


i dont remember doing this! but maybe this is why i cant edit my shares, does the EDShares list have to match the samba.cfg?


Top
 Profile  
 
PostPosted: Fri Nov 04, 2011 9:54 pm 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 6039
Code:
NetworkSpace /etc # cat EDShares.list
myshare:/home/myshare:SMB,AFP,HTTP,FTP,BJR:admin=rw:disable:no
openshare:/home/openshare:SMB,AFP,HTTP,FTP,BJR:admin=rw,ftp=rw:enable:no

It looks like the config file in which the webinterface settings are stored. I suppose there is some daemon which generates smb.conf from this.
Did you check if your smb.conf changed again?

BTW, there is one big difference between your and my file, the 'freeshare' and 'myfiles' prefix.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group