NSa 210 Debian

Oxnas 810 based
Post Reply
marcin81233
Posts: 3
Joined: Sat Feb 08, 2014 3:07 am

NSa 210 Debian

Post by marcin81233 » Sat Feb 08, 2014 3:28 am

Welcome. I am using the NSA 210 for a long time and I've read a lot of the information from this forum and I'm wondering about installing Debian on my server. I do not know which version and what kernel? whether under this processor can must be version 2.6.24.4 or can be different? Is it possible to install as other nsa "For instance 220 ​​or 310?" With Mountains thank you for your reply.

Mijzelf
Posts: 6226
Joined: Mon Jun 16, 2008 10:45 am

Re: NSa 210 Debian

Post by Mijzelf » Sat Feb 08, 2014 11:04 am

It might be relatively easy, and without any risk to put Debian on that box: Link. Unfortunately I never got any feedback if anyone ever tried and succeeded.

The only available kernel for this SoC is the 2.6.24.4, and this limits the possible Debian version. Lenny works. You can update to Squeeze, if you keep the Lenny udev. Maybe there are more problems with Squeeze on that old kernel, but I'm not aware of any. It seems Wheezy won't work at all.

marcin81233
Posts: 3
Joined: Sat Feb 08, 2014 3:07 am

Re: NSa 210 Debian

Post by marcin81233 » Sat Feb 15, 2014 6:47 pm

Thank you for your prompt reply. I am a beginner in Linux so hold on to the installation of debian on my NSA210. I installed transmission which should be enough for me. However, I have a little problem with setting the startup time of the NSA210. Maybe some suggestions?

vi /ffp/start/transmission.sh :
== Welcome at FFP version 0.5, running on NSA210 NSA210, firmware V4.40(AFD.0) = =
root@NSA210:~# vi /ffp/start/transmission.sh
#!/ffp/bin/sh

# PROVIDE: Transmission

. /ffp/etc/ffp.subr

TRANSMISSION_HOME=/mnt/HD_a2/.transmission-daemon

name="transmission-daemon"
command="/ffp/bin/$name"
start_cmd="transmission_start"
stop_cmd="transmission_stop"
status_cmd="transmission_status"
user=nobody
su_cmd="/ffp/bin/su"

transmission_start()
{
if [ ! -d ${TRANSMISSION_HOME} ]; then
$su_cmd $user -c "mkdir ${TRANSMISSION_HOME}"
fi
echo "Starting $name"
$su_cmd $user -c "$command -g ${TRANSMISSION_HOME} -e ${TRANSMISSION_HOM
- /ffp/start/transmission.sh 1/42 2%


settings.json :
{
"alt-speed-down": 50,
"alt-speed-enabled": false,
"alt-speed-time-begin": 540,
"alt-speed-time-day": 127,
"alt-speed-time-enabled": false,
"alt-speed-time-end": 1020,
"alt-speed-up": 50,
"bind-address-ipv4": "0.0.0.0",
"bind-address-ipv6": "::",
"blocklist-enabled": false,
"blocklist-url": "http://www.example.com/blocklist",
"cache-size-mb": 2,
"dht-enabled": true,
"download-dir": "/mnt/HD_a2/admin/transmission/downloads",
"download-queue-enabled": true,
"download-queue-size": 5,
"encryption": 0,
"idle-seeding-limit": 30,
"idle-seeding-limit-enabled": false,
"incomplete-dir": "/mnt/HD_a2/admin/transmission/incomplete",
"incomplete-dir-enabled": false,
"lpd-enabled": false,
"message-level": 2,
"peer-congestion-algorithm": "",
"peer-id-ttl-hours": 6,
"peer-limit-global": 200,
"peer-limit-per-torrent": 50,
"peer-port": 51413,
"peer-port-random-high": 65535,
"peer-port-random-low": 49152,
"peer-port-random-on-start": false,
"peer-socket-tos": "default",
"pex-enabled": true,
"port-forwarding-enabled": true,
"preallocation": 1,
"prefetch-enabled": 0,
"queue-stalled-enabled": true,
"queue-stalled-minutes": 30,
"ratio-limit": 2,
"ratio-limit-enabled": false,
"rename-partial-files": true,
"rpc-authentication-required": false,
"rpc-bind-address": "0.0.0.0",
"rpc-enabled": true,
"rpc-password": "{14abd701c151c8083b82edebd05cf15864ae7862LCHYpXbf",
"rpc-port": 9091,
"rpc-url": "/transmission/",
"rpc-username": "admin",
"rpc-whitelist": "127.0.0.1,192.168.1.*",
"rpc-whitelist-enabled": true,
"scrape-paused-torrents-enabled": true,
"script-torrent-done-enabled": false,
"script-torrent-done-filename": "",
"seed-queue-enabled": false,
"seed-queue-size": 10,
"speed-limit-down": 100,
"speed-limit-down-enabled": false,
"speed-limit-up": 100,
"speed-limit-up-enabled": false,
"start-added-torrents": true,
"trash-original-torrent-files": false,
"umask": 0,
"upload-slots-per-torrent": 14,
"utp-enabled": true
}

Mijzelf
Posts: 6226
Joined: Mon Jun 16, 2008 10:45 am

Re: NSa 210 Debian

Post by Mijzelf » Sun Feb 16, 2014 11:44 am

1) On firmware 4.40 FFP 0.7/arm can run. Why did you install 0.5?
2) What is your problem?

marcin81233
Posts: 3
Joined: Sat Feb 08, 2014 3:07 am

Re: NSa 210 Debian

Post by marcin81233 » Sun Feb 16, 2014 2:24 pm

The problem is that the transmission does not start with the NSA automatically. And at 0.7 will be something better? I like so I can change. Now I use the server Buffalo, and NSA210 took to improve.

Mijzelf
Posts: 6226
Joined: Mon Jun 16, 2008 10:45 am

Re: NSa 210 Debian

Post by Mijzelf » Sun Feb 16, 2014 6:10 pm

FFP 0.7/arm uses a more efficient way to 'talk' to the kernel (EABI vs. OABI). I don't think you will notice on transmission, but other packages just runs a bit more smooth. And by now there is just more support for 0.7.

About starting transmission, have you made the startscript executable?

Code: Select all

chmod a+x /ffp/start/transmission.sh
If yes, have a look in your ffpboot.log, which can be found on the fat parttiion of your FFP stick.

Post Reply