General NAS-Central Forums

Welcome to the NAS community
It is currently Mon Dec 18, 2017 5:14 am

All times are UTC




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Sun May 29, 2016 1:24 am 
Offline

Joined: Sun May 29, 2016 1:09 am
Posts: 2
Hello,

After five years of service, my NAS 210 has suddenly decided to pack it in, rather ungracefully.

I was trying to get some videos out to a new WDTV media player so was looking at the network shares but the files were not being read.

Then I tried logging into the web interface to check it out, but instead of the login prompt I was getting 404 page not found. I looked at my router's connected devices and checked I was using the correct IP to access it.

Then I used the NSU to locate it. Sure enough, it found it at the address I knew already. However, it said it was Uninitialized...

I tried resetting it to factory settings, many times, just in case I did it wrong... Still no login page, still uninitialized.

At this point I took out the HDD that held my stuff. The NSU was saying that if I tried to initialize the NSA, the driver would be formatted.

I then downloaded the latest firmware I could find 4.41 and tried to apply it using the NSU. It got stuck at 10% forever. Later I found out it has to have some storage attached to be able to initialize.

So I added another HDD and tried initializing again, with the latest firmware. Even though the NSU finds it uses 4.41, it's still reported as uninitialized and there is no login page at the configured IP.

I even tried the forced flashing from USB, that didn't work either.

And of course, I've reset it to factory settings between initializations, just to be on the safe side.

Can anybody help?


Top
 Profile  
 
PostPosted: Sun May 29, 2016 1:00 pm 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 6091
The NSA210 doesn't have enough flash to store the whole firmware in flash. For that reason only a basic Linux system is stored in flash, and NSU is used to push the remaining stuff (GUI and Samba) over network to the disk.

I don't know which protocol is used to push that firmware, maybe FTP, combined with some communication over UDP.

Try to switch off the firewall on your PC, and reinstall the firmware using NSU.


Top
 Profile  
 
PostPosted: Sun May 29, 2016 11:46 pm 
Offline

Joined: Sun May 29, 2016 1:09 am
Posts: 2
Gee wiz, that did it!

I shut down the Windows Firewall and reinitialized the NSA and at the end of the firmware installation, it was giving a message about rebooting, but while before it was not doing anything, now it actually did reboot. After it was done rebooting, I could access the web UI and all!

I remember reading in the Troubleshooting section that UDP port 50127 had to be allowed through the firewall for the NSU to function correctly. Still, there was no mention of storage needing to be attached, so that got me stuck for a couple of hours... Couldn't imagine not having enough flash to hold the firmware!

Anyway, now it's back online, so thank you for your prompt response!

:D


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group