General NAS-Central Forums

Welcome to the NAS community
It is currently Wed Nov 22, 2017 5:32 am

All times are UTC




Post new topic Reply to topic  [ 1 post ] 
Author Message
PostPosted: Mon Sep 17, 2012 11:39 pm 
Offline

Joined: Mon Sep 17, 2012 11:18 pm
Posts: 1
I am new to linux so please be explicit...
I have been trying to setup an svn server for the past week on the NSA210.
Here is what I have accomplished so far...

1. Installed FFP 0.7 using these steps:
http://zyxel.nas-central.org/wiki/FFP-stick

2. Installed packages using "slacker -Ui":
apr-1.4.5-arm-1.txz
subversion-1.7.3-arm-1.txz
apr_util-1.4.1-arm-1
neon-0.29.6-arm-1
sqlite-3.7.9-arm-1

3. Made svnserve.sh in "/ffp/start/" like this:

#!/bin/sh

REPOSITORY="/mnt/HD_a2/svn/"

4. Followed "Create Repository" and "Authorization" and "Star Server" form here:
http://dns323.kood.org/howto:subversion

1) Create Repository
svnadmin create svn/

2) Authorization

Edit svnserve.conf
vi svnserve.conf

[general]
anon-access = read
auth-access = write

password-db = passwd
# authz-db = authz
realm = My First Repository

Save the file and exit


Edit the passwd-file
vi passwd

[users]
foo = bar

Save the file and exit

3) Star Server

svnserve -d --listen-port <port> --listen-host <ip or domain> -r /mnt/HD_a2/Data/svn/

................GOT THROUGH ALL THE PROBLEMS UP TO HERE............


5. Used TortoiseSVN to connect to the server:

svn://192.168.0.31

Error: "Unable to connect to a repository"
No connection could be made because the target machine actively refused it.


Please help I would hate to abandon this now that I have gone so far with this...

Update!!!:

I was able to connect to the server but now I am getting errors from the svnserve.conf file: specifically from each of the uncommented lines in the 4. 2) Authorization step.

If i leave those lines commented I am able connect without any errors but
1) I don't see any of the files in the svn folder and
2) If I try to create a folder with TortoiseSVN I get an error:
Subversion reported an error: Authorization failed.

I aslo cannot connect to the server from outside my wireless network?!

Any help would be greatly appreciated!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 12 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group