FFP Install Fails

Oxnas 810 based
Post Reply
jbrice
Posts: 6
Joined: Fri Mar 04, 2011 8:42 am

FFP Install Fails

Post by jbrice » Thu Nov 08, 2012 2:12 pm

I'm trying to put ffp onto an NSA210 (FW version V4.40(AFD.1)) using the "package install" method as documented here:http://zyxel.nas-central.org/wiki/FFP_as_zypkg. all appears to go according to the description until the last phase of the installation, when it hangs for a long time at "98%"

FFP install log is:

Code: Select all

Rotating logfiles...
Try to determine NAS type...
according to /zyxel/mnt/info/modelid: D401->NSA210
type NSA210, fw V4.40(AFD.1)
Starting /usr/local/zy-pkgs/ffproot/after_booting.sh version 20120924 at Thu Nov 8 13:45:57 WET 2012...
Which FFP version to use?
Is OABI supported?...yes. Is EABI supported?...yes, choosing FFP 0.7/arm
Will try to download fun_plug.tgz (version 0.7/arm)
http://ffp.inreto.de/ffp/0.7/arm/fun_plug.tgz
If the script stops here, downloading the tarball from ffp.inreto.de failed.
ping ffp.inreto.de...
ffp.inreto.de found. Downloading fun_plug.tgz...
pwd /usr/local/zy-pkgs/ffproot/ffp
tar: invalid tar magic
Download failed.
Any help or suggestions appreciated.

TIA

Mijzelf
Posts: 6197
Joined: Mon Jun 16, 2008 10:45 am

Re: FFP Install Fails

Post by Mijzelf » Thu Nov 08, 2012 4:28 pm

Somehow the download and extraction of http://ffp.inreto.de/ffp/0.7/arm/fun_plug.tgz fails. I suggest to remove the package, and install again.
jbrice wrote:when it hangs for a long time at "98%"
That is due to the way the progress counter works. It downloads the zypkg, extracts it, does some administration, and starts it. When it calls the start script, the progress count is 98%, but the FFP start script yet has to download and extract fun_plug.tgz.

jbrice
Posts: 6
Joined: Fri Mar 04, 2011 8:42 am

Re: FFP Install Fails

Post by jbrice » Thu Nov 08, 2012 5:07 pm

Thnaks for the reassurance about the long 98% stage. However I have since tried deleting the package completely and re-installing. Each time the logs show a failure at the same point.

Only change is that sometimes the error message looks like this:

Code: Select all

...
ffp.inreto.de found. Downloading fun_plug.tgz...
pwd /usr/local/zy-pkgs/ffproot/ffp
tar: short read
Download failed.

jbrice
Posts: 6
Joined: Fri Mar 04, 2011 8:42 am

Re: FFP Install Fails

Post by jbrice » Thu Nov 08, 2012 5:52 pm

Just tried installing FFP on a memory stick (using the FFPStick-2012-05-28.zip and finally the FFPStick-2012-10-20.zip versions). These grind to a halt in a similar manner to the zpkg install above:

Code: Select all

*** snip ***
Will try to download fun_plug.tgz (version 0.7/arm)
http://ffp.inreto.de/ffp/0.7/arm/fun_plug.tgz
If the script stops here, downloading the tarball from ffp.inreto.de failed.
You can try to get internet access for the NSA210,
or copy fun_plug.tgz (case sensitive!) to the share containing ffproot.
It should be recognized and installed.
It is possible that you have to reboot the box before this share shows up.
ping ffp.inreto.de...
ffp.inreto.de found. Downloading fun_plug.tgz...
pwd /e-data/77bae0e6-bbb7-4747-85be-fd972f3c3a19/ffproot/ffp
tar: invalid tar magic
Download failed.
Could not download fun_plug.tgz for some reason
Will start polling for the existance forever in the share containing ffproot...

Mijzelf
Posts: 6197
Joined: Mon Jun 16, 2008 10:45 am

Re: FFP Install Fails

Post by Mijzelf » Thu Nov 08, 2012 6:08 pm

So some way fun_plug.tgz is corrupted. I just downloaded the file, and it's fine. So I think it has something to do with your network. When you download it manually, is it corrupted? Does something like 7zip complain when it opens the archive?

jbrice
Posts: 6
Joined: Fri Mar 04, 2011 8:42 am

Re: FFP Install Fails

Post by jbrice » Thu Nov 08, 2012 6:52 pm

Tried download and open archive as soon as I hit problems earlier and again after seeing your message. Both times a clean download and no problems opening archives.
A bit of a mystery then - will return to it another day and hopefully the gremlins will have gone away.
Thanks for the support.
JB

LATER - FFP stick now working after downloading fun_plug.tgz manually and copying across to root of larger partition on the USB stick, then re-booting.
Last edited by jbrice on Thu Nov 08, 2012 8:47 pm, edited 1 time in total.

Mijzelf
Posts: 6197
Joined: Mon Jun 16, 2008 10:45 am

Re: FFP Install Fails

Post by Mijzelf » Thu Nov 08, 2012 8:44 pm

Did you ever observe data corruption when transferring data between your PC and your NAS?

jbrice
Posts: 6
Joined: Fri Mar 04, 2011 8:42 am

Re: FFP Install Fails

Post by jbrice » Thu Nov 08, 2012 8:49 pm

No sign of data corruption. Did you have something in mind? See note in previous post - FFP stick now working using file d.loaded via PC.

Mijzelf
Posts: 6197
Joined: Mon Jun 16, 2008 10:45 am

Re: FFP Install Fails

Post by Mijzelf » Thu Nov 08, 2012 9:11 pm

jbrice wrote:Did you have something in mind?
Bad wiring can cause transfers to get corrupted. I suppose both your PC and your NAS are connected to your router. Downloading to the PC goes fine, downloading to the NAS doesn't. So if it's due to bad wire, it' s the wire between the NAS and the router. In that case you would also expect corrupted transfers between NAS and PC.

On the other hand, the download of fun_plug.tgz by the NAS is done over http, so the checksum in the TCP header is the only mechanism preventing corruption. While the transfers between PC and NAS are over samba, I suppose. I don't know enough about it, maybe samba has some extra corruption prevention mechanism.

Post Reply