Network Space not Booting

Post Reply
rimoth
Posts: 73
Joined: Thu Jan 13, 2011 9:27 am

Network Space not Booting

Post by rimoth » Thu Aug 01, 2013 9:44 pm

Yesterday my Network Space 2 was not discoverable on the network. It had been up and running without any issues for a number of weeks.

I tried a reboot but I was left with a constant flashing blue led. Reading previous threads this indicates that it is not possible to load/boot the kernel from the disk, possible disk failure or corruption.

I used u-boot to boot up over the lan. The disk looked OK (cat /etc/partitions) so I then mounted sda9 and deleted some log files. (a suggestion from an earlier thread).

When I rebooted the nas it booted up and obtained an ip address from the router. It also launched a debian chroot I am using to run Logitech Media Server.

The problem is when I ssh into the nas a listing of the root directory gives me this..

Code: Select all

[root@NetworkSpace2 /]# ls
09J2bi                 MfoiP7                 iaz_uE
0b46jf                 MhO1pp                 iixk5t
0qNUpu                 MuNtNy                 j2lJW_
10YakL                 NBRcFY                 jIF9oS
1A7TYr                 NT7NbG                 jJTz4g
1B4RAU                 NtEEyo                 jkNmMu
1OY1wT                 NyOlTZ                 kDI52r
24OKa9                 O3MYK_                 kUqH4C
2bFWH4                 O8TLjQ                 k_RJOl
2s3FnS                 OPhvyP                 lCEXug
3DhVHf                 Oiz_0K                 lDpWA2
3SzYeU                 Oj0iCB                 lKDIMk
3aeDMv                 PGpmWX                 lacie
3ieayp                 PMpzNK                 lbsXPI
5AMmjq                 PZXLNx                 lib
5JTIrl                 Pls3BB                 lost+found
5i6SY1                 PsGZGy                 mDJUjI
5vORn2                 QEN9Db                 mER919
60VjML                 QS_Ypj                 mbBFkf
6AmpCW                 RWkZgQ                 media
6SD4Zz                 RtpPmX                 mnt
6x8nOh                 S5vg5C                 n5ZmCN
71drtK                 TMTJic                 nlwW8l
7VCe2g                 T_Ky8Q                 nvDUj8
88PlXx                 TeP7Zd                 nwyDwJ
8FqNd8                 TvAH1M                 o0lvcI
8yMGCC                 TvAfnZ                 oFbg0F
934qpQ                 U2sHPV                 oGH5QV
9kXQEd                 Urzmxy                 o_oqcy
9n5UWs                 VDXrgp                 oijEOT
9olT_J                 VrfbfB                 oldroot
9zTle6                 Vwf9Mz                 onN4KY
A5pWf1                 WLVFKw                 opt
ADXu0z                 WNgxHW                 p0YF8k
AGvsS6                 WV59Zr                 pQDRyQ
AKDBmx                 W_KmqZ                 pShQv3
AR6vu8                 WrQLRC                 pVHYvu
ARD2Mv                 Ws43E8                 pVQl7y
AW1ai7                 XrGYlu                 pVQv4g
A_41q8                 Xzm6_P                 pp6aY3
Aq1Qpj                 YJgLuv                 proc
BDbZZX                 YWcFrj                 qENQqm
BgvCFD                 Ylzhm9                 qOWMhO
BpUYer                 _Jydgs                 qYFhCD
BpfaP7                 _LFCng                 qkqe1G
CI2Wcr                 _zeXSd                 qo7iRa
CQ83Vy                 aEGVk9                 rdwpjQ
CeRGq2                 aTTZNb                 root
CgdUJV                 an6ygj                 rxBLf5
CjGIJk                 bN2Yk0                 s28JZ4
Cleu7K                 bin                    s6PEff
Czrr3c                 boot                   sIvMwO
DE8s57                 c4BZ8L                 sRXW8v
Dj8IGh                 cJ2GEw                 sbin
DyvzTU                 chroot-debian          share
EAcXm2                 chroot-squeezebox.old  shares
EqaSuR                 chroot-squeezebox.sh   sys
EwnC3m                 ctRE28                 tJMWi3
FvpsHc                 dEfd9K                 tZNk2U
G8yTyD                 dOvgaE                 tjgzyb
GipH6F                 dYMWvp                 tmp
GzEcLe                 debian                 twonkymedia
H67tVU                 dev                    u5VC0s
HGI9ME                 dwDOOl                 uWd3Gk
HSNDls                 dzjteq                 usr
HY70FV                 e1sPlx                 v65JtQ
Hq6Ve3                 eH9R5n                 vKt51t
I0UPMD                 eJINR9                 var
I7H_W4                 eqFIcR                 vpF_Zk
Iglvst                 erxMpZ                 wA_Efv
IwL91_                 etc                    wkLgrm
JULjqr                 fy_70E                 www
JkewHQ                 gQlgCC                 xeeApk
Jl3QPi                 gwV5Cm                 xnUcQq
Juil70                 hBT0Ut                 y2uLvJ
K6QXzo                 hFDtRy                 yGvda3
K9ND8T                 hXj4iI                 yNLrGG
KXeQj0                 hlpbK_                 yWLH9e
Kn0lk9                 hoVZiX                 ykbGok
L54k_q                 home                   zDkXp_
LhySXW                 huq2LH                 zE1sgc
Lp09eI                 i3ISz9                 zo3UOS
M5tY3g                 iArJJw                 zwNdHY
MU0Cxq                 iOyReR
Mf_NwR                 iTTcrK
[root@NetworkSpace2 /]# 
Then looking in the shares/OpenShare directory, where I expected my data to be, there was nothing.

The puzzling part is when I entered a debian chroot, mounted sda2 where OpenShare is located "sda2/shares/2/" all the files look to present and correct.

If the files actually exist via the debian environment, then is there a corruption within the lacie environment which can be rectified?

Any suggestions will be appreciated

rimoth
Posts: 73
Joined: Thu Jan 13, 2011 9:27 am

Re: Network Space not Booting

Post by rimoth » Thu Aug 01, 2013 9:59 pm

OK, where I see nothing in OpenShare in the Lacie environment I am guessing this has failed to mount. I am not sure why though. Can someone point me to where I should look to see why the mount is failing.

fyi, I am listening to music which is streaming from the OpenShare mounted in the debian chroot, so I think the OpenShare partition is potentially sound.

Mijzelf
Posts: 6251
Joined: Mon Jun 16, 2008 10:45 am

Re: Network Space not Booting

Post by Mijzelf » Fri Aug 02, 2013 8:33 am

Mounting of the data partition is done by Unicorn, and Unicorn has a logfile. At the moment I can't remember if that logfile is in /var/log or in /etc. In both cases you should search in sda9/snaps/<some-number>/ var/log/ or etc.

rimoth
Posts: 73
Joined: Thu Jan 13, 2011 9:27 am

Re: Network Space not Booting

Post by rimoth » Fri Aug 02, 2013 6:28 pm

Thanks Mijzelf. I found unicorn.log in /var/log. Every 10 seconds the following is being logged.

Code: Select all

Aug  2 19:21:28 NetworkSpace2 [INFO __init__.init@123] Initializing unicorn...
Aug  2 19:21:28 NetworkSpace2 [DEBUG database.init_database@86] Creating database
Aug  2 19:21:29 NetworkSpace2 [CRITICAL run.run@319] Caught an exception during Unicorn initialization, initialization failed
Aug  2 19:21:29 NetworkSpace2 Traceback (most recent call last):
Aug  2 19:21:29 NetworkSpace2   File "/usr/lib/unicorn/run.py", line 315, in run
Aug  2 19:21:29 NetworkSpace2     log_path=run_config.get('log_file', '')
Aug  2 19:21:29 NetworkSpace2   File "/usr/lib/python2.6/site-packages/unicorn/core/database.py", line 299, in work
Aug  2 19:21:29 NetworkSpace2     result = f(*args, **kws)
Aug  2 19:21:29 NetworkSpace2   File "/usr/lib/python2.6/site-packages/unicorn/__init__.py", line 131, in init
Aug  2 19:21:29 NetworkSpace2     init_modules(modules)
Aug  2 19:21:29 NetworkSpace2   File "/usr/lib/python2.6/site-packages/unicorn/core/module.py", line 331, in init_modules
Aug  2 19:21:29 NetworkSpace2     modules_dict = _init_modules(modules_config_dict)
Aug  2 19:21:29 NetworkSpace2   File "/usr/lib/python2.6/site-packages/unicorn/core/module.py", line 249, in _init_modules
Aug  2 19:21:29 NetworkSpace2     module = __import__(name, fromlist=[''])
Aug  2 19:21:29 NetworkSpace2   File "/usr/lib/python2.6/site-packages/unicorn/sharing/__init__.py", line 17, in <module>
Aug  2 19:21:29 NetworkSpace2     from unicorn.sharing.access.user import ShareUserAccess
Aug  2 19:21:29 NetworkSpace2   File "/usr/lib/python2.6/site-packages/unicorn/sharing/access/user.py", line 31, in <module>
Aug  2 19:21:29 NetworkSpace2     from unicorn.authentication.local.user import LocalUser
Aug  2 19:21:29 NetworkSpace2   File "/usr/lib/python2.6/site-packages/unicorn/authentication/local/user.py", line 234
Aug  2 19:21:29 NetworkSpace2      'anonymous:x:65534:65534:Nobod
Aug  2 19:21:29 NetworkSpace2                                   ^
Aug  2 19:21:29 NetworkSpace2  SyntaxError: EOL while scanning string literal
I can see it is some sort of initialisation error reading a string but not sure where to look next.

Mijzelf
Posts: 6251
Joined: Mon Jun 16, 2008 10:45 am

Re: Network Space not Booting

Post by Mijzelf » Sat Aug 03, 2013 9:43 am

Hm. That database could be the problem. I vaguely remember (and it should be somewhere in this forum) that someone had problems with his data partition. It was solved by reformatting sda2 *and* deleting some unicorn database. /etc/unicorn.db? Maybe better rename it.

rimoth
Posts: 73
Joined: Thu Jan 13, 2011 9:27 am

Re: Network Space not Booting

Post by rimoth » Wed Sep 04, 2013 7:28 pm

Apologies for not responding to your suggestion sooner.

I backed up unicorn.db and then deleted it and rebooted the NAS. Unfortunately this did not remedy the problem.

I have managed to rescue all of my data and have decided to give fvdw's alternative firmware a go on the NS2.

I believe the issue might be down to the drive getting a little bit hot. Fvdw's firmware does provide disk temperature and SMART monitoring so should allow me to keep a closer eye on things.

Thanks again for your assitance.

Post Reply