General NAS-Central Forums

Welcome to the NAS community
It is currently Fri Nov 24, 2017 7:39 am

All times are UTC




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Data error / XFS issues
PostPosted: Thu Jan 30, 2014 5:59 pm 
Offline

Joined: Sun Jan 15, 2012 4:24 am
Posts: 6
Hi,

When I try to copy files via network, after some time the operation hangs and Windows says network drive isn't reachable, blue led keep blinking very fast, like if they can't copy the file.

Anyone know what is this?

I think is data corrupted, I'll try to run xfs tolls to see if can recover, but I'm reading many ppl with issues trying to recover files from a XFS partition.

Anyone with more experience in this can give me a light?

Tks!


Top
 Profile  
 
PostPosted: Mon Mar 03, 2014 10:30 pm 
Offline

Joined: Mon Mar 03, 2014 10:19 pm
Posts: 1
I did it this morning! ;)
My disk became slow and noisy, disk usage at 80%.

First I run fsck with -p option (automatic repair) on the ext3 partitions:
Code:
fsck -p /dev/sda2
fsck -p /dev/sda7
fsck -p /dev/sda9


Than I repaired the ifs partition (data), but the partition needs to be unmounted:
Code:
umount /shares/OpenShare/
umount /shares/MyShare/
umount /lacie/afp_db/
umount /lacie/autoupdate/
umount /lacie/torrent_dir/
umount /lacie/var/
umount /lacie/tmp/
umount /media/internal_8/


Finally the xfs repair command:
Code:
xfs_repair -n /dev/sda2


The disk now is like new!
I thinks it's even better erasing all the data... ;)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC


Who is online

Users browsing this forum: Bing [Bot] and 32 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group