Spin Down Problem after updates 2.x.x

Post Reply
grdiver
Posts: 2
Joined: Tue Dec 27, 2011 10:18 pm

Spin Down Problem after updates 2.x.x

Post by grdiver » Tue Dec 27, 2011 10:40 pm

Hello everybody!

My Network Space 2 has worked flawlessly up to version 1.2.93. After the 2.x.x versions started coming from Lacie, I noticed that the HDD inside the device would not spin down correctly when reaching the "Eco Management" setting. To be more specific, it starts spinning again almost instantly after being stopped, although there is no network traffic to the NAS.

I performed a Factory reset, which took the device back to version 1.0.2. and tested some versions up to 1.2.93. Using 1.x.x versions, the HDD spins down correctly, and the smart_spindown.log file looks like below:


>> Monitoring spindown opportunities for disk(s) sda
>> Spindowns counter: 0, time up/down: 480/0.
Exiting.
>> smart_spindown start - disk(s): sda
>> Spindowns counter: 0, time up/down: 300/0.
>> smart_spindown stop
>> smart_spindown start - disk(s): sda
>> Spindowns counter: 0, time up/down: 0/0.
>> smart_spindown stop
>> smart_spindown start - disk(s): sda
>> Spindowns counter: 2, time up/down: 2970/7830.
>> smart_spindown stop
>> smart_spindown start - disk(s): sda
>> Spindowns counter: 1, time up/down: 600/90.
>> smart_spindown stop
>> smart_spindown start - disk(s): sda
>> Spindowns counter: 0, time up/down: 5460/0.
>> smart_spindown stop
>> smart_spindown start - disk(s): sda
>> Spindowns counter: 7, time up/down: 33540/23490.
>> smart_spindown stop
>> smart_spindown start - disk(s): sda
>> Spindowns counter: 0, time up/down: 5190/0.
>> smart_spindown stop
>> smart_spindown start - disk(s): sda
>> Spindowns counter: 0, time up/down: 300/0.
>> smart_spindown stop
>> smart_spindown start - disk(s): sda
>> Spindowns counter: 0, time up/down: 7290/0.
>> smart_spindown stop
>> smart_spindown start - disk(s): sda


If I upgrade to anything 2.x.x, the disk does not spin down correctly, and the smart_spindown.log file looks like below:

>> smart_spindown start - disk(s): sda
!! ------------------------------------------------------------
!!
!! Fail to execute: /bin/mount /dev/sda2 -t xfs /shares/MyShare -o remount,rw,nosuid,nodev,relatime,attr2,usrquota,prjquota,grpquota
!!
!! ------------------------------------------------------------
!! An error occured while executing smart_spindown.
!! Please, report this error to the LaCie support team.
!!
!! Thanks.
!!
/sbin/smart_spindown: line 202: 2828 Done ${SLEEP} ${poll_time}
2829 Terminated | while read -r DEV MP FST OPTS DUMP PASS; do
[ -z "${DEV}" -o -z "${MP}" -o -z "${FST}" -o -z "${OPTS}" ] && log_and_die $? "Fail to parse mountpoints file ${MOUNTPOINTS_FILE}"; MP=`printf $MP`; $* "${DEV}" "${MP}" "${FST}" "${OPTS}" || log_and_die $? "Fail to execute: $* ${DEV} ${MP} ${FST} ${OPTS}";
done
!! ------------------------------------------------------------
!!
!! Fail to parse mountpoints file /etc/mtab
!!
!! ------------------------------------------------------------
!! An error occured while executing smart_spindown.
!! Please, report this error to the LaCie support team.
!!
!! Thanks.
!!
>> smart_spindown start - disk(s): sda


There is no support e-mail address in Lacie's website to send them this error log, and because I am not very familiar with Linux I do not really understand the error , or know if there is anything I can do to correct the problem myself.

I would like to ask if other people have similar problems after upgrading to NAS OS2.0.

Thank you very much!

Mijzelf
Posts: 6251
Joined: Mon Jun 16, 2008 10:45 am

Re: Spin Down Problem after updates 2.x.x

Post by Mijzelf » Fri Dec 30, 2011 11:09 am

I think you can post your log here:
https://www.lacie.com/mystuff/login.htm?rtn=newticket

BTW, that smart_spindown script is a strange thing. Normally you just tell the disk to spindown after some idle time. No running script needed. I haven't looked at the NS2 script, but I think it's similar to the 2Big2 script. On the 2Big2 the temperature sensor of the disk(s) are used for the fan control. Problem is that by asking the temperature, the idle count of the disk is reset, resulting in never sleeping disks. So because of that the script keeps track of the disk access, and puts it asleep actively. Because the script has done this, it also knows it's should ask the temperature anymore, as that could spin up disk.
Stunning point is of course that the NS2 doesn't have a fan.

grdiver
Posts: 2
Joined: Tue Dec 27, 2011 10:18 pm

Re: Spin Down Problem after updates 2.x.x

Post by grdiver » Fri Dec 30, 2011 11:49 am

Thank you for your response!

I visited the link you sent me a few days ago, it seems that you can actually get a new support "ticket" only if you have set "USA" as country of residence. The online form then asks for a valid address and telephone number (in the USA). When registering my product I entered Greece, which is where I live, so I can't get support via the "ticket" system. To my surprise there is no support e-mail address either(!)...

It is very weird that the problem only occurs in versions of the NAS OS2.0. Perhaps it is a bug that hasn't come in their attention yet, and might be solved in future releases.

The original HDD of my NS2 failed a while ago so I am currently running a Seagate Barracuda LP 1TB in it, that I prepared using the uploaded images available on this forum. Thinking that it might be some sort of hardware incompatibility, yesterday I also prepared and tested a Western Digital Caviar Blue HDD, and it has the exact same performance in all 2.x.x versions.

I am running Mac OS X 10.7.2 Lion on my Mac machines, but since i do not use Time Machine BackUps on the NAS I have reverted to version 1.2.93 and have no problems so far. I will post/update if anything new comes into my attention.

Thanks again for your help!

Post Reply