Flickering d2 Network 2 after power loss

Post Reply
Posts: 2
Joined: Mon Jan 21, 2013 9:48 am

Flickering d2 Network 2 after power loss

Post by Interceptor » Mon Jan 21, 2013 10:39 am

I have d2 Network 2 LaCie Nas. After power loss I cant get to it, and LED is flickering blue. I cant do reset or connect to it so i disassembled it to copy data. After that i started looking for solution and i found this forum.
I have another sata hdd so i tried on him to make partitions. But when i print print table of partitions of Lacie HDD i get:

Code: Select all

Dysk /dev/sdb: 1000.2 GB, bajtów: 1000204886016
głowic: 255, sektorów/ścieżkę: 63, cylindrów: 121601
Jednostka = cylindrów, czyli 16065 * 512 = 8225280 bajtów
Rozmiar sektora (logiczny/fizyczny) w bajtach: 512 / 512
Rozmiar we/wy (minimalny/optymalny) w bajtach: 512 / 512
Identyfikator dysku: 0x9507db67

Urządzenie Rozruch   Początek      Koniec   Bloków   ID  System
/dev/sdb1               1         125     1004031    5  Rozszerzona
/dev/sdb2             126      121601   975755970   83  Linux
/dev/sdb5               1          16      128457   82  Linux swap / Solaris
/dev/sdb6              17          17        8001   83  Linux
/dev/sdb7              18          18        8001   83  Linux
/dev/sdb8              19          40      176683+  83  Linux
/dev/sdb9              41         124      674698+  83  Linux
/dev/sdb10            125         125        8001   83  Linux
So its different from those what i found on that forum. Even info on http://www.rigacci.org is different.

Ive already created all partitions like above on 2nd hdd, and copied sdb6,7,8 on them but i still have no reaction from Nas.
I need to do "raid arrays" liek in 2big2 if that nas have only one hdd? If i do, i need to do them all (sdb5,7,8,9,2 and 10)?

Posts: 1
Joined: Mon Jan 21, 2013 3:16 pm

Re: Flickering d2 Network 2 after power loss, my solution

Post by spolies » Mon Jan 21, 2013 3:34 pm

Connecting the disk
Connect the new disks to a Linux PC. (A windows PC booted from a Linux Live CD or -usb stick is fine). You can use an USB-SATA converter, or connect the disk on an in- or extern SATA port.

Find device name
Find the device name of the disk:
cat /proc/partitions
I'll assume the disk is sdb for the rest of the story.

Collect files
Download the 3 files .gz and .tgz from http://downloads.lacie.nas-central.org/ ... rk2/2.2.5/
and the mbr+label.gz from http://downloads.lacie.nas-central.org/ ... r+label.gz

Become root
You'll need to have root rights to do the next steps. In Ubuntu or Knoppix you can get these by executing
sudo su
In most other flavors you just execute

MBR and label

Write mbr+label.gz to disk:
gzip -dc /full/path/to/mbr+label.gz | dd of=/dev/sdb
(when using sudo for root things, this should be
gzip -dc /full/path/to/mbr+label.gz | sudo dd of=/dev/sdb

Create partitions
Use fdisk to generate this partition table:

Code: Select all

      Device Boot      Start         End      Blocks  Id System
/dev/sdb1               1         250     2008093+  5 Extended
/dev/sdb2             251      121601   974751907+ fd Linux raid autodetect
/dev/sdb5               1          32      256977  fd Linux raid autodetect
/dev/sdb6              33          33        8001  83 Linux
/dev/sdb7              34          35       16002  fd Linux raid autodetect
/dev/sdb8              36         141      851413+ fd Linux raid autodetect
/dev/sdb9             142         249      867510  fd Linux raid autodetect
/dev/sdb10            250         250        8001  83 Linux
/dev/sdb2 is the data partition, it uses all remaining space.
After writing mbr+label.gz to the disk, /dev/sdb1 and /dev/sdb5 are already created.
/dev/sdb2 is a primary partition, /dev/sdb1 is an extended partition, and all other partitions are logical.
fdisk is started by:
fdisk /dev/sdb
and use 'm' to get further help.
Use 'u' to change to sector units.

Loading partitions

/dev/sdb5 (swap)
mkswap -f /dev/sdb5

/dev/sdb7 (initfs)
mke2fs -j /dev/sdb7
mkdir /tmp/md0
mount /dev/sdb7 /tmp/md0
cd /tmp/md0
tar xzf /full/path/to/sda7.tgz
cd ..
umount /tmp/md0

/dev/sdb8 (ro layer rootfs)
mke2fs -j /dev/sdb8
mount /dev/sdb8 /tmp/md0
cd /tmp/md0
tar xzf /full/path/to/sda8.tgz
cd ..
umount /tmp/md0

/dev/sdb9 (rw layer rootfs)
mke2fs -j /dev/sdb9

/dev/sdb2 (data partition)
mkfs.xfs /dev/sdb2

/dev/sdb6 (kernel)
gzip -cd /full/path/to/sda6.gz | dd of=/dev/sdb6

/dev/sdb10 (spare kernel?)
dd if=/dev/zero of=/dev/sdb10

Installing the disk
When the disk is prepared, you can put in the D2 Network 2. Switch it on, and the box will boot. After about a minute you can login on the webinterface, and choose your settings.

Good Luck.

Posts: 2
Joined: Mon Jan 21, 2013 9:48 am

Re: Flickering d2 Network 2 after power loss

Post by Interceptor » Wed Jan 23, 2013 6:48 am

spolies Thanks for Your reply. Its weird because in tutorial its suggested to use "Linux Raid Autodetect" when I have on orginal HDD just "Linux" partions and one Linux swap for sdb5.

-Problem solved-
Fault was not on HDD but with one of Condensators on LaCie mainboard. After change on working 470µF(same like orginal one) Condensator, LaCie is back online.
Im lucky cos i tried on another HDD and i left orginal one unchanged.
Best regards

Post Reply