General NAS-Central Forums

Welcome to the NAS community
It is currently Thu Mar 22, 2018 5:43 am

All times are UTC

Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: update ssl/tls gnutls
PostPosted: Fri Mar 07, 2014 11:03 am 

Joined: Mon Apr 05, 2010 5:44 am
Posts: 3
Hi all,

after I read about the leak in the ssl/tls software I wanted to update my current gnutls version on my NAS (HMNHD)

I downloaded the full package at to compile it from source because I couldn't find a package from Debian for this old distro. (I have the firmware of this forum running with telnet)

I uploaded the files to my NAS and started typing ./configure, but I am getting an error message ;
 $ ./configure

## --------- ##
## Platform. ##
## --------- ##

hostname = Iomega
uname -m = armv5tejl
uname -r =
uname -s = Linux
uname -v = #1 Mon Jun 1 11:21:53 MDT 2009

/usr/bin/uname -p = unknown
/bin/uname -X     = unknown

/bin/arch              = unknown
/usr/bin/arch -k       = unknown
/usr/convex/getsysinfo = unknown
/usr/bin/hostinfo      = unknown
/bin/machine           = unknown
/usr/bin/oslevel       = unknown
/bin/universe          = unknown

PATH: /usr/local/sbin
PATH: /usr/local/bin
PATH: /usr/sbin
PATH: /usr/bin
PATH: /sbin
PATH: /bin

## ----------- ##
## Core tests. ##
## ----------- ##

configure:3897: checking build system type
configure:3911: result: armv5tejl-unknown-linux-gnueabi
configure:3931: checking host system type
configure:3944: result: armv5tejl-unknown-linux-gnueabi
configure:3981: checking for a BSD-compatible install
configure:4049: result: /usr/bin/install -c
configure:4060: checking whether build environment is sane
configure:4115: result: yes
configure:4266: checking for a thread-safe mkdir -p
configure:4305: result: /bin/mkdir -p
configure:4312: checking for gawk
configure:4342: result: no
configure:4312: checking for mawk
configure:4328: found /usr/bin/mawk
configure:4339: result: mawk
configure:4350: checking whether make sets $(MAKE)
configure:4372: result: yes
configure:4401: checking whether make supports nested variables
configure:4418: result: yes
configure:4554: checking whether make supports nested variables
configure:4571: result: yes
configure:4587: result: ***
*** Checking for compilation programs...

configure:4640: checking for gcc
configure:4656: found /usr/bin/gcc
configure:4667: result: gcc
configure:4896: checking for C compiler version
configure:4905: gcc --version >&5
gcc (Debian 4.3.2-1.1) 4.3.2
Copyright (C) 2008 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO

configure:4916: $? = 0
configure:4905: gcc -v >&5
Using built-in specs.
Target: arm-linux-gnueabi
Configured with: ../src/configure -v --with-pkgversion='Debian 4.3.2-1.1' --with-bugurl=file:///usr/share/doc/gcc-4.3/README.Bugs --enable-languages=c,c++,fortran,objc,obj-c++ --prefix=/usr --enable-shared --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --enable-nls --with-gxx-include-dir=/usr/include/c++/4.3 --program-suffix=-4.3 --enable-clocale=gnu --enable-libstdcxx-debug --enable-objc-gc --enable-mpfr --disable-libssp --disable-sjlj-exceptions --enable-checking=release --build=arm-linux-gnueabi --host=arm-linux-gnueabi --target=arm-linux-gnueabi
Thread model: posix
gcc version 4.3.2 (Debian 4.3.2-1.1)
configure:4916: $? = 0
configure:4905: gcc -V >&5
gcc: '-V' option must have argument
configure:4916: $? = 1
configure:4905: gcc -qversion >&5
gcc: unrecognized option '-qversion'
gcc: no input files
configure:4916: $? = 1
configure:4936: checking whether the C compiler works
configure:4958: gcc    conftest.c  >&5
configure:4962: $? = 0
configure:5010: result: yes
configure:5013: checking for C compiler default output file name
configure:5015: result: a.out
configure:5021: checking for suffix of executables
configure:5028: gcc -o conftest    conftest.c  >&5
configure:5032: $? = 0
configure:5054: result:
configure:5076: checking whether we are cross compiling
configure:5084: gcc -o conftest    conftest.c  >&5
conftest.c:11:19: error: stdio.h: No such file or directory
conftest.c: In function 'main':
conftest.c:15: error: 'FILE' undeclared (first use in this function)
conftest.c:15: error: (Each undeclared identifier is reported only once
conftest.c:15: error: for each function it appears in.)
conftest.c:15: error: 'f' undeclared (first use in this function)
configure:5088: $? = 1
configure:5095: ./conftest
./configure: line 5097: ./conftest: No such file or directory
configure:5099: $? = 127
configure:5106: error: in `/gnutls-3.2.12':
configure:5108: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.

unfortunately I am not jet very good with linux althought I am learning every day ;-)

Someone any idea what is going wrong here?

With googling I find answers like: 'the right compiler is used or available' and 'chmod of the files are exec' .
Do I understand it correctly out of this log that the minimum version of the gcc compiler must be 5?
Files are exec so their can't lie the problem.

BTW I think it is important for everyone to upgrade their NAS too.

PostPosted: Tue Mar 11, 2014 3:00 pm 

Joined: Fri Apr 08, 2011 9:59 am
Posts: 160
If I read this correctly the first real error you find is "error: stdio.h: No such file or directory"
I have never tried this before, but my quick google found that you probably need to run:
apt-get install build-essential

I've tried that on my nas, and it actually installed something, but I haven't tried updating gnutls (yet). Let me know if this fixes it.

[edit]ok, so I tried it and I ran in to 'libnettle 2.7 was not found'
I could install libnettle2, but I don't think libnettle 2.7 is on lenny, so you might have to build that as well, though I'm really not sure.
At least I got past the stdio.h error. :)

[edit2]I suppose you could solve most problems by going to squeeze / wheezy

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC

Who is online

Users browsing this forum: No registered users and 12 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group