squeeze stuck apt-get

Post Reply
hxm
Posts: 2
Joined: Mon Dec 01, 2014 9:49 pm

squeeze stuck apt-get

Post by hxm » Mon Dec 01, 2014 10:02 pm

Hello guys, first of all THANKS for this forum

following a thread i was able to upgrade to squeeze, and now when i want to install something, apt wants to upgrade libc6.

When libc6 is being upgraded it says:

Preparing to replace libc6 2.11.3-4 (using .../libc6_2.13-38+deb7u6_armel.deb) ...
Checking for services that may need to be restarted...
Checking init scripts...
WARNING: this version of the GNU libc requires kernel version
2.6.26 or later. Please upgrade your kernel before installing
glibc.

The installation of a 2.6 kernel _could_ ask you to install a new libc
first, this is NOT a bug, and should *NOT* be reported. In that case,
please add lenny sources to your /etc/apt/sources.list and run:
apt-get install -t lenny linux-image-2.6
Then reboot into this new kernel, and proceed with your upgrade
dpkg: error processing /var/cache/apt/archives/libc6_2.13-38+deb7u6_armel.deb (--unpack):
subprocess new pre-installation script returned error exit status 1
configured to not write apport reports
Errors were encountered while processing:
/var/cache/apt/archives/libc6_2.13-38+deb7u6_armel.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I follow the suggestion and switch to lenny repo, apt-get update, fix the gpg key, and i get this:

Package linux-image-2.6 is a virtual package provided by:
linux-image-2.6.26-2-versatile 2.6.26-29
linux-image-2.6.26-2-orion5x 2.6.26-29
linux-image-2.6.26-2-ixp4xx 2.6.26-29
linux-image-2.6.26-2-iop32x 2.6.26-29

You should explicitly select one to install.

this nas is armv5tejl, which should i use? i wont break the system

Mijzelf
Posts: 6197
Joined: Mon Jun 16, 2008 10:45 am

Re: squeeze stuck apt-get

Post by Mijzelf » Tue Dec 02, 2014 8:24 am

Unfortunately, none. The SoC (OXE810) has only one working kernel. I have read that PLX patched the kernel that dirty to fit the '810, that noone succeeded in porting it to the vanilla kernel. So if libc6 indeed needs that newer kernel, it can't run on your box.

hxm
Posts: 2
Joined: Mon Dec 01, 2014 9:49 pm

Re: squeeze stuck apt-get

Post by hxm » Tue Dec 02, 2014 9:04 am

Oh,

compiling a custom kernel could be a solution?

squeeze is fair enough by the moment though

Mijzelf
Posts: 6197
Joined: Mon Jun 16, 2008 10:45 am

Re: squeeze stuck apt-get

Post by Mijzelf » Tue Dec 02, 2014 8:15 pm

hxm wrote:compiling a custom kernel could be a solution?
The only suitable source for an OXE810 SoC can be found in the GPL sources of the HMNHD, or in the GPL source of one of the other boxes running the same SoC (ZyXEL NSA-210/221, WD MyBook World (White Light Edition), ...). They all will give you a 2.6.24.4 kernel. With some effort you can update that to 2.6.24.7.
Getting a newer kernel is not trivial.

Post Reply