HMND and TwonkyVision

Mijzelf
Posts: 6226
Joined: Mon Jun 16, 2008 10:45 am

Re: HMND and TwonkyVision

Post by Mijzelf » Tue Jan 03, 2012 8:43 am

DPJames wrote:Does "upload" mean to use the Update Firmware function with this file?
Yes. The file is technically a firmware update, but without files. Only the configuration script is provided and executed.
It doesn't appear to be in the same format as earlier firmware files.
It is. A firmware update is an encrypted tar ball. This one is small (it's almost empty, as all needed parts are already installed), and it has a different extension (the used extension just reflects the actual contents), but the update mechanism doesn't check for size or extension, it just checks the contents.

DPJames
Posts: 11
Joined: Mon Jan 02, 2012 6:58 pm

Re: HMND and TwonkyVision

Post by DPJames » Wed Jan 04, 2012 1:51 am

That works. I now have root access with telnet. Let's see what kind of damage I can do to Twonky...

Success!

I found the clients.db file in TwonkyVision/resources, copied it to a shared folder, changed the file permissions, copied it to my PC for editing (with a Unix-compatible text editor), made the recommended changes, copied it back to the resources folder, and restarted the NAS. Now I can stream mp4 video (only if the files are named m4v for some reason) and mpeg video files as well as avi, pause, skip forward/back, go to time index. Big improvement! No luck with mkv so far - everyone says Twonky doesn't support mkv, but it looks like people have had some limited success by spoofing the MIME type in the clients.db file as long as the DLNA client supports mkv.

Thanks for the really useful help here on this site and in this forum.

Update on mkv and mp4 video file support between Twonky on the NAS and my Samsung BD-C5500 Blu-Ray client:

I read everything I could find on other people's experiments and tried a bunch of my own, without success.

No luck with mkv. Darn! Most of my DVD rips are Handbrake H264 mkv, and play just fine on the Samsung player from a local USB drive. Twonky seems to recognize the mkv file type as video, but will not stream it successfully to the Samsung with any combination of different mkv variations produced by different programs from different source media with any of the suggested mime types. I tried dozens of variations. Some produced different behavior, and sometimes it looked like the Samsung was really trying to start playing the stream. In some cases it looked like it thought it actually had played the video. But in the end, no video with any of them. Some people have claimed partial success, but without providing details, and they may have been using Twonky 6 running on a PC.

Also no luck with mp4, although m4v works. Most of my "mp4" files were actually generated as m4v files, and will play on anything that plays mp4 files, whether named as m4v or mp4 (including my iPod Touch and my HP TouchPad as well as the Samsung Blu-Ray from a local drive). Twonky will stream them successfully to the Samsung Blu-Ray player if they are named m4v, but not if they are named mp4. I tried generating some test files in iPad mp4 format from various programs, and none of them worked with Twonky/Samsung combination. Either Twonky didn't like the mp4 format and refused to see the file as video at all, or it would not stream successfully to the Samsung (although it would stream to others like the iPod Touch, and would play on the Samsung from local storage).

Do you ever get the feeling that DLNA isn't much of a standard? :-)

DPJames
Posts: 11
Joined: Mon Jan 02, 2012 6:58 pm

Re: HMND and TwonkyVision

Post by DPJames » Sat Jan 07, 2012 8:08 pm

For what it's worth for anyone else experimenting with DLNA on the Iomega Home Media Network Hard Drive, here's what I found:

With the stock firmware 2.064 (Twonky version 4.4.16), using my Samsung BDC-5500 Blu-Ray player (DLNA 1.5 compliant) as my primary video client:

AVI - plays, but can't pause/skip/goto-time-index/ff/rw
MPEG - plays, but can't pause/skip/goto-time-index/ff/rw
MP4 - recognized, but can't play
M4V - some files play, but can't pause/skip/goto-time-index/ff/rw
MKV - recognized, but can't play

Not very useful before modification, but...

After modifying the Twonky config.db file to add the Samsung settings to profile ID:049 (primarily the line DL:MP4DLNA), the Samsung compatibility improved:

AVI - plays, and can pause/skip/goto-time-index, can't ff/rw
MPEG - plays, and can pause, but can't skip/goto-time-index/ff/rw
MP4 - recognized, but can't play
M4V - some files play, and can pause/skip/goto-time-index, can't ff/rw (*see below)
MKV - recognized, but can't play

Not ideal, but better.

It's ironic that Twonky doesn't seem to handle MP4 files, considering that they are identical to M4V with just the extension changed.

With some other portable device clients, including iPod Touch 4th gen (Media Link Player app) and HP Touchpad (uPnP AV Player and BHome apps):

MP4 - not recognized
M4V - play fine, can pause and goto-time-index (no ff/rw/skip functions in apps)
other file types not supported by these clients

* After considerable experimentation, the problem with playing some M4V files on the Samsung turns out to be the text track added by Handbrake to represent chapters. The files play correctly with the text track removed (using YAMB). Odd, since these file with the text track are streamed by Twonky to the iPod and TouchPad without problems, and the Samsung plays them just fine from a local USB drive. Oh well! Just another DLNA glitch...

Further experimentation shows that Twonky 4 also can't handle mp4/m4v files with multiple audio tracks - they don't show up at all. I'm guessing the Twonky folks didn't do much testing on this version...

Apparently Twonky version 4 can't handle mkv files at all, although it seems to recognizes them as video files. I didn't see anyone reporting any success at all with Twonky version 4. I suppose it might be possible to upgrade the version of Twonky on the NAS to 5 or 6, but I've no idea how to find the license key for the installed version.

As for the other DLNA media types, photos and music stream ok. Music even includes album art, although for some reason the Samsung reports the artist/album name as "unknown" when it plays an individual track, even though it was able to access folders by Artist at the higher level.

The rest of the NAS functionality works just fine for the most part. A disk benchmark test shows max read speed about 12 Mbytes/sec and write speed about 11 Mbytes/sec over the 100 mb/sec ethernet connection, which is fairly close to the ethernet capacity. File read/write speed more like 10/8 Mbytes/sec, which seems slow compared to a local USB drive, but it serves the purpose as shared storage with my Windows computers. I haven't tested it with Gigabit ethernet speed.

Remote internet access via the web console using dyndns and port remapping in my router works fine, no need to fool around with Iomega's remote access setup software and TZO. There are some minor bugs though. Very large files (e.g., 200 Gbyte disk backup) don't show up at all when accessing folders via the web interface. For some reason I can't download anything from the "backups" folder, although the same files download from other folders. The zip archive that the NAS creates automatically when downloading mp3 files has an invalid format and needs to be repaired to open with WinZip. With other file types the downloaded zip archive is fine.

The local USB port works for accessing USB drives, and for sharing my Canon ink-jet printer over the network (although many others reported failure with their printers).

Torrent downloads work fine once set up correctly, and I've seen it hit a reasonable speed (>500 Kbytes/sec). Seems to open the proper ports in the router via UPnP. I didn't try any of the other stuff like FTP, Facebook and Email uploads.

The NAS is quiet in operation, and it only draw about 12 watts according to my power meter, even though it doesn't seem to ever spin down the disk for power saving. It still draws about 4 watts when turned off though. It seems to run fairly cool, and I haven't noticed the fan running.

Once a long while it makes some alarming clicking sounds which I hope don't indicate a hard drive reset due to a read error.
Last edited by DPJames on Wed Jan 25, 2012 6:54 pm, edited 3 times in total.

itmind
Posts: 4
Joined: Tue Jan 10, 2012 7:08 am

Re: HMND and TwonkyVision

Post by itmind » Tue Jan 10, 2012 7:13 am

Twonky support mkv and transcoding.
See my post in http://forum.ixbt.com/topic.cgi?id=11:42830-6 (install ffmpeg and enable streaming mkv)

DPJames
Posts: 11
Joined: Mon Jan 02, 2012 6:58 pm

Re: HMND and TwonkyVision

Post by DPJames » Tue Jan 10, 2012 4:03 pm

itmind wrote:Twonky support mkv and transcoding.
See my post in http://forum.ixbt.com/topic.cgi?id=11:42830-6 (install ffmpeg and enable streaming mkv)
If I understand correctly your post in the referenced thread (in Russian), you are installing ffmpeg and using it for transcoding mkv to mpeg. Wouldn't that be too much of a burden on the low-power NAS CPU? I note that your thread is in the Cloud Edition forum. Maybe you are using the Cloud Edition, which has a faster CPU?

Post Reply