PLEASE HELP: Cannot see new created folders under /nethdd

Post Reply
nanalisa
Posts: 18
Joined: Sat Feb 11, 2012 7:24 am

PLEASE HELP: Cannot see new created folders under /nethdd

Post by nanalisa » Fri Feb 17, 2012 6:07 am

Hi everybody.

The firmware of my HMNHD is 2.064.
It is connected to my main router via ethernet.

Logged in via SSH I created new directories in the /nethdd/ folder, such as
/nethdd/backups/xChange/
/nethdd/photos/Bilderkes/
and so on.

I was expecting them to appear in the windows explorer below the existing folders (/nethdd/backups/ and /nethdd/photos/).

Unfortunately this is not the case. I can still see them in PuTTY (including the data in them) but not in Windows. Even in the Iomega Home Storage Manager they don't appear.

What can I do?

Please bear in mind that I am a newbie to linux server manipulation and give detailed instructions.
Thank you very much in advance!

Driminicus
Posts: 160
Joined: Fri Apr 08, 2011 9:59 am

Re: PLEASE HELP: Cannot see new created folders under /nethd

Post by Driminicus » Mon Feb 20, 2012 1:40 pm

the HMNDH uses samba to share folders with windows.
In short you need to configure samba to share the folders you created in the /nethdd folder.
You could do this manually, editing the samba configuration file. (you can find it here: /etc/samba/smb.conf)
It is, however, way easier to use the http frontend created by iomega (http://*yournasip*/).
you go to folders and click at the bottom on the folder with a + logo.

nanalisa
Posts: 18
Joined: Sat Feb 11, 2012 7:24 am

Re: PLEASE HELP: Cannot see new created folders under /nethd

Post by nanalisa » Mon Feb 20, 2012 4:30 pm

Driminicus wrote:you go to folders and click at the bottom on the folder with a + logo.
Hey, thanks for the reply.
Unfortunately this doesn't do what I want.
It just adds folders on the same level as the existing ones and doesn't make the ones visible which I already created via SSH/PuTTY under the /nethd folder.

So I will have to stick to the idea of Samba configuration.
Driminicus wrote:the HMNDH uses samba to share folders with windows.
In short you need to configure samba to share the folders you created in the /nethdd folder.
You could do this manually, editing the samba configuration file. (you can find it here: /etc/samba/smb.conf)
Thanks. The configuration file shows the following:

Code: Select all

        workgroup = wasserwerk
        server string = Home Media Network Hard Drive
        security = user
        map to guest = Bad User
        use sendfile = yes
        hide dot files = yes
        veto files = /.AppleDouble/.AppleDB/.AppleDesktop/:2eDS_Store/:2eTemporaryItems/Network Trash Folder/Temporary Items/
        encrypt passwords = yes
        smb passwd file = /etc/samba/smbpasswd
        socket options = TCP_NODELAY SO_RCVBUF=16384 SO_SNDBUF=16384
        dns proxy = no
        local master = no
        os level = 20 #ensure that we lose a browser election
        domain master = no
        preferred master = no
        max xmit = 65535
        username level = 16
        disable spoolss = yes
        stat cache = no
        null passwords = yes
        log level = 0
        winbind enum users = yes
I can't find anything to tell the system to show me (or not to show me) the folders which I can see via PuTTY/SSH under /nethdd ( such as /nethdd/backups/myBackups and /nethdd/photos/Bilderkes)..
Any ideas?

nanalisa
Posts: 18
Joined: Sat Feb 11, 2012 7:24 am

Re: PLEASE HELP: Cannot see new created folders under /nethd

Post by nanalisa » Mon Feb 20, 2012 4:37 pm

S O R R Y ! ! !

I just found out, that I have just been seeing a part of the file.

Here is the whole of it:

Code: Select all

[global]
        workgroup = wasserwerk
        server string = Home Media Network Hard Drive
        security = user
        map to guest = Bad User
        use sendfile = yes
        hide dot files = yes
        veto files = /.AppleDouble/.AppleDB/.AppleDesktop/:2eDS_Store/:2eTemporaryItems/Network Trash Folder/Temporary Items/
        encrypt passwords = yes
        smb passwd file = /etc/samba/smbpasswd
        socket options = TCP_NODELAY SO_RCVBUF=16384 SO_SNDBUF=16384
        dns proxy = no
        local master = no
        os level = 20 #ensure that we lose a browser election
        domain master = no
        preferred master = no
        max xmit = 65535
        username level = 16
        disable spoolss = yes
        stat cache = no
        null passwords = yes
        log level = 0
        winbind enum users = yes
- /etc/samba/smb.conf 1/152 0%
        path = /nethdd/backup/
        preallocate = yes
        vfs objects = netatalk
        write list =
        read list =
        guest ok = yes
[printers]
        path = /var/spool/lpd/samba/
        printable = yes
        print command = /usr/bin/lpr -P%p -r %s
        lpq command = /usr/bin/lpq -P%p
        lprm command = /usr/bin/lprm -P%p %j
        lppause command = /usr/sbin/lpc hold %p %j
        lpresume command = /usr/sbin/lpc release %p %j
        queuepause command = /usr/sbin/lpc stop %p
        queueresume command = /usr/sbin/lpc start %p
        guest only = yes
[photos]
        writable = yes
        wide links = no
        force user = nobody
        map archive = yes
        create mask = 0777
        directory mask = 0777
        comment =
        path = /nethdd/media/pictures/
        preallocate = yes
        vfs objects = netatalk
        write list =
        read list =
        guest ok = yes
[airlive_4]
        writable = yes
        wide links = no
        force user = nobody
        map archive = yes
        create mask = 0777
        directory mask = 0777
        path = /nethdd//airlive_4
        vfs objects = netatalk
        write list =
        read list =
        guest ok = yes
So I guess, for example if I want to change anything for the photos folder, I have to look at the part of [photos].
OK - but what do I need to change so I can see the folder /nethdd/photos/Bilderkes?

Driminicus
Posts: 160
Joined: Fri Apr 08, 2011 9:59 am

Re: PLEASE HELP: Cannot see new created folders under /nethd

Post by Driminicus » Mon Feb 20, 2012 6:20 pm

Oh, I might have misunderstood, so lets check before we continue:

You have a shared folder called /nethdd/backups
You should be able to see this folder when you browse to your nas in windows. Correct?

You have created a subfolder in /nethdd/backups. This is called xChange, right?
I assume you did not create this using samba (ie, not from windows explorer?)

However, browsing to the folder via explorer, the subfolder does not show up, right?

Samba should share folders and their subfolders. (you could add a new share in the samba config file, this will make a new folder in the root of your nas.)

What I think is happening is that the permissions of the folders are set wrong.
You can check this by going to the folder /nethdd/backups in putty and using "ls -l"
You'll see something like -rwxrwxrwx in front of the folder. More info here.

If I'm right you don't have permission to view the folder from samba. You can change permissions using chmod.

nanalisa
Posts: 18
Joined: Sat Feb 11, 2012 7:24 am

Re: PLEASE HELP: Cannot see new created folders under /nethd

Post by nanalisa » Mon Feb 20, 2012 6:48 pm

First of all: thank you very much for your effort in understanding my problem!!!!
Driminicus wrote:Oh, I might have misunderstood, so lets check before we continue:

You have a shared folder called /nethdd/backups
You should be able to see this folder when you browse to your nas in windows. Correct?
Yes, that is correct.
Driminicus wrote:You have created a subfolder in /nethdd/backups. This is called xChange, right?
I assume you did not create this using samba (ie, not from windows explorer?)
That is correct, as well. I created this folder using putty.
Driminicus wrote:However, browsing to the folder via explorer, the subfolder does not show up, right?
Yes, that is exactly my problem.
Driminicus wrote:Samba should share folders and their subfolders. (you could add a new share in the samba config file, this will make a new folder in the root of your nas.)
Right, but that is not what I want.
Driminicus wrote: What I think is happening is that the permissions of the folders are set wrong.
You can check this by going to the folder /nethdd/backups in putty and using "ls -l"
You'll see something like -rwxrwxrwx in front of the folder. More info here.

If I'm right you don't have permission to view the folder from samba. You can change permissions using chmod.
The output of ls -l in the folder /nethdd/backups is the following:

Code: Select all

root@Iomega:/nethdd/backups# ls -l
total 0
drwxr-xr-x 3 root root 20 Feb 15 10:57 xChange
If I understand it right, this means that user class has full permissions and group and others classes have only the read and execute permissions.

Anyway I changed it to the following:

Code: Select all

root@Iomega:/nethdd/backups# chmod 777 xChange
root@Iomega:/nethdd/backups# ls -l
total 0
drwxrwxrwx 3 root root 20 Feb 15 10:57 xChange
I even restarted samba

Code: Select all

root@Iomega:/nethdd/backups# sh /etc/init.d/samba restart
Stopping Samba daemons: nmbd smbd.
Starting Samba daemons: nmbd smbd.
But unfortunately I still cannot see the folder backups/xChange in Windows Explorer. :-/

nanalisa
Posts: 18
Joined: Sat Feb 11, 2012 7:24 am

Re: PLEASE HELP: Cannot see new created folders under /nethd

Post by nanalisa » Mon Feb 20, 2012 7:11 pm

Oh-oh-oh.

I am very sorry!

Again, I didn't look closeley enough.
I had a couple of typos, e.g. the folder backup was not the one in question but the folder backups.

The same is valid for some other folders. I will sort this out and try to make everything visible in Windows. It worked for my backup folder already, I can see it in Windows now.

Thank you very much anyway for your help, it opened my eyes to see the fault.

Post Reply