General NAS-Central Forums

Welcome to the NAS community
It is currently Mon May 22, 2017 3:25 pm

All times are UTC




Post new topic Reply to topic  [ 1 post ] 
Author Message
PostPosted: Tue Jun 23, 2015 2:29 pm 
Offline

Joined: Thu Jun 04, 2015 8:06 am
Posts: 4
Recently I tried to upgrade my firmware in my ix2-ng box and the box bricked leaving me with 2 TB of replicated data on 2 disks which I couldn't access. With the help of this forum and other I managed to get to my data so that I could copy it to a new disk. This post will outline my steps. I had virtually no experience with linux before and was somewhat intimidated. A little perserverance in my case paid off.
Here are the steps I took. Some may be superfluous as it was mainly trial and error (much error).
First I downloaded and created a bootable ubuntu boot disk using the instructions and image from this site:
http://www.ubuntu.com/download/desktop/create-a-usb-stick-on-windows
there are other linux bootables on the web but they didn't work for me.
I connected one of the disks from the NAS box to an old computer and booted it with my USB stick.
(I ended up using the 2nd disk of the raid but I don't think it matters, unless one is bad).

Being a windows guy I immediately started the graphic gui. I clicked on the top icon on the left which has a circle inside a triangle and says "search for programs on your computer"
I then clicked on the disks icon which showed me the connected raid disk and 3 partitions. The large one was the one with all my data and it was labeled
Device: /dev/sda2
Partition type: Basic Data
Contents: Linux RAID Member

Then I opened the terminal program and got the prompt
Code:
root@ubunto: ~#


I created a directory that I would eventually mount the disk on
Code:
mkdir media/mine


Now comes the part where you rebuild the raid data
Mainly I followed this post
http://pissedoffadmins.com/os/mount-unknown-filesystem-type-lvm2_member.html

first install raid controller software:
Code:
sudo apt-get install mdadm

Then you need become a superuser:
Code:
sodu su

Code:
root@ubuntu:~# mdadm --assemble --run /dev/md0 /dev/sda2

this was the result
Code:
mdadm: /dev/md0 has been started with 1 drive (out of 2).


I then left it running for several hours. I have no idea how long it took to complete. it is probably much less tiem.
Code:
root@ubuntu:~# lvscan

I got this response:
Code:
inactive          '/dev/1ee26577_vg/lv3249210a' [1.80 TiB] inherit


then the following:
Code:
vgchange -ay

getting this response
Code:
 1 logical volume(s) in volume group "1ee26577_vg" now active

And now the final step:
Code:
mount /dev/1ee26577_vg/lv3249210a /media/mine


Afterwards I opened the graphic file explorer. clicked to media/mine and found all my files.

Copying to a network share was easy as there is a control panel in the gui that will allow one to connect to windows shares on the network.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group