Enable Twonky Configuration

Post Reply
s016aq
Posts: 17
Joined: Thu Nov 11, 2010 3:32 pm

Enable Twonky Configuration

Post by s016aq » Thu Nov 11, 2010 3:35 pm

Hi!
I just got my Wireless Space today
When I try to access it with port 9000, it tells me 'Access is restricted'
I've read the thread on how to enable it on the Network Space 2, but it doesn't seem to work....
Anyone know how to do this on the Wireless Space ?

Regards
/Patrik

Mijzelf
Posts: 6198
Joined: Mon Jun 16, 2008 10:45 am

Re: Enable Twonky Configuration

Post by Mijzelf » Thu Nov 11, 2010 3:40 pm

Do you have ssh access? In that case you can redirect localhost:9000 on your PC to localhost:9000 on the NAS, and try to access it that way.

s016aq
Posts: 17
Joined: Thu Nov 11, 2010 3:32 pm

Re: Enable Twonky Configuration

Post by s016aq » Thu Nov 11, 2010 5:39 pm

I've changed my hosts-file to point localhost to 192.168.1.1
And then i try to connect to http://localhost:9000

Same error.
I'm guessing that's not what you meen ?

I have enabled ssh-server in the settings of wireless space

Regards
/Patrik

Mijzelf
Posts: 6198
Joined: Mon Jun 16, 2008 10:45 am

Re: Enable Twonky Configuration

Post by Mijzelf » Thu Nov 11, 2010 10:37 pm

Indeed, that is not what I mean. Because the firmware is able to access the Twonky settings, I suppose that connections from the box itself are accepted.
It's a bit impractical to run a browser on the box itself, but fortunately ssh has an option which is called 'tunneling', which gives the advantage to forward a port to the host system.
When you run ssh from commandline, you can give the command:

Code: Select all

ssh -L 9000:localhost:9000 <username>@<name-or-ip-address>
Now port 9000 on your localhost is forwarded through a tunnel, and connects on the box to localhost:9000. So Twonky doesn't know that it's a connection from the outside.

You can also do this with PuTTY, but I can't remember exactly how. Somewhere in settings->ssh->tunneling.

s016aq
Posts: 17
Joined: Thu Nov 11, 2010 3:32 pm

Re: Enable Twonky Configuration

Post by s016aq » Sat Nov 13, 2010 4:26 pm

Hi again!
I think I did what you suggest, but no luck. Same error.

I've figured out that twonky start with configurations from the file:
/lacie/var/userPar/conf/twonky/mediaserver.ini
That file seems to be binary...
But right next to it there's a file called mediaserver.ini.8
And if I in that file change the entry 'enableweb' from 0 to 2
Deletes the binary mediaserver.ini and renames mediaserver.ini.8 to mediaserver.ini
And then start/stop twonky, I can connect to the webinterface.
However.
The changes I make dissapears when I restart Twonky.
And when I restart the Wireless Space, I can no longer connect to it with :9000
The mediaserver.ini.8 is back!

Any ideas ????

Mijzelf
Posts: 6198
Joined: Mon Jun 16, 2008 10:45 am

Re: Enable Twonky Configuration

Post by Mijzelf » Sun Nov 14, 2010 2:14 pm

s016aq wrote:Any ideas ????
Looking at the Wiki, I think that the firmware is in flashrom, which is (semi-) readonly. So your modifications exist only in RAM, and are lost at each reboot.
You'll have to find to run a script at boot, which make the modifications for you.

olihey
Posts: 10
Joined: Fri Oct 01, 2010 2:20 pm

Re: Enable Twonky Configuration

Post by olihey » Tue Nov 16, 2010 11:53 am

Hej,

Try modifying the file

/lacie/default/mediaserver.ini.klaxon

to make changes reboot-safe!

Need to be root to do that ;)

s016aq
Posts: 17
Joined: Thu Nov 11, 2010 3:32 pm

Re: Enable Twonky Configuration

Post by s016aq » Tue Nov 16, 2010 9:04 pm

Hej!
I've made it!
(Thanks for your tip olihey, but I did it anonther way..)

Here's how:
Change to 'enableweb=2' in /lacie/var/userPart/conf/twonky/mediaserver.ini.8
copy /lacie/var/userPart/conf/twonky/mediaserver.ini.8 to /lacie/var/userPart/share/OpenShare/Twonky/mediaserver.ini
change INIFILE="${WORKDIRINI}/mediaserver.ini" to INIFILE="/lacie/var/userPart/share/OpenShare/Twonky/mediaserver.ini"
in both /lacie/etc/init.d/mediaserver & /etc/init.d/mediaserver

Now everything works.
And it sticks on a reboot.

I'm so happy!

Why does Lacie block this ?
Why shouldn't we be able to change Twonky-settings ?
I don't get it.

anyway
Case Closed!

/Patrik

Mijzelf
Posts: 6198
Joined: Mon Jun 16, 2008 10:45 am

Re: Enable Twonky Configuration

Post by Mijzelf » Tue Nov 16, 2010 9:10 pm

s016aq wrote:Why shouldn't we be able to change Twonky-settings ?
I can think of 2 reasons:
1) The Twonky interface is not designed by Neil Poulton. (or doesn't fit in Lacie's idea of GUI)
2) The license Lacie bought for Twonky excludes the interface.

Don't know of either of these reasons is true.

jib
Posts: 5
Joined: Tue Jan 04, 2011 9:45 pm

Re: Enable Twonky Configuration

Post by jib » Tue Jan 04, 2011 9:49 pm

I've been able to access the configuration page, thanks to s016aq. But what a surprise : this is a very very old version of Twonky (4.4.18, from 2008). And this version is not really a good version, especially for my Samsung DLNA TV. I'm not sure if LaCie is planning to update this version, as in the Network Space 2 ?

But, did someone managed to update this version ?

19pacman73
Posts: 7
Joined: Sat Mar 26, 2011 1:47 pm

Re: Enable Twonky Configuration

Post by 19pacman73 » Sat Mar 26, 2011 1:49 pm

hi,
can anyone tell me how go gain root access on a wireless network space...

highly apreciated
thnx,

pacman

jotsetung
Posts: 2
Joined: Thu May 12, 2011 5:20 pm

Re: Enable Twonky Configuration

Post by jotsetung » Thu May 12, 2011 7:32 pm

s016aq wrote:Hej!
I've made it!
(Thanks for your tip olihey, but I did it anonther way..)

Here's how:
Change to 'enableweb=2' in /lacie/var/userPart/conf/twonky/mediaserver.ini.8
copy /lacie/var/userPart/conf/twonky/mediaserver.ini.8 to /lacie/var/userPart/share/OpenShare/Twonky/mediaserver.ini
change INIFILE="${WORKDIRINI}/mediaserver.ini" to INIFILE="/lacie/var/userPart/share/OpenShare/Twonky/mediaserver.ini"
in both /lacie/etc/init.d/mediaserver & /etc/init.d/mediaserver

Now everything works.
And it sticks on a reboot.

I'm so happy!

Why does Lacie block this ?
Why shouldn't we be able to change Twonky-settings ?
I don't get it.

anyway
Case Closed!

/Patrik
hi,
yep, works like a marvel. I was however not able to modify the /lacie/etc/init.d/mediaserver file, it said "read only file system". did you re-mount the file system rw, and if yes, how?

cheers, jo

s016aq
Posts: 17
Joined: Thu Nov 11, 2010 3:32 pm

Re: Enable Twonky Configuration

Post by s016aq » Thu May 12, 2011 7:56 pm

Hi Jotsetung,
You have to go to the following url:
http://192.168.1.1/cmd.php?mode=exec&cm ... unt,rw%20/

Just like you did when you enabled root access!

Good luck
/Patrik

Post Reply