General NAS-Central Forums

Welcome to the NAS community
It is currently Tue Oct 24, 2017 9:31 am

All times are UTC




Post new topic Reply to topic  [ 71 posts ]  Go to page Previous  1, 2, 3, 4, 5  Next
Author Message
PostPosted: Mon Sep 05, 2016 4:24 pm 
Offline
User avatar

Joined: Mon Dec 21, 2015 7:21 pm
Posts: 597
michielvv wrote:
Every time Deluge is downloading for a couple of minutes, it crashes with the following error:

Code:
terminate called after throwing an instance of 'boost::bad_weak_ptr'
  what():  tr1::bad_weak_ptr


It looks like a boost error for me... This command reinstalls all deluge tools from br2 repository:

Code:
slacker -UaA br2:deluge/


Edit: I tried the deluge now, and it works for me.

_________________
Thanks nas-central the lot of help! :)


Top
 Profile  
 
PostPosted: Mon Sep 05, 2016 6:46 pm 
Offline

Joined: Sat Aug 27, 2016 10:59 am
Posts: 16
I tried this, but it does not work (still crashing).

I also tried installing the newest Deluge version which in itself was successful. However it still errors. When i look at the debug log of deluge i do not find anything wrong...

These are the deluge packages i have installed:"

Code:
boost boost-1.57.0-arm-1 boost-1.57.0-arm-1 br2:deluge/boost-1.57.0-arm-1.txz
geoip geoip-1.6.3_git20141110-arm-1 geoip-1.6.3_git20141110-arm-1 br2:deluge/geoip-1.6.3_git20141110-arm-1.txz
icu4c icu4c-54.1-arm-1 icu4c-54.1-arm-1 br2:deluge/icu4c-54.1-arm-1.txz
libffi libffi-3.1-arm-1 libffi-3.1-arm-1 br2:deluge/libffi-3.1-arm-1.txz
libtorrent libtorrent-1.0.6_git0f2f144-arm-2 libtorrent-1.0.6_git0f2f144-arm-2 br2:deluge/libtorrent-1.0.6_git0f2f144-arm-2.txz


Any version differences?


Top
 Profile  
 
PostPosted: Mon Sep 05, 2016 7:49 pm 
Offline
User avatar

Joined: Mon Dec 21, 2015 7:21 pm
Posts: 597
I have one more idea, but it is also in the first post. Try to upgrade uClibc and the solibs to the latest version!

Code:
slacker -uiA br2:{uClibc,uClibc-solibs}

_________________
Thanks nas-central the lot of help! :)


Top
 Profile  
 
PostPosted: Mon Sep 05, 2016 8:03 pm 
Offline

Joined: Sat Aug 27, 2016 10:59 am
Posts: 16
Hey,

Thanks for sticking with me. Unfortunately, this does not work either. I have installed the following uClib:
Code:
uClibc uClibc-0.9.33.3_git-arm-8 uClibc-0.9.33.3_git-arm-8 br2:uClibc-0.9.33.3_git-arm-8.txz
uClibc-solibs uClibc-solibs-0.9.33.3_git-arm-8 uClibc-solibs-0.9.33.3_git-arm-8 br2:uClibc-solibs-0.9.33.3_git-arm-8.txz


In addition, i upgraded some packages using:
Code:
slacker -UaA br2:{wget,openssl,openssh}

And:
Code:
pip install -U $(pip list --outdated | awk '!/Could not|ignored/ { print $1}')


(from here: viewtopic.php?f=249&t=10881&start=660)

This did identify older packages and upgraded them.

However, nothing helps.

One thing springs in mind: i am currently copying lots of GBs over the network towards my NAS. As it is, it caches in RAM leaving not so much memory left. Would there be any relation with that? E.g. that the cache hinders Deluge from getting enough memory it suddenly needs?

Code:
             total       used       free     shared    buffers     cached
Mem:       1011656     958992      52664          0       9116     499852
-/+ buffers/cache:     450024     561632
Swap:      1998780       4324    1994456



Thanks for the help so far!

Michiel


Top
 Profile  
 
PostPosted: Tue Sep 06, 2016 5:19 am 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2303
michielvv wrote:
Guys,

Every time Deluge is downloading for a couple of minutes, it crashes with the following error:

Code:
terminate called after throwing an instance of 'boost::bad_weak_ptr'
  what():  tr1::bad_weak_ptr


I use Deluge 1.3.11 with libtorrent-1.0.5_svn11115-arm-2

How can i fix this? I found something regarding "BOOST_SP_USE_PTHREADS" to use when compiling, but i do not know how this works?

Regards, Michiel


Seems like identical issue:
https://github.com/arvidn/libtorrent/issues/317

Which NAS has you?
Also paste outputs:
Code:
uname -mr
Code:
cat /proc/cpuinfo


Top
 Profile  
 
PostPosted: Tue Sep 06, 2016 5:58 am 
Offline

Joined: Sat Aug 27, 2016 10:59 am
Posts: 16
Code:
3.2.54 armv7l


Code:
Processor       : ARMv7 Processor rev 1 (v7l)
processor       : 0
BogoMIPS        : 1196.85

processor       : 1
BogoMIPS        : 1196.85

Features        : swp half thumb fastmult vfp edsp neon vfpv3 tls
CPU implementer : 0x41
CPU architecture: 7
CPU variant     : 0x2
CPU part        : 0xc09
CPU revision    : 1

Hardware        : Comcerto 2000 EVM
Revision        : 0001
Serial          : 0000000000000000


Top
 Profile  
 
PostPosted: Tue Sep 06, 2016 6:24 am 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2303
Ok. Looks like we found the culprit. I suspect it is the case, which arvidn mentioned, regarding some ARM chips. It wasn't and there is no problems with armv5 chips, but you have armv7.
I will try to compile libtorrent this evening with additional CXXFLAGS=-DBOOST_SP_USE_PTHREADS and we will see.
Will keep you in touch.


Top
 Profile  
 
PostPosted: Tue Sep 06, 2016 8:24 am 
Offline

Joined: Sat Aug 27, 2016 10:59 am
Posts: 16
Thanks - Very much appreciated!


Top
 Profile  
 
PostPosted: Tue Sep 06, 2016 9:04 am 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2303
One more thing. Which gcc version you have?
Code:
funpkg -q gcc


Top
 Profile  
 
PostPosted: Tue Sep 06, 2016 12:22 pm 
Offline

Joined: Sat Aug 27, 2016 10:59 am
Posts: 16
Code:
gcc-4.9.2-arm-1
gcc-solibs-4.9.2-arm-1


Top
 Profile  
 
PostPosted: Tue Sep 06, 2016 1:27 pm 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2303
Round 2. Install updates:
Code:
cd /ffp/funpkg/cache/br2
wget http://downloads.zyxel.nas-central.org/Users/barmalej2/ffp/0.7/arm/packages/testing/deluge-1.3.13_git20160906-arm-2.txz
wget http://downloads.zyxel.nas-central.org/Users/barmalej2/ffp/0.7/arm/packages/testing/libtorrent-1.0.10_gite650ecc-arm-2.txz
funpkg -u libtorrent-1.0.10_gite650ecc-arm-2.txz deluge-1.3.13_git20160906-arm-2.txz
sh /ffp/start/deluged.sh restart

Report if you encounter any problems.


Top
 Profile  
 
PostPosted: Tue Sep 06, 2016 2:05 pm 
Offline

Joined: Sat Aug 27, 2016 10:59 am
Posts: 16
Hi!

Thanks for compiling the packages. This however does not start. Deluged is start for about a couple of seconds and then crashes without any error message. I tried combinations with this newer and the older deluged version, but it does not work. I also did a pip --update for the packages which did update cffi, but also did not work.

This is my PIP list:

Code:
attrs (16.1.0)
cffi (1.8.2)
chardet (2.3.0)
Cheetah (2.4.4)
cryptography (1.5)
deluge (1.3.13)
enum34 (1.1.6)
feedparser (5.2.1)
Glances (2.6.2)
idna (2.1)
ipaddress (1.0.16)
lxml (3.6.4)
Mako (1.0.4)
Markdown (2.6.6)
MarkupSafe (0.23)
Pillow (3.3.1)
pip (8.1.2)
psutil (4.3.1)
pyasn1 (0.1.9)
pyasn1-modules (0.0.8)
pycparser (2.14)
pyOpenSSL (16.1.0)
pysqlite (2.8.3)
python-libtorrent (1.0.10)
pyxdg (0.25)
service-identity (16.0.0)
setproctitle (1.1.10)
setuptools (26.1.1)
six (1.10.0)
Twisted (16.4.0)
zope.interface (4.3.2)


BTW i got this error when installing the uClib* :

Code:
Reinstalling uClibc-0.9.33.3_git-arm-8
Removing uClibc-0.9.33.3_git-arm-8,reinstalled,20160906_160559
Running doinst.sh ...
IMPORTANT NOTICE: Fully compatible with Zyxel NSA 3** series NAS'es.
Other devices with kernel different from 2.6.31.8 are only partly compatible.
This release doesn't has UTF-8 locales support.


Has this something to do with that? All my other programs run just fine (e.g. Couchpotato, Sickrage, Headphones, Plex).


Top
 Profile  
 
PostPosted: Tue Sep 06, 2016 2:10 pm 
Offline

Joined: Sat Aug 27, 2016 10:59 am
Posts: 16
Set it to debug:

Code:
[DEBUG   ] 16:08:15 torrentmanager:298 Attempting to create torrent_info from /ffp/var/lib/deluge/state/--LOTS OF HEX REMOVED--.torrent


this is where it crashes i think.

EDIT: when i rename the state folder (so it will not load old torrents in progress), deluged will start, but as soon as i add a torrent, it crashes again. Must be something with libtorrent?

reg, M


Top
 Profile  
 
PostPosted: Tue Sep 06, 2016 4:03 pm 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2303
michielvv wrote:
when i rename the state folder (so it will not load old torrents in progress), deluged will start, but as soon as i add a torrent, it crashes again. Must be something with libtorrent?

Most likely. People on deluge forum reported a lot problems with libtorrent 1.1 and deluge developer states, that deluge-1.3.13 is compatible up to libtorrent 1.09 version only. I will build lt 1.09 version tomorrow for testing.
What is crash output now, when you add torrent?


Top
 Profile  
 
PostPosted: Wed Sep 07, 2016 8:22 am 
Offline

Joined: Sat Aug 27, 2016 10:59 am
Posts: 16
Hey,

There is no crash reporting. The debug log stops with the line of text as provided...


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 71 posts ]  Go to page Previous  1, 2, 3, 4, 5  Next

All times are UTC


Who is online

Users browsing this forum: Google [Bot], Majestic-12 [Bot] and 76 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group