General NAS-Central Forums

Welcome to the NAS community
It is currently Thu Aug 17, 2017 1:44 pm

All times are UTC




Post new topic Reply to topic  [ 93 posts ]  Go to page Previous  1 ... 3, 4, 5, 6, 7
Author Message
PostPosted: Thu Mar 16, 2017 1:55 pm 
Offline

Joined: Sun Feb 05, 2017 12:55 pm
Posts: 21
Quote:
stty -F /dev/ttyUSB0 9600


I did this one already when I figured out that I did not have the cu package...
It did not make any difference.

I will try to install the cu package tonight and see if it can fix my problems.


Top
 Profile  
 
PostPosted: Thu Mar 16, 2017 7:03 pm 
Offline

Joined: Sun Feb 05, 2017 12:55 pm
Posts: 21
barmalej2 wrote:
Code:
slapt-get -u
slapt-get -i uucp


One more thing. Try to set baudrate on terminal:
Code:
stty -F /dev/ttyUSB0 9600

And recheck domoticz.


I could install the package just find and when running:

Code:
cu -l /dev/ttyUSB0 -s 9600 --parity=even


I get an output which looks just fine:

Code:
/ISk5\2ME382-1004

0-0:96.1.1(4B414C37303035313338393938333133)
1-0:1.8.1(08234.559*kWh)
1-0:1.8.2(03543.334*kWh)
1-0:2.8.1(02018.359*kWh)
1-0:2.8.2(04940.602*kWh)
0-0:96.14.0(0002)
1-0:1.7.0(0000.46*kW)
1-0:2.7.0(0000.00*kW)
0-0:17.0.0(0999.00*kW)
0-0:96.3.10(1)
0-0:96.13.1()
0-0:96.13.0()
0-1:24.1.0(3)
0-1:96.1.0(3238303131303031333036303636343133)
0-1:24.3.0(170316190000)(00)(60)(1)(0-1:24.2.1)(m3)
(05479.482)
0-1:24.4.0(1)
!


However when running the command that is said to be the fix I get an error:

Code:
cu -l /dev/ttyUSB0 -s 9600 --parity=even|bash


Gives:

: No such file or directory004
bash: line 2: $'\r': command not found
bash: line 3: syntax error near unexpected token `4B414C37303035313338393938333133'
' bash: line 3: `0-0:96.1.1(4B414C37303035313338393938333133)

It doesn't say anything to me. Do you have any suggestions?


Top
 Profile  
 
PostPosted: Thu Mar 16, 2017 8:50 pm 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2290
lucaswiersma wrote:
However when running the command that is said to be the fix I get an error:

Code:
cu -l /dev/ttyUSB0 -s 9600 --parity=even|bash

This command makes no senses to me and is totally illogic. It passes all output from
Quote:
cu -l /dev/ttyUSB0 -s 9600 --parity=even
to bash command line, which only understands bash syntax, thus gives errors of executing code.
The obvious thing is that data is incoming via /dev/ttyUSB0, but domoticz is not getting (fetching) it. Why, I have no clue. Without having device to test I can only guess that some of others required devices nodes are missing or it is old kernel issue or something else.
It would be great, if you post this problem on domoticz forum. Maybe developer(s) or advanced users will be able to help to find out, where the key-reason is.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 93 posts ]  Go to page Previous  1 ... 3, 4, 5, 6, 7

All times are UTC


Who is online

Users browsing this forum: Bing [Bot], silax and 68 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group