Play sounds with nsa320s?

Marvell Kirkwood based
barmalej2
Posts: 2387
Joined: Sun Apr 29, 2012 5:24 pm

Re: Play sounds with nsa320s?

Post by barmalej2 » Wed Mar 16, 2016 7:16 pm

16:18:37 ERROR in core: ../src/xmms/plugin.c:388: Failed to open plugin /ffp/lib/xmms2/libxmms_avcodec.so: unknown dl-error
Forget about xmms2, if it can load own library. Looks like xmms2 source is really buggy.
/i-data/bf835951/build/mpd-0.19.13/src/system/fd_util.c:264: undefined reference to `accept4'
That is old problem for NSA3** series NAS'es. Syscalls like accept4() as well as ppoll, pselect6 or epoll_pwait was introduced only with 2.6.32 kernel on arm. We have 2.6.31.8 kernel :(
Fortunately there is a possible workaround (not so good like kernel native) using external libraries.
I will paste tomorrow evening mine mpd package. Imo, MPD configures and builds very cleanly. It should be solid, noteworthy and fast (written in C) music server I hope, but I unable to test it without sound card.

User avatar
MrDini
Posts: 651
Joined: Mon Dec 21, 2015 7:21 pm
Contact:

Re: Play sounds with nsa320s?

Post by MrDini » Wed Mar 16, 2016 9:17 pm

It should be solid, noteworthy and fast (written in C) music server I hope, but I unable to test it without sound card.
Of course, I will test it. :) Very interesting!
Thanks nas-central the lot of help! :)

barmalej2
Posts: 2387
Joined: Sun Apr 29, 2012 5:24 pm

Re: Play sounds with nsa320s?

Post by barmalej2 » Thu Mar 17, 2016 3:41 pm

MPD test package: http://downloads.zyxel.nas-central.org/ ... -arm-1.txz
Start script included.
Some info.
1. Config file - /ffp/etc/mpd.conf
2. Depends on these packages:
br2:ffmpeg2/ br2:alsa-lib br2:expat br2:gcc-solibs br2:gettext br2:glib br2:icu4c br2:sqlite
br2:uClibc-solibs mz:samba s:bzip2 uli:flac uli:libogg uli:libvorbis
3. Home directory - /ffp/opt/mpd

Good luck :roll:

User avatar
MrDini
Posts: 651
Joined: Mon Dec 21, 2015 7:21 pm
Contact:

Re: Play sounds with nsa320s?

Post by MrDini » Thu Mar 17, 2016 4:17 pm

barmalej2 wrote:MPD test package: http://downloads.zyxel.nas-central.org/ ... -arm-1.txz
Start script included.
Some info.
1. Config file - /ffp/etc/mpd.conf
2. Depends on these packages:
br2:ffmpeg2/ br2:alsa-lib br2:expat br2:gcc-solibs br2:gettext br2:glib br2:icu4c br2:sqlite
br2:uClibc-solibs mz:samba s:bzip2 uli:flac uli:libogg uli:libvorbis
3. Home directory - /ffp/opt/mpd

Good luck :roll:
Good job! Thanks a lot!

It works. But when I tried to start first time it said Alsa can't find card 0 or something similar. But the modules are loaded and I "mknod"-ded the soundcard to /dev/dsp and I have a mixer too. After I corrected the soundcard's details it started without any issues!!! :)

I have only one question... How Can I change the default volume? Because I have very loud sub-woofer and with the default value my house's floor is vibrating. :/

With the madplay and mplayer the volume is the same, but with manual (in case madplay) "-A -28" or (with mplayer) "-af volume=-28" the sounds are nice. Is there a way to change this value "system wide"?

Thanks again!
Thanks nas-central the lot of help! :)

barmalej2
Posts: 2387
Joined: Sun Apr 29, 2012 5:24 pm

Re: Play sounds with nsa320s?

Post by barmalej2 » Thu Mar 17, 2016 5:37 pm

MrDini wrote:After I corrected the soundcard's details it started without any issues!!! :)
Please provide more details in case someone else will be interested in.
MrDini wrote:I have only one question... How Can I change the default volume? Because I have very loud sub-woofer and with the default value my house's floor is vibrating. :/
You are user, not me. As I said, I don't have usb sound card. I would expect to get answer from you :)
Most likely clients can control volume. Another place to look is module (hardware driver) options. modinfo should reveal them.
And this wiki page source is exactly about volume control:
http://mpd.wikia.com/wiki/Alsa

User avatar
MrDini
Posts: 651
Joined: Mon Dec 21, 2015 7:21 pm
Contact:

Re: Play sounds with nsa320s?

Post by MrDini » Thu Mar 17, 2016 6:43 pm

Ok, sorry. The alsa-lib package was wrong.

There were the errors:

Code: Select all

root@NSA320S:/i-data/bf835951/build# mpd
ALSA lib confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib conf.c:4292:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:4292:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:4292:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:4771:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2266:(snd_pcm_open_noupdate) Unknown PCM default
So I recompiled it (you Can find it at my repo). And one more thing! I needed to modprobe the snd-pcm-oss driver to use it. I wrote about it at my Hungarian blog. Here is the article if anyone Can speak Hun.: http://logout.hu/bejegyzes/mr_dini/zene ... s-sel.html .

These are the modprobe commands, I'm used for my soundcard (you just need only once run it):

Code: Select all

modprobe snd-usb-audio index=0

mknod /dev/mixer c 14 0
mknod /dev/dsp c 14 3

modprobe snd-pcm-oss
modprobe snd-mixer-oss
I Can't find any working information about volume control. In a Rpi forum somebody said, I have to change the mixer_type "hardware" to mixer_type "software". So I uncommented it at the config, but it doesn't starts... Here is the change that I made:

Code: Select all

#audio_output {
        type            "alsa"
        name            "My ALSA Device"
##      device          "hw:0,0"        # optional
        mixer_type      "software"      # optional
##      mixer_device    "default"       # optional
##      mixer_control   "PCM"           # optional
##      mixer_index     "0"             # optional
#}
And the error:

Code: Select all

root@NSA320S:~# mpd
config_file: unrecognized parameter in config file at line 210: type
This package contains the whole mpd? When You configured it what options are disabled?
Thanks nas-central the lot of help! :)

barmalej2
Posts: 2387
Joined: Sun Apr 29, 2012 5:24 pm

Re: Play sounds with nsa320s?

Post by barmalej2 » Thu Mar 17, 2016 7:12 pm

MrDini wrote:So I recompiled...
How? I mean, what configure options you used for alsa-lib ?
MrDini wrote:This package contains the whole mpd? When You configured it what options are disabled?
It is full package with sample config untouched.
#audio_output {
type "alsa"
name "My ALSA Device"
## device "hw:0,0" # optional
mixer_type "software" # optional
## mixer_device "default" # optional
## mixer_control "PCM" # optional
## mixer_index "0" # optional
#}
Red # should be removed, I think.
Better read slowly and attentively info at mpd wiki link, that I gave you. It contains all info you need.

User avatar
MrDini
Posts: 651
Joined: Mon Dec 21, 2015 7:21 pm
Contact:

Re: Play sounds with nsa320s?

Post by MrDini » Thu Mar 17, 2016 7:22 pm

Thanks. The uncomment saved my life! :)

I'm very careless... :roll:
Thanks nas-central the lot of help! :)

User avatar
MrDini
Posts: 651
Joined: Mon Dec 21, 2015 7:21 pm
Contact:

Re: Play sounds with nsa320s?

Post by MrDini » Thu Mar 17, 2016 7:49 pm

what configure options you used for alsa-lib ?
I don't know. Sorry, but I forgot to save the configure script's output. If it helps, I Can run again the configure.
Thanks nas-central the lot of help! :)

User avatar
MrDini
Posts: 651
Joined: Mon Dec 21, 2015 7:21 pm
Contact:

Re: Play sounds with nsa320s?

Post by MrDini » Thu Mar 17, 2016 8:08 pm

With alsa i can't change the volume by mpd clients... But with oss and with a little config change It works! I can change the volume client side! Here is the edited config part:

Code: Select all

audio_output {
	type		"oss"
	name		"My OSS Device"
        device		"/dev/dsp"	# optional
	mixer_type      "software"	# optional
        mixer_device	"/dev/mixer"	# optional
##	mixer_control	"PCM"		# optional
}
Thanks nas-central the lot of help! :)

User avatar
MrDini
Posts: 651
Joined: Mon Dec 21, 2015 7:21 pm
Contact:

Re: Play sounds with nsa320s?

Post by MrDini » Fri Mar 18, 2016 5:09 pm

Hi!

I have made some changes in Your package at the config. This config works with all pcm compatible sound card (I think all of the soundcards are supports pcm). I uploaded to my repository, You Can download and upload to Your repo. I tested it on NSA320S and NSA325 v2. The package was stable So (I think) You Can move from testing folder to the "stable" directory! :)

Here is the package: mpd-0.19.13-arm-1.txz
Thanks nas-central the lot of help! :)

barmalej2
Posts: 2387
Joined: Sun Apr 29, 2012 5:24 pm

Re: Play sounds with nsa320s?

Post by barmalej2 » Sat Mar 19, 2016 12:06 am

Very well. Changes accepted with minor correction-instead zyxel specific-/i-data/md0, more ffp generic path /mnt/HD_a2 will be used in mpd.conf.
mpd-0.19.13-arm-1.txz is now uploaded to slacker br2: repo.
Good work MrDini.

User avatar
MrDini
Posts: 651
Joined: Mon Dec 21, 2015 7:21 pm
Contact:

Re: Play sounds with nsa320s?

Post by MrDini » Sat Mar 19, 2016 7:23 pm

Hello again barmalej2!

Thanks for the mpd, it works nice. The processor usage is max 4% when I'm playing music and with mixer_type software the sounds are very nice with my home-studio system. I bought a new Denon soundcard and with Your package and 0 config edit it works. I Can play music streams too like internet radio and it also supports m3u list. So I think it is a good choice. I'm very thankful! ;)

I putted to a Hun. howto Your mpd. But it was on yesterday, when You even had only the testing mpd. So I putted to my howto my "repository"'s link which had the edited config. I Can't change the howto, So if You don't angry I don't remove the mpd from my "repo". But I will hide it, because this package not mine. This package is Your work
And I think that was a hard work (the compile). A hun. sentence is nice for this situation. With my poor english it is something similar: Don't pride with other (person's) feather. :)

But I have some bad news regarding cmus. Flyingmutant (a cmus git developer) said:

This looks like a problem with your installation of FFmpeg, and not cmus. Please make sure you've built and installed it correctly.

I'm using Your ffmpeg to compile it. If You remember, I had some compilation issue. Finally, it successfully compiled with ffmpeg yes flag. But when I installed it and I runned a cmus --plugins command I can't see the ffmpeg. Without ffmpeg I Can only play mp3-s...
Last edited by MrDini on Sun Mar 20, 2016 6:38 pm, edited 1 time in total.
Thanks nas-central the lot of help! :)

User avatar
MrDini
Posts: 651
Joined: Mon Dec 21, 2015 7:21 pm
Contact:

Re: Play sounds with nsa320s?

Post by MrDini » Sun Mar 20, 2016 8:48 am

Regarding mpd and missing accept4. I simply commented the if and I tried to make it. I Can't believe it, it worked! :D

I think You used an other thing to solve it, aren't you? I think this accept4 not accidental in the source and the package not stable bc I commented it. :roll:
Thanks nas-central the lot of help! :)

User avatar
MrDini
Posts: 651
Joined: Mon Dec 21, 2015 7:21 pm
Contact:

Re: Play sounds with nsa320s?

Post by MrDini » Sun Mar 20, 2016 1:10 pm

I make a try to compile cmus with roar. But it says the following:

Code: Select all

make[1]: Entering directory '/i-data/bf835951/build/roaraudio-1.0beta11/roarclients'
/ffp/bin/gcc -g -Wall -L../lib/  -o roarctl roarctl.o -lroar -lroardsp -lm -lm
../lib//libroar.so: warning: gethostbyname is obsolescent, use getnameinfo() instead.
../lib//libroardsp.so: undefined reference to `sqrtl'
collect2: error: ld returned 1 exit status
Makefile:59: recipe for target 'roarctl' failed
make[1]: *** [roarctl] Error 1
make[1]: Leaving directory '/i-data/bf835951/build/roaraudio-1.0beta11/roarclients'
Makefile:23: recipe for target 'all' failed
make: *** [all] Error 2
I tried to add to roarcctl.c the #include <math.h> line, but it not solved the problem...

I also tried

Code: Select all

LIBS="-lm" ./configure --prefix=/ffp
...

Any idea? :roll:
Thanks nas-central the lot of help! :)

Post Reply