General NAS-Central Forums

Welcome to the NAS community
It is currently Fri Oct 20, 2017 5:40 pm

All times are UTC




Post new topic Reply to topic  [ 54 posts ]  Go to page Previous  1, 2, 3, 4  Next
Author Message
PostPosted: Sun Jan 01, 2017 1:42 am 
Offline

Joined: Thu Sep 29, 2016 9:16 pm
Posts: 37
Another question:

Is it possible to use

uvcvideo driver with v4l-dvb-2.6.31.8_gitc3e8bd6-arm-1.txz

OR

v4l-dvb-2.6.31.8_git20110614-arm-1.txz with dvb-usb-rtl2832 driver

(SO

uvcvideo webcam and RTL2832U+R820T together)?

Ikolo


Top
 Profile  
 
PostPosted: Sun Jan 01, 2017 12:36 pm 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2303
Ikolo wrote:
Now, I just see one adapter. Is it possible?
Ikolo

Possible with this particular driver. I didn't said, that this driver doesn't has drawbacks, but at least it is working with latest RTL tuners.

Ikolo wrote:
Another question:
Is it possible to use uvcvideo driver with v4l-dvb-2.6.31.8_gitc3e8bd6-arm-1.txz
OR
v4l-dvb-2.6.31.8_git20110614-arm-1.txz with dvb-usb-rtl2832 driver

Possible first variant with some drawback again:
https://forum.nas-central.org/viewtopic.php?f=249&t=18317&start=30#p101849
Second one I didn't tested, but should work as well.


Top
 Profile  
 
PostPosted: Sun Jan 01, 2017 3:57 pm 
Offline

Joined: Thu Sep 29, 2016 9:16 pm
Posts: 37
Hi!

I tried this post earlier (about a half year and now too). Unfortunately uvcvideo driver + v4l-dvb-2.6.31.8_gitc3e8bd6-arm-1.txz together didn't worked for me. Just because I used the second method to my old dvb device. I know, I know I am so, so silly... :oops:

Now to new device I had to change/copy dvb-usb-rtl2832, dvb-usb, rc-core, dvb-core from new v4l-dvb to old v4l-dvb. I know it's not too elegant, but works.

Ikolo


Top
 Profile  
 
PostPosted: Wed May 17, 2017 3:13 am 
Offline

Joined: Sun Apr 30, 2017 3:17 pm
Posts: 12
Hello.
barmalej2,is there any manual, how manualy build Tvheadend from sources?
I tried do this on my D-Link DNS-325 using gcc from your repo, but I have errors, while it's compyling
Or, maybe, You can build Tvheadend latest stable 4.2.2 and put it in your repo?


Top
 Profile  
 
PostPosted: Wed May 17, 2017 9:50 am 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2303
It is not easy to build latest Tvheadend as this task involves building direct dependent libs first (ffmpeg, x264, x265, libtheora,libvorbis, libvpx), which has numerous subdependencies. I have sources for 4.0.9 version, but there is significant changes in latest tvheadend release and these sources will not help you.
If you can wait a week or two, I can try to compile Tvheadend 4.2.2.


Top
 Profile  
 
PostPosted: Wed May 17, 2017 11:17 am 
Offline

Joined: Sun Apr 30, 2017 3:17 pm
Posts: 12
Looks like it's stop on compiling one of this libraries. Before error was message "/bin/sh not found". Script download one of that librarier and compile them.

I'll wait until you compile new version. Thanks.


Top
 Profile  
 
PostPosted: Wed May 17, 2017 11:59 am 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2303
It downloads x264 sources and tries to compile it statically. Downloaded sources are not configured for ffp prefix, so compilation fails. Building statically is unnecessary waste of shared resources and is not suitable for low powered devices like NAS.
I will proceed to build dependent packages first and lastly will build Tvheadend itself. Will let you know, when task will be finished.


Top
 Profile  
 
PostPosted: Fri May 26, 2017 7:41 pm 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2303
Done. Steps to install/upgrade Tvheadend (root priviledges is requirement):
1. # Check, if you have slapt-get package installed. If no, then proceed further else proceed from step3:
Code:
funpkg -q slapt-get

2. # If there is no slapt-get installed, then create funpkg cache dir for br2 repo in case it not exists and install new slapt-get package manager:
Code:
[ -d /ffp/funpkg/cache/br2 ] || mkdir -p /ffp/funpkg/cache/br2
cd /ffp/funpkg/cache/br2
/ffp/bin/wget -nv http://downloads.zyxel.nas-central.org/Users/barmalej2/ffp/0.7/arm/packages/slapt-get-0.10.2t-arm-2.txz
funpkg -i slapt-get-0.10.2t-arm-2.txz

3. # Update slapt-get lists and upgrade core packages:
Code:
slapt-get -u
slapt-get --upgrade

4. # Restart sshd daemon service after upgrading:
Code:
sh /ffp/start/sshd.sh restart

5. # Stop current running tvheadend daemon service in case of upgrade:
Code:
sh /ffp/start/tvheadend.sh stop

6. # Install Tvheadend package with dependent packages together:
Code:
slapt-get -i tvheadend

7. # Start tvheadend daemon service after updating package:
Code:
sh /ffp/start/tvheadend.sh start

8. # Enable auto start of service, if desired:
Code:
chmod 755 /ffp/start/tvheadend.sh

Noticeable changes in new Tvheadend version:
1. New initial configuration wizard on first time login. Much simplifies initial configuration.
2. IPTV m3u playlist support. Local (file://path/to/file.m3u) and http (http://path/to/file.m3u) playlists support. Scans and finds all available IPTV services like subtitles, audio tracks. Shows which streams are dead and which alive. Tested remotely with openvpn-works cool.
There is also major change in ffp package. From now, loginless access to Web UI is enabled in case of fresh Tvheadend install (first time). You will see the following output after starting tvheadend daemon service (only on first run):
Quote:
******** Important Information ********
To control tvheadend service, access the Web UI at http://localhost:9981
Web UI default access is allowed for everyone without username/password. To secure it, you must set
Web UI administrator username and password during initial configuration wizard at first login time

or run wizard manually via menu-/Configuration/General/Base/Start wizard in the web interface.
Starting tvheadend...done! [ OK ]


Top
 Profile  
 
PostPosted: Sat May 27, 2017 1:53 pm 
Offline

Joined: Sun Apr 30, 2017 3:17 pm
Posts: 12
Thanks for update, but i have a problem.
IPTV stream plays 5 seconds and stops. It's happens even with clear installation.


Top
 Profile  
 
PostPosted: Sat May 27, 2017 7:28 pm 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2303
Well, I wasn't able to reproduce with my ISP provider's IPTV udp streams (SD quality). Plays without vice. The only difference I noticed in players, which handles m3u. Windows media player always starts in paused state, but pressing play button will play flawlessly (tested on Windows 7 locally and with 8.1 remotely via vpn). I have k-lite codec pack installed for WMP. If VLC is used, it starts to play immediately. Unfortunately, I can't test HD streams with PC at home right now, since it is too old, but will try to do that remotely on Monday.
So on what device you are testing, OS, player? Which type of IPTV stream ( UDP /RTP / HTTP / HTTP HLS )? Was this problem with earlier version(s) of tvheadend?
BTW. Searching in Tvheadend issues found this result:
https://tvheadend.org/issues/4384
Seems like this bug is not new.


Top
 Profile  
 
PostPosted: Sun May 28, 2017 4:02 pm 
Offline

Joined: Sun Apr 30, 2017 3:17 pm
Posts: 12
My ISP provides IPTV using http streams.
I'm used Android 4.4 with KODI 16 and Windows 10 with KODI 17 for testing. On both platforms, the video stops after 5 seconds and waits for buffering. Looks like problem with caching of the stream.
The problem occurs only when playing video using Tvheadend. When I playing stream with PotPlayer, the video plays without problems.
Before updating to 4.2.2, I used Tvheadend 4.0.9. There was no problem with playing streams.

Is there any way to rollback from 4.2.2 to 4.0.9? I can't found 4.0.9 in your repo.

P.S. If you speak Russian, we can continue this disscussion in PM


Top
 Profile  
 
PostPosted: Mon May 29, 2017 7:48 am 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2303
Sorry, but typing in russian with latin keyboard, which doesn't has cyrilic characters is real pain in the *** . Please continue here, because tvheadend IPTV playback problem might affect other users too.
Meanwhile, I tested HD streams remotely with VLC and WMP players. Playback on both players is good.
I wonder to know, is your problem related with kodi. Can you test direct playback from tvheadend Web UI on PC?
Go to Configuration> Channel/EPG> Channels and push play button on any channel. By clicking with right mouse button on any channel play button icon, you can save http link to m3u file, which can opened lately by most players on PC. This m3u file contains stream URL served by Tvheadend daemon service.


Top
 Profile  
 
PostPosted: Tue May 30, 2017 2:26 am 
Offline

Joined: Sun Apr 30, 2017 3:17 pm
Posts: 12
Tested on built-in player, VLC, PotPlayer.
On all this players stream plays few seconds and stops on buffering.
May be problem in my NAS? I'm using DNS-325


Top
 Profile  
 
PostPosted: Tue May 30, 2017 7:09 pm 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2303
Quote:
On all this players stream plays few seconds and stops on buffering.
In that case, it's tvheadend server problem.
I checked your NAS specs. They are almost identical to mine NSA310 except HD bays quantity. So I doubt if the NAS is a problem.
Quote:
Is there any way to rollback from 4.2.2 to 4.0.9?
Unfortunately not. Older tvheadend 4.0.9 depends on older ffmeg and others libraries. All of them are updated now and old release will not run with new ffmpeg. Recompilation of old tvheadend version is impossible, because it has no support of new ffmpeg versions. I can't downgrade ffmpeg since others packages depends on it now.
My suggestion is to fill bug ticket on tvheadend support and provide debug info for them to analyze problem.


Top
 Profile  
 
PostPosted: Wed May 31, 2017 10:53 am 
Offline

Joined: Sun Apr 30, 2017 3:17 pm
Posts: 12
Sad to hear it.
Now I'm left without tvheadend.
Do You have a copy of old packages? I will try install them manually.
You have precompiled dependencies. Will it be difficult to compile versions 4.1 and 4.3? I want to try them.
Or can you give me a list of all dependencies and keys to compile them. I'll try to compile them miself.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 54 posts ]  Go to page Previous  1, 2, 3, 4  Next

All times are UTC


Who is online

Users browsing this forum: Bing [Bot], Google [Bot], Majestic-12 [Bot] and 94 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group