General NAS-Central Forums

Welcome to the NAS community
It is currently Mon Oct 23, 2017 6:21 am

All times are UTC




Post new topic Reply to topic  [ 54 posts ]  Go to page Previous  1, 2, 3, 4
Author Message
PostPosted: Wed May 31, 2017 11:45 am 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2303
Quote:
Do You have a copy of old packages? I will try install them manually.

Yes I have them, all of previous builds in one dir. Do you know which one you need? I don't, because I don't keep a list of updated packages.
Dependencies tree in linux is a real headache.
Quote:
You have precompiled dependencies. Will it be difficult to compile versions 4.1 and 4.3? I want to try them.
I built 4.3 version already. It is really buggy, some streams not found and not recognizes alives or dead ones. Scan result for all of them is Fail. This is normal, because it development version and should not be used in regular use.
If you want to test it, then be my guest:
http://downloads.zyxel.nas-central.org/Users/barmalej2/ffp/0.7/arm/packages/testing/tvheadend-4.3-arm-1.txz
Regarding older versions like 4.0.9 and 4.0.10 I answered in previuos post. Didn't tried 4.1 yet, but can do that a bit later. Note: it is development version also and released in 2015 may 15, so I doubt it will compile with latest ffmpeg.
I can upload build scripts of packages to NAS central if you wish to try yourself. You will need to modify each of them and adapt to your system.


Top
 Profile  
 
PostPosted: Wed May 31, 2017 2:37 pm 
Offline

Joined: Sun Apr 30, 2017 3:17 pm
Posts: 12
barmalej2 wrote:
It is really buggy, some streams not found and not recognizes alives or dead ones. Scan result for all of them is Fail. This is normal, because it development version and should not be used in regular use.

I have the same problem on 4.2, when I made a clean install. There are 86 streams in my IPTV, but only 7 were found.


Top
 Profile  
 
PostPosted: Wed May 31, 2017 5:51 pm 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2303
OK. Let's try downgrade first. It might be simpler than I thought, because older ffmpeg and tvheadend has less dependencies than current builds.
Code:
sh /ffp/start/tvheadend.sh stop
rm -rf /ffp/etc/tvheadend
Code:
mkdir -p /ffp/funpkg/cache/br2/tvheadend-4.0.9
cd /ffp/funpkg/cache/br2/tvheadend-4.0.9
Code:
wget -e robots=off -nv -np -nd -H -r --level=1 -A txz http://downloads.zyxel.nas-central.org/Users/barmalej2/ffp/0.7/arm/packages/testing/old/tvheadend-4.0.9/
Code:
funpkg -u $(ls *.txz | xargs)
Then paste me outputs of
Code:
ldd /ffp/bin/ffmpeg
ldd /ffp/bin/tvheadend
and run this tool:
http://forum.nas-central.org/viewtopic.php?f=249&t=14699


Top
 Profile  
 
PostPosted: Wed May 31, 2017 6:28 pm 
Offline

Joined: Sun Apr 30, 2017 3:17 pm
Posts: 12
I tested 4.3, the same problem as on 4.2. The stream shows several minutes and waits for buffering.
Now I'll try to downgrade the version


Top
 Profile  
 
PostPosted: Wed May 31, 2017 6:54 pm 
Offline

Joined: Sun Apr 30, 2017 3:17 pm
Posts: 12
Thanks. Tvheadend successfully downgraded back to 4.0.9. Now streams works perfect.
Here is output of commands:
Code:
root@DNS-325:/ffp/funpkg/cache/br2/tvheadend-4.0.9# ldd /ffp/bin/ffmpeg
ldd: can't open cache '/ffp/etc/ld.so.cache'
        libavdevice.so.55 => /ffp/lib/libavdevice.so.55 (0x40002000)
        libavfilter.so.3 => /ffp/lib/libavfilter.so.3 (0x40016000)
        libavformat.so.55 => /ffp/lib/libavformat.so.55 (0x400ef000)
        libavresample.so.1 => /ffp/lib/libavresample.so.1 (0x4023f000)
        libavcodec.so.55 => /ffp/lib/libavcodec.so.55 (0x40256000)
        libpostproc.so.52 => /ffp/lib/libpostproc.so.52 (0x40f60000)
        libswresample.so.0 => /ffp/lib/libswresample.so.0 (0x40f76000)
        libswscale.so.2 => /ffp/lib/libswscale.so.2 (0x40f91000)
        libavutil.so.52 => /ffp/lib/libavutil.so.52 (0x40fe0000)
        libm.so.0 => /ffp/lib/libm.so.0 (0x41043000)
        libpthread.so.0 => /ffp/lib/libpthread.so.0 (0x4105d000)
        libc.so.0 => /ffp/lib/libc.so.0 (0x41079000)
        libfreetype.so.6 => /ffp/lib/libfreetype.so.6 (0x410e4000)
        libass.so.4 => /ffp/lib/libass.so.4 (0x4118c000)
        libfontconfig.so.1 => /ffp/lib/libfontconfig.so.1 (0x411b0000)
        librtmp.so.1 => /ffp/lib/librtmp.so.1 (0x411f8000)
        libz.so.1 => /ffp/lib/libz.so.1 (0x41211000)
        libbz2.so.1.0 => /ffp/lib/libbz2.so.1.0 (0x41231000)
        libiconv.so.2 => /ffp/lib/libiconv.so.2 (0x41242000)
        libx264.so.140 => /ffp/lib/libx264.so.140 (0x41329000)
        libtwolame.so.0 => /ffp/lib/libtwolame.so.0 (0x414b1000)
        libshine.so.3 => /ffp/lib/libshine.so.3 (0x414df000)
        libopus.so.0 => /ffp/lib/libopus.so.0 (0x414f1000)
        libmp3lame.so.0 => /ffp/lib/libmp3lame.so.0 (0x41546000)
        ld-uClibc.so.0 => /ffp/lib/ld-uClibc.so.0 (0x2a000000)
        libdl.so.0 => /ffp/lib/libdl.so.0 (0x415cd000)
        libfribidi.so.0 => /ffp/lib/libfribidi.so.0 (0x415d8000)
        libgcc_s.so.1 => /ffp/lib/libgcc_s.so.1 (0x415f7000)
        libexpat.so.1 => /ffp/lib/libexpat.so.1 (0x4161e000)
        libssl.so.1.0.0 => /ffp/lib/libssl.so.1.0.0 (0x41646000)
        libcrypto.so.1.0.0 => /ffp/lib/libcrypto.so.1.0.0 (0x416aa000)
root@DNS-325:/ffp/funpkg/cache/br2/tvheadend-4.0.9# ldd /ffp/bin/tvheadend
ldd: can't open cache '/ffp/etc/ld.so.cache'
        libdvben50221.so => /ffp/lib/libdvben50221.so (0x40002000)
        libdvbapi.so => /ffp/lib/libdvbapi.so (0x40017000)
        libucsi.so => /ffp/lib/libucsi.so (0x40023000)
        libssl.so.1.0.0 => /ffp/lib/libssl.so.1.0.0 (0x40041000)
        libcrypto.so.1.0.0 => /ffp/lib/libcrypto.so.1.0.0 (0x400a5000)
        libz.so.1 => /ffp/lib/libz.so.1 (0x40226000)
        liburiparser.so.1 => /ffp/lib/liburiparser.so.1 (0x40246000)
        libavcodec.so.55 => /ffp/lib/libavcodec.so.55 (0x40265000)
        libavutil.so.52 => /ffp/lib/libavutil.so.52 (0x40f6f000)
        libavformat.so.55 => /ffp/lib/libavformat.so.55 (0x40fd2000)
        libswscale.so.2 => /ffp/lib/libswscale.so.2 (0x41122000)
        libavresample.so.1 => /ffp/lib/libavresample.so.1 (0x41172000)
        libdbus-1.so.3 => /ffp/lib/libdbus-1.so.3 (0x41189000)
        libdl.so.0 => /ffp/lib/libdl.so.0 (0x411cc000)
        libpthread.so.0 => /ffp/lib/libpthread.so.0 (0x411d7000)
        libm.so.0 => /ffp/lib/libm.so.0 (0x411f2000)
        libiconv.so.2 => /ffp/lib/libiconv.so.2 (0x4120c000)
        librt.so.0 => /ffp/lib/librt.so.0 (0x412f3000)
        libc.so.0 => /ffp/lib/libc.so.0 (0x412fe000)
        libgcc_s.so.1 => /ffp/lib/libgcc_s.so.1 (0x41369000)
        libx264.so.140 => /ffp/lib/libx264.so.140 (0x41390000)
        libtwolame.so.0 => /ffp/lib/libtwolame.so.0 (0x41518000)
        libshine.so.3 => /ffp/lib/libshine.so.3 (0x41547000)
        libopus.so.0 => /ffp/lib/libopus.so.0 (0x41558000)
        libmp3lame.so.0 => /ffp/lib/libmp3lame.so.0 (0x415ad000)
        librtmp.so.1 => /ffp/lib/librtmp.so.1 (0x41634000)
        libbz2.so.1.0 => /ffp/lib/libbz2.so.1.0 (0x4164d000)
        ld-uClibc.so.0 => /ffp/lib/ld-uClibc.so.0 (0x2a000000)


affected-files.txt
Code:
/ffp/lib/php/extensions/no-debug-non-zts-20100525/gd.so


missing-libs.txt
Code:
/ffp/lib/php/extensions/no-debug-non-zts-20100525/gd.so:
checking sub-depends for 'not found'
   libpng15.so.15 => not found (0x00000000)


Top
 Profile  
 
PostPosted: Wed May 31, 2017 7:17 pm 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2303
If you don't use php package then better remove it, you have very old and outdated php. If you need it then create symlink:
Code:
ln -s /ffp/lib/libpng16.so.16 /ffp/lib/libpng15.so.15
and rerun lddd.
Caution: be careful using slapt-get from now. Installing others packages might break your current running tvheadend daemon service, because it will update your current packages, while you need downgraded ones.


Top
 Profile  
 
PostPosted: Wed May 31, 2017 7:51 pm 
Offline

Joined: Sun Apr 30, 2017 3:17 pm
Posts: 12
I created a symlink for libpng. After that, the lddd reported: "Congratulations! No missing libraries was found in /ffp."
Do you have any idea why the new versions didn't work?
barmalej2 wrote:
I can upload build scripts of packages to NAS central if you wish to try yourself. You will need to modify each of them and adapt to your system.
Upload this scripts,I'll try to build them on my NAS. Maybe it will help.


Top
 Profile  
 
PostPosted: Wed May 31, 2017 9:10 pm 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2303
vlmaksime wrote:
Do you have any idea why the new versions didn't work?
Of course not. I am not developer of tvheadend and I am not regular user of it too. As you can imagine now, newer version doesn't mean better and this applies to other programs sometimes as well.
vlmaksime wrote:
Upload this scripts,I'll try to build them on my NAS. Maybe it will help.
Ok. Will upload tomorrow. I have no doubts it will not help you.


Top
 Profile  
 
PostPosted: Thu Jun 01, 2017 2:31 pm 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2303
All the build scripts and build logs are uploaded to nas-central downloads.
List of current packages in br2 repository, descriptions, dependencies can be found here.
Good luck.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 54 posts ]  Go to page Previous  1, 2, 3, 4

All times are UTC


Who is online

Users browsing this forum: Baidu [Spider], Bing [Bot] and 49 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group