General NAS-Central Forums

Welcome to the NAS community
It is currently Tue Apr 25, 2017 10:22 am

All times are UTC




Post new topic Reply to topic  [ 7 posts ] 
Author Message
 Post subject: Problem streaming videos
PostPosted: Wed Dec 21, 2016 10:34 am 
Offline

Joined: Wed Sep 24, 2014 3:48 pm
Posts: 8
I've been using the NSA325's Twonky for serving media for the last several years but about a year ago it started disconnecting shortly after starting to play any files. The screen would go black and the error would say that the device has disconnected. I'd got a Raspberry Pi shortly after this, originally for another reason, but I decided to put MiniDLNA on this and have it grab the files from the NSA325 via NFS. Works well enough but my LG smart TV seems to keep asking MiniDLNA what media it has available when it should be concentrating on streaming Netflix. This seems to cause a lot of unneccessary buffering which stops if I stop Minidlna. We got a bit annoyed by this and then I looked more into installing other packages on the NSA325, which is when I found Minidlna available. I think we've watched a few things via Minidlna on the NSA325 but now it's saying device disconnected just like it used to with Twonky. I've had an SSH session open at the time which was showing the top command and whilst it paused briefly, it recovered, so not entirely sure if it was a genuine loss of connectivity or not. Oddly, when I'm SSHing to the box it will sometimes appear to hang for 10 seconds or so before it continues, and I've never had that happen when SSHing to the Pi.

I checked minidlna.log and it shows;
minidlna.c:154: warn: received signal 15, good-bye

Is there any way to determine what's happening?


Top
 Profile  
 
 Post subject: Hard reset
PostPosted: Wed Dec 21, 2016 3:48 pm 
Offline

Joined: Wed Sep 24, 2014 3:48 pm
Posts: 8
I'm considering a factory reset but would like to make sure I understand the process first. I installed ffp via Mijzelf's MetaRepository instead of the USB stick. Do I just disable ffp in the firmware/packages section in the admin section? Then hold down the power button until it beeps three times and once it's rebooted, enable ffp again? Would I then have to do that web_prefix thing (IIRC) again to activate MetaRepository?

Is that it? I'm not missing any steps?


Top
 Profile  
 
PostPosted: Wed Dec 21, 2016 8:01 pm 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 5979
leesspam wrote:
hold down the power button until it beeps three times
You shouldn't use the power button to reset, but the reset button on the back.

About the packages, all packages will be disabled at a factory reset. (A factory reset basically erases some internal flash partition. The 'enabled' flags are also stored there). You can simply re-enable them in the webinterface, including MR and FFP.

There is no need to disable them first, but it doesn't hurt either.


Top
 Profile  
 
PostPosted: Wed Dec 21, 2016 9:13 pm 
Offline

Joined: Wed Sep 24, 2014 3:48 pm
Posts: 8
Thank you for the reply.

My other half has put on a movie and so far it's holding out but tomorrow evening if there's time I'll try the factory reset and over the course of the next few days report back in case it fixes the issue and is of help to others.


Top
 Profile  
 
PostPosted: Fri Dec 23, 2016 4:18 pm 
Offline

Joined: Wed Sep 24, 2014 3:48 pm
Posts: 8
It appears to have done the trick. We have watched a couple of movies successfully so far with issue. I will post back if the issue rears it's head again. I was pleasantly surprised how little configuring I had to do after the reset!


Top
 Profile  
 
PostPosted: Wed Dec 28, 2016 9:44 pm 
Offline

Joined: Wed Sep 24, 2014 3:48 pm
Posts: 8
Sadly, it has disconnected around 10 minutes into a video. I can resume straight away as usual and there's nothing mentioned in /ffp/var/log/minidlna.log. Open to suggestions again, please.


Top
 Profile  
 
PostPosted: Wed Dec 28, 2016 10:19 pm 
Online

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2217
Is there a disconnecting problem with other devices too? I mean, if you are watching movies with PC via DLNA for example.
Have you latest minidlna package installed?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC


Who is online

Users browsing this forum: barmalej2, Bing [Bot], Google [Bot], normsland and 69 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group