General NAS-Central Forums

Welcome to the NAS community
It is currently Fri Oct 20, 2017 5:46 pm

All times are UTC




Post new topic Reply to topic  [ 22 posts ]  Go to page Previous  1, 2
Author Message
PostPosted: Fri Jan 13, 2017 9:42 pm 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2303
Lsb is required only for start script, provided by logmein.
Look at dnsdown and dnsup and you will understand, what is harcoded. Unfortunately you can't look at hamachid source and find out, where it expects these scripts to be. I was asking two times before, about what I need to configure and setup to login to these logmein VPN servers.


Top
 Profile  
 
PostPosted: Fri Jan 13, 2017 10:29 pm 
Offline
User avatar

Joined: Mon Dec 21, 2015 7:21 pm
Posts: 597
The original path of the binary is /opt/logmein-hamachi/bin see the deb package. I have already done a test with placing here the binaries (I have entware-ng installed too), but the login also cannot be done.

Sorry, for the late explanation, I misunderstood You first... But I think, if the daemon Can't login to the server without credientals, it will also does the same, if You execute theese too.

_________________
Thanks nas-central the lot of help! :)


Top
 Profile  
 
PostPosted: Sun Jan 15, 2017 11:01 am 
Offline
User avatar

Joined: Mon Dec 21, 2015 7:21 pm
Posts: 597
I had no idea, So created a new package from an older source, but nothing changed which is related with the logging in.

I had no more idea, So as a last chance, I looked on the strace output, and I saw, the binary tries to use for example the libpthread from the /lib folder (where I haven't got a pthread library), instead of using the FFp version...

Okay, now, I tried to force using the FFp lib folder, by setting the LD_LIBRARY_PATH variable, but when I try to start the daemon, it says this:

Code:
root@NSA320S:~# LD_LIBRARY_PATH=/ffp/lib hamachid
hamachid: /ffp/lib/libpthread.so.0: no version information available (required by hamachid)
hamachid: /ffp/lib/libc.so.6: no version information available (required by hamachid)
hamachid: /ffp/lib/libc.so.6: no version information available (required by hamachid)
hamachid: /ffp/lib/libc.so.6: no version information available (required by /lib/libdl.so.2)
hamachid: /ffp/lib/libc.so.6: no version information available (required by /lib/libdl.so.2)
hamachid: /ffp/lib/libc.so.6: no version information available (required by /lib/libm.so.6)
Inconsistency detected by ld.so: do-lookup.h: 115: check_match: Assertion `version->filename == ((void *)0) || ! _dl_name_match_p (version->filename, map)' failed!


And don't want to start up... :(

_________________
Thanks nas-central the lot of help! :)


Top
 Profile  
 
PostPosted: Sun Jan 15, 2017 12:23 pm 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2303
What are you trying to do, makes no sense. Hamachi is not compiled with ffp toolchain. It is clearly compiled with and for glibc and it doesn't uses any of ffp libraries. Instead of them, zyxel firmware libs are used:
Code:
readelf -d ./hamachid | grep NEEDED
Quote:
0x00000001 (NEEDED) Shared library: [libstdc++.so.6]
0x00000001 (NEEDED) Shared library: [libpthread.so.0]
0x00000001 (NEEDED) Shared library: [libdl.so.2]
0x00000001 (NEEDED) Shared library: [libm.so.6]
0x00000001 (NEEDED) Shared library: [libgcc_s.so.1]
0x00000001 (NEEDED) Shared library: [libc.so.6]

Dynamic linker is also glibc based:
Code:
readelf -l ./hamachid | grep interpreter
Quote:
[Requesting program interpreter: /lib/ld-linux.so.3]

On ffp linker is:
Code:
ls -la /ffp/lib/ld-uClibc*
Quote:
lrwxrwxrwx 1 root root 25 May 22 2016 /ffp/lib/ld-uClibc.so -> ld-uClibc-0.9.33.3-git.so
-rwxr-xr-x 1 root root 29K May 22 2016 /ffp/lib/ld-uClibc-0.9.33.3-git.so
lrwxrwxrwx 1 root root 25 May 22 2016 /ffp/lib/ld-uClibc.so.0 -> ld-uClibc-0.9.33.3-git.so


Top
 Profile  
 
PostPosted: Sun Jan 15, 2017 12:27 pm 
Offline
User avatar

Joined: Mon Dec 21, 2015 7:21 pm
Posts: 597
So, that means, We Cannot use this daemon binary on FFp?

_________________
Thanks nas-central the lot of help! :)


Top
 Profile  
 
PostPosted: Sun Jan 15, 2017 12:29 pm 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2303
Interesting way of thinking. You have already run it. What makes you think, that you can't? It just doesn't depends on ffp at all.


Top
 Profile  
 
PostPosted: Sun Jan 15, 2017 12:31 pm 
Offline
User avatar

Joined: Mon Dec 21, 2015 7:21 pm
Posts: 597
:D

I just try to find out, why it Can't login...

_________________
Thanks nas-central the lot of help! :)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 22 posts ]  Go to page Previous  1, 2

All times are UTC


Who is online

Users browsing this forum: Bing [Bot], Majestic-12 [Bot] and 97 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group