General NAS-Central Forums

Welcome to the NAS community
It is currently Wed Dec 13, 2017 10:45 pm

All times are UTC




Post new topic Reply to topic  [ 46 posts ]  Go to page 1, 2, 3, 4  Next
Author Message
 Post subject: Oscam on ffp-0.7arm
PostPosted: Mon Jan 09, 2017 6:08 pm 
Offline

Joined: Thu Sep 29, 2016 9:16 pm
Posts: 37
Hi!

How can i watch encrypted channels with oscam and tvheadend? I've got an Alcor AU9540 smartreader.
(http://www.dx.com/p/usb-smart-card-read ... HPPuLmgRD0)

I found just these packages:oscam-unstable-1.20-r7855-arm-0.txz, oscam-unstable-1.20-r7940-arm-0.txz
(http://downloads.zyxel.nas-central.org/ ... ty/picard/)

Are these enough?

Thank you in advance!

Ikolo


Top
 Profile  
 
PostPosted: Mon Jan 09, 2017 8:28 pm 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2314
Sorry, but I am not familiar with oscam.


Top
 Profile  
 
PostPosted: Thu Jan 12, 2017 8:21 pm 
Offline

Joined: Thu Sep 29, 2016 9:16 pm
Posts: 37
Hi!

No problem.

(I tried to install oscam-unstable-1.20-r7855-arm-0.txz or oscam-unstable-1.20-r7940-arm-0.txz. I set up all oscam settings, but my cardreader isn't working, because these versions have no support for pcsc...)

Bye,
Ikolo


Top
 Profile  
 
PostPosted: Sun Jan 15, 2017 10:39 am 
Offline

Joined: Thu Sep 29, 2016 9:16 pm
Posts: 37
Hi Everybody!

Searching oscam-unstable-1.20-rXXXX-arm-0.txz with pcsc support for my NSA310S!

Thanks in advance!

Ikolo


Top
 Profile  
 
PostPosted: Sun Jan 15, 2017 12:50 pm 
Offline
User avatar

Joined: Mon Dec 21, 2015 7:21 pm
Posts: 605
Hi,

The latest oscam and pcsc-lite packages are uploaded to my slacker repo. The installation of theese packages Can be easily done, with this command:

Code:
slacker -UuiA mrdini:{oscam-unstable,pcsc-lite}

_________________
Thanks nas-central the lot of help! :)


Last edited by MrDini on Sun Jan 15, 2017 4:38 pm, edited 1 time in total.

Top
 Profile  
 
PostPosted: Sun Jan 15, 2017 2:47 pm 
Offline

Joined: Thu Sep 29, 2016 9:16 pm
Posts: 37
Hi!

Thank you so much for your help!
I will test it.

(pcsc-lite-1.8.20-arm-1.txz: No such file or directory)

Ikolo


Top
 Profile  
 
PostPosted: Sun Jan 15, 2017 2:55 pm 
Offline
User avatar

Joined: Mon Dec 21, 2015 7:21 pm
Posts: 605
Sorry, my SFTP server crashed during an upload, So the pcsc-lite package Cannot be uploaded. But now, hopefully the pcsc-lite package is available at the repo.

_________________
Thanks nas-central the lot of help! :)


Top
 Profile  
 
PostPosted: Sun Jan 15, 2017 6:41 pm 
Offline

Joined: Thu Sep 29, 2016 9:16 pm
Posts: 37
Hi!

Thanks! It's almost perfect, but when i add a reader with the pcsc protocol then crash oscam. I don't know why.

oscam.server:

[reader]
label = mypcscreader
enable = 1
protocol = pcsc
device = 0
detect = cd
group = 1
emmcache =1,3,2
cardmhz = 400

Here talk similar things:

http://www.streamboard.tv/oscam/ticket/2868

Ikolo


Top
 Profile  
 
PostPosted: Sun Jan 15, 2017 6:46 pm 
Offline
User avatar

Joined: Mon Dec 21, 2015 7:21 pm
Posts: 605
Can You attach a log file and please run the oscam binary with strace 'prefix', like this:

Code:
strace oscam


Unfortunately, I Can't test the package without a card reader itself.

BTW: the pcsc package is built with udev support, So the barmalej2's udev package and all of its dependencies are have to be installed!

And one more thing. If the problem related with pcsc, execute this command:

Code:
ldd /ffp/lib/libpcsclite.so


And look on its output.

_________________
Thanks nas-central the lot of help! :)


Top
 Profile  
 
PostPosted: Sun Jan 15, 2017 7:17 pm 
Offline

Joined: Thu Sep 29, 2016 9:16 pm
Posts: 37
strace oscam:

http://pastebin.com/vZJDe2DU

Barmalej2's udev already installed. He helped me a lot. (See above.)

Log:

http://pastebin.com/CYSwSgCx

ldd:

ldd /ffp/lib/libpcsclite.so
ldd: can't open cache '/ffp/etc/ld.so.cache'
checking sub-depends for '/ffp/lib/libdl.so.0'
libc.so.0 => /ffp/lib/libc.so.0 (0x4000d000)
ld-uClibc.so.0 => /ffp/lib/ld-uClibc.so.0 (0x2a000000)
checking sub-depends for '/ffp/lib/librt.so.0'
libc.so.0 => /ffp/lib/libc.so.0 (0x4000d000)
libdl.so.0 => /ffp/lib/libdl.so.0 (0x40078000)
libpthread.so.0 => /ffp/lib/libpthread.so.0 (0x40083000)
ld-uClibc.so.0 => /ffp/lib/ld-uClibc.so.0 (0x2a000000)
checking sub-depends for '/ffp/lib/libpthread.so.0'
ld-uClibc.so.0 => /ffp/lib/ld-uClibc.so.0 (0x2a000000)
libdl.so.0 => /ffp/lib/libdl.so.0 (0x4001d000)
libc.so.0 => /ffp/lib/libc.so.0 (0x40028000)
checking sub-depends for '/ffp/lib/libc.so.0'
ld-uClibc.so.0 => /ffp/lib/ld-uClibc.so.0 (0x2a000000)
libdl.so.0 => /ffp/lib/libdl.so.0 (0x00000000)
librt.so.0 => /ffp/lib/librt.so.0 (0x00000000)
libpthread.so.0 => /ffp/lib/libpthread.so.0 (0x00000000)
libc.so.0 => /ffp/lib/libc.so.0 (0x00000000)
/ffp/lib/ld-uClibc.so.0 => /ffp/lib/ld-uClibc.so.0 (0x00000000)

Without pcsc oscam doesn't crash.

strace pcscd:

http://pastebin.com/6ZvgGnsq


Top
 Profile  
 
PostPosted: Sun Jan 15, 2017 9:20 pm 
Offline
User avatar

Joined: Mon Dec 21, 2015 7:21 pm
Posts: 605
OK. I haven't read the past posts...

Well, it looks like the pcsc Cannot connect to Your card reader. It isn't the package's failure. Try to ask this question with attached log at some oscam forum.

Sorry, I Cannot help You in this case, as I said. :(

_________________
Thanks nas-central the lot of help! :)


Top
 Profile  
 
PostPosted: Sun Jan 15, 2017 9:32 pm 
Offline

Joined: Thu Sep 29, 2016 9:16 pm
Posts: 37
Hi!

pcscd --foreground --debug
00000000 debuglog.c:289:DebugLogSetLevel() debug level=debug
00000713 configfile.l:358:DBGetReaderList() Parsing conf file: /ffp/etc/reader.conf.d
00000115 pcscdaemon.c:655:main() pcsc-lite 1.8.20 daemon ready.
00000567 hotplug_libudev.c:122:HPReadBundleValues() Cannot open PC/SC drivers directory: /ffp/lib/pcsc/drivers
00000057 hotplug_libudev.c:123:HPReadBundleValues() Disabling USB support for pcscd.
00000061 hotplug_libudev.c:726:HPRegisterForHotplugEvents() No bundle files in pcsc drivers directory: /ffp/lib/pcsc/drivers
00000050 hotplug_libudev.c:727:HPRegisterForHotplugEvents() Disabling USB support for pcscd

lsusb:

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 003: ID 1a40:0101 Terminus Technology Inc. 4-Port HUB
Bus 001 Device 004: ID 058f:9540 Alcor Micro Corp.
Bus 001 Device 005: ID 1a40:0101 Terminus Technology Inc. 4-Port HUB
Bus 001 Device 006: ID 1908:2311 GEMBIRD

I don't know what is the module I need.

(I try these earlier:
modprobe usbserial
modprobe pl2303
modprobe ftdi_sio)

Ikolo


Top
 Profile  
 
PostPosted: Sun Jan 15, 2017 9:43 pm 
Offline
User avatar

Joined: Mon Dec 21, 2015 7:21 pm
Posts: 605
Code:
00000567 hotplug_libudev.c:122:HPReadBundleValues() Cannot open PC/SC drivers directory: /ffp/lib/pcsc/drivers


That is interesting. Maybe, I Can make this msg disappear. Now trying to recompile it.

_________________
Thanks nas-central the lot of help! :)


Top
 Profile  
 
PostPosted: Sun Jan 15, 2017 10:12 pm 
Offline
User avatar

Joined: Mon Dec 21, 2015 7:21 pm
Posts: 605
New package is updated to my repo. Run:

Code:
slacker -UuiA br2:python/python-2.7 mrdini:pcsc-lite


However, I Can also reproduce this messages:

Code:
00000000 debuglog.c:289:DebugLogSetLevel() debug level=debug
00009742 configfile.l:358:DBGetReaderList() Parsing conf file: /ffp/etc/reader.conf.d
00000129 pcscdaemon.c:655:main() pcsc-lite 1.8.20 daemon ready.
00000729 hotplug_libudev.c:726:HPRegisterForHotplugEvents() No bundle files in pcsc drivers directory: /ffp/lib/pcsc/drivers
00000060 hotplug_libudev.c:727:HPRegisterForHotplugEvents() Disabling USB support for pcscd


But I think, this is okay. This package is built with libudev enabled. And the drivers at the folder is only needed, if I build the package with libusb enabled. But in this case, the udev has to make devnodes, correct permissions, etc. So I recommend You to Do these steps:

1. Power off the box.
2. Remove the card reader.
3. Now, power on the box and wait for the final boot up.
4. Now, execute:

Code:
sh /ffp/start/udevd.sh stop
sh /ffp/start/udevd.sh debug

5. And finally, while the udev debugger log woke up, connect the card and see what happens.

As a B try, I will compile a pcsc with libusb support and upload it to my testing dir. Will notify You if it finished.

Mod: I uploaded the package built with libusb here. But no affect for me. :( Ask the devs...

_________________
Thanks nas-central the lot of help! :)


Top
 Profile  
 
PostPosted: Sun Jan 15, 2017 10:54 pm 
Offline

Joined: Thu Sep 29, 2016 9:16 pm
Posts: 37
udevd.sh debug: (no module matches)

http://pastebin.com/tGiKYhNB

Meanwhile I found two interesting things:

1. Missing udev rule:

https://forums.gentoo.org/viewtopic-t-8 ... art-0.html

2. Missing libccid/ccid:

https://www.raspberrypi.org/forums/view ... 8&t=146199

http://www.netboard.hu/viewtopic.php?to ... 72&x_p=150 (4299-4302)

Ikolo

Mod: with pcsc-lite-1.8.20-arm-3.txz: No module matches 'usb:v058Fp9540d0120dc00dsc00dp00ic0Bisc00ip00'

http://pastebin.com/yY7A8Y8E


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 46 posts ]  Go to page 1, 2, 3, 4  Next

All times are UTC


Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 73 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group