NS325 - Can't access web admin pages

Marvell Kirkwood based
Post Reply
robinc
Posts: 5
Joined: Mon May 15, 2017 3:02 pm

NS325 - Can't access web admin pages

Post by robinc » Mon May 15, 2017 3:18 pm

Hi All,

(First post, so apologies if any rule breaks)

I am out of support with a NSA325, purchased Jan 2013.

Zyxel app is showing firmware is at 4.81 - but no idea if that is actually the case. I wasn't really paying a lot of attention when I recently hit the "firmware update" button. Indeed probably several months before I even noticed I had generated a problem for myself (as drive was still visible).

I believe as a result of that recent-ish upgrade my http web pages for administration are unavailable.

Things that are working:
= Folder shares via network I can see and add content
- Twonky Service is still running
- Can ping the box (by "nsa325" name)
- Can connect on telnet:80 to a bash prompt.. (more on that later)

Things I have tried (none of which helped!)

- Multitude of browsers on different machines/tablets
- Clear Cookies/Private Browsing
- http to IP address, not http://nsa325/
- Rebooting box
- Factory Reset (this has worked as password now "1234"!)

Product support walked me through the above (mainly my ideas anyway), and then gave up on me, as box is out of warranty.

Back to that Telnet session. I was surprised to get to a BusyBox prompt on port 80. Is that right? or does that indicate an issue.

AS an ex-Unix hacker 20 years ago, I ran "ps" to see what jobs were up.
There were no httpd processes seemingly, which would suggest web service is not up, aligned to symptons? Is that correct?

Any ideas on either how to:
- kickstart the apache web server or
- roll back the firmware update, or some other firmware action

I don't think its that interesting but I have some screenshots in a word file (trouble uploading - but let me know if useful). Its just a bunch of different browesers showing refused connections to http://nsa325/ as well as http://nsa325/playzone,/ etc)

Thanks in advance,
Robin

Mijzelf
Posts: 6224
Joined: Mon Jun 16, 2008 10:45 am

Re: NS325 - Can't access web admin pages

Post by Mijzelf » Mon May 15, 2017 5:34 pm

That is strange. I can't think of a mechanism in the bare firmware which can cause this.

Is it possible that you installed the Tweaks package? It has an option to start a telnet daemon on any port, and if you configure port 80, maybe this happens.

User avatar
MrDini
Posts: 651
Joined: Mon Dec 21, 2015 7:21 pm
Contact:

Re: NS325 - Can't access web admin pages

Post by MrDini » Mon May 15, 2017 5:50 pm

Hello there!

Well, thats a known problem, several users asked me for help about that. For that people only the webserver got killed somehow, but all the other services were also accessible... But after a simple reboot, the web server (apache) got back without any clue, and the server just killed again after some days. Unfortunately, because I Couldn't reproduce the issue, I Couldn't find any direct solution, only a workaround. And that was this command:

Code: Select all

LD_LIBRARY_PATH=/usr/local/zy-pkgs/lib /etc/init.d/httpd.sh restart
If You have BusyBox console, simply paste that, hit enter, and see what happens. Else, reboot Your box, and install FFp (or enable the built-in ssh/telnet), and run the command from here.

Yes, it will restart the whole webserver (just if running already, else it will start simply it). But that is only a one time solution, if You want to make it automagically restart the webserver periodically, well the crontab is what You are looking for. You Can find it for example within Mijzelf's Tweaks package, or install uwcron from FFp etc...

Interesting, but that crontab restart with that command worked for all of the users, who have experienced similar issues.

I hope it will work for You too! :)
Thanks nas-central the lot of help! :)

robinc
Posts: 5
Joined: Mon May 15, 2017 3:02 pm

Re: NS325 - Can't access web admin pages

Post by robinc » Mon May 15, 2017 6:52 pm

Mr-dini, thank you so much.
I am back up and running.

Not quite as simple as you said - but it got me into the right area.

My httpd.conf file was erroring when I ran your restart command.
So I had a look at the errors, and compared to httpd.default and saw that in there the two lines:

Code: Select all

LoadModule php5_module /usr/local/zy-pkgs/lib/libphp5.so
PHPIniDir /usr/local/zy-pkgs/php
Were commented out.
So took that action, and the restart went through perfectly.

I guess because of these errors the Httpd services could never start properly.

Something I had done (and I really don't believe I have touched the web config for years, except for that reason firmware upgrade) - had clearly messed with the apache settings, and put it in this state.

Thanks once again !

User avatar
MrDini
Posts: 651
Joined: Mon Dec 21, 2015 7:21 pm
Contact:

Re: NS325 - Can't access web admin pages

Post by MrDini » Mon May 15, 2017 7:57 pm

You are welcome! ;) I glad to hear Your NAS is back again!

Oh, that's another problem! :) One person also noticed the same thing at the past, and he shared me his SSH connection, So I Could take a look for that too. As I remember that was related with the phpMyAdmin package.

After a firmware upgrade the webserver became unreachable, and the PHP module Couldn't be loaded, just as in Your case. I also commented theese lines, but keep in mind, theese config files are just stored temporarily on the ramdisk and during the next reboot, the NAS may regenerate the damaged config. So I told him to remove the phpMyAdmin package, and after that, the reboots doesn't broke the server. :)
Thanks nas-central the lot of help! :)

robinc
Posts: 5
Joined: Mon May 15, 2017 3:02 pm

Re: NS325 - Can't access web admin pages

Post by robinc » Tue May 16, 2017 10:56 am

Thanks again
(Maybe) last question....
How do I turn off PhpMyAdmin as you suggest?

User avatar
MrDini
Posts: 651
Joined: Mon Dec 21, 2015 7:21 pm
Contact:

Re: NS325 - Can't access web admin pages

Post by MrDini » Tue May 16, 2017 12:57 pm

You Can do that at the Packages tab on the webGUI.
Thanks nas-central the lot of help! :)

robinc
Posts: 5
Joined: Mon May 15, 2017 3:02 pm

Re: NS325 - Can't access web admin pages

Post by robinc » Tue May 16, 2017 2:19 pm

Found it, eventually ! Being a bit dumb !
Going to try some reboots now and see what happens!

User avatar
MrDini
Posts: 651
Joined: Mon Dec 21, 2015 7:21 pm
Contact:

Re: NS325 - Can't access web admin pages

Post by MrDini » Tue May 16, 2017 3:52 pm

Okay. Fingers crossed! ;)
Thanks nas-central the lot of help! :)

robinc
Posts: 5
Joined: Mon May 15, 2017 3:02 pm

Re: NS325 - Can't access web admin pages

Post by robinc » Tue May 16, 2017 3:55 pm

reboot worked just fine ;-)
Thanks for all your replies.
Still a bit shocked that Zyxel support refused to help with such a key issue.

Post Reply