General NAS-Central Forums

Welcome to the NAS community
It is currently Thu Jan 18, 2018 9:50 am

All times are UTC




Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Thu Jan 04, 2018 4:59 pm 
Offline

Joined: Thu Jan 04, 2018 4:14 pm
Posts: 10
I have a NSA325V2 that has been running Serviio version1.52 successfully for some time. I decided to upgrade it to version 1.6 so I can make use of the web console. I followed the steps listed in this "How To" thread [HowTo] Serviio 1.3.1 for Zyxel NSA325 which on page 2 has been updated to include version 1.6. I installed the latest JAVA version (build 1.8.0_151-B12 headless) and that worked fine showing the proper response when checking version. The next step was to install FFMpeg which was already installed but was an older version so I thought I should upgrade. The command given in the "How To" thread was this: slacker -UAa br2:ffmpeg2/ which didn't work. Looking over the repositories, I noticed it had been updated to ffmpeg3 so I ran the same command using ffmpeg3 instead and installed (or reinstalled) all the packages. It seemed to work fine and installed with no errors. Now comes my issue. When checking to see if ffmpeg installed properly, I get an error. I run the following command and this is the message;
ffmpeg -version
ffmpeg: can't load library "libasound.so.2"

I can't seem to find any ifo on this error and there is no such library on my system. Why is ffmpeg looking for it? I probably should have stopped at this point with my install but I didn't. I ran the serviio slacker command "slacker -UAa br2:serviio/" and continued. I start serviio using:
sh /ffp/start/serviio.sh start
Starting Serviio. . . [Fail!!! ] ERROR WARNING: serviio can not start!!!

I don't know why I get the ffmpeg error or how to fix it and I don't know if that is what is keeping serviio from starting. Any suggestions?

UPDATE: Serviio process is now running even though the web console is not.
Error log:
Code:
java.lang.ExceptionInInitializerError
   at org.serviio.MediaServer.main(MediaServer.java:144)
Caused by: java.lang.RuntimeException: FFMPEG not found. Serviio will not work properly.
   at org.serviio.external.FFMPEGWrapper.loadFFmpegInfo(FFMPEGWrapper.java:143)
   at org.serviio.external.FFMPEGWrapper.<clinit>(FFMPEGWrapper.java:116)

_________________
Doug


Top
 Profile  
 
PostPosted: Fri Jan 05, 2018 6:39 am 
Online

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2332
Forget about slacker. It should not be used in ffp anymore and all instructions using slacker is outdated. ffp has new package manager: slapt-get, which can install desired package with all dependencies automatically.

I posted instructions for serviio updating here:
https://forum.nas-central.org/viewtopic.php?f=249&t=11553&start=135#p108447

But it will not help you at your current state. So now, do as follows:

1. Stop serviio daemon service:
Code:
sh /ffp/start/serviio.sh stop

2. Make sure that all serviio subprocesses are stopped (or simply reboot NAS):
Code:
ps aux | grep serviio | grep -v grep

3. Remove serviio and ffpmpeg packages:
Code:
funpkg -r serviio ffmpeg

4. Create funpkg cache dir for br2 repo if it not exists and install new slapt-get package manager:
Code:
[ -d /ffp/funpkg/cache/br2 ] || mkdir -p /ffp/funpkg/cache/br2
cd /ffp/funpkg/cache/br2
/ffp/bin/wget -nv http://downloads.zyxel.nas-central.org/Users/barmalej2/ffp/0.7/arm/packages/slapt-get-0.10.2t-arm-2.txz
funpkg -i slapt-get-0.10.2t-arm-2.txz

5. Update slapt-get lists and upgrade core packages:
Code:
slapt-get -u
slapt-get --upgrade

6. If you are using ffp sshd, then you need restart sshd daemon service after upgrading, if not-skip this step:
Code:
sh /ffp/start/sshd.sh restart

7. Install serviio package with all required dependencies:
Code:
slapt-get -i serviio

8. Start serviio daemon service:
Code:
sh /ffp/start/serviio.sh start

9. Enable autostart (if everything works as expected):
Code:
chmod 755 /ffp/start/serviio.sh


If you are getting unexpected error(s) on any step, then stop and report here.


Top
 Profile  
 
PostPosted: Fri Jan 05, 2018 4:44 pm 
Offline

Joined: Thu Jan 04, 2018 4:14 pm
Posts: 10
Code:
root:/ffp/funpkg/cache/br2# slapt-get -u
Retrieving package data [http://downloads.zyxel.nas-central.org/Users/barmalej2/ffp/0.7/arm/packages/]...Done
Retrieving patch list [http://downloads.zyxel.nas-central.org/Users/barmalej2/ffp/0.7/arm/packages/]...Done
Retrieving checksum list [http://downloads.zyxel.nas-central.org/Users/barmalej2/ffp/0.7/arm/packages/]...Done
Retrieving checksum signature [http://downloads.zyxel.nas-central.org/Users/barmalej2/ffp/0.7/arm/packages/]...Not Found
Retrieving ChangeLog.txt [http://downloads.zyxel.nas-central.org/Users/barmalej2/ffp/0.7/arm/packages/]...Done
Reading Package Lists...Done


Is not finding checksum signature a problem?

_________________
Doug


Top
 Profile  
 
PostPosted: Fri Jan 05, 2018 5:11 pm 
Offline
User avatar

Joined: Mon Dec 21, 2015 7:21 pm
Posts: 612
No, AFAIK it is just an additional repository function
I think to make sure, the package was published by the real repository owner. But the barmalej2's repository doesn't have a GPG-key. So that's fine. :)

_________________
Thanks nas-central the lot of help! :)


Top
 Profile  
 
PostPosted: Sat Jan 06, 2018 4:31 pm 
Offline

Joined: Thu Jan 04, 2018 4:14 pm
Posts: 10
I wanted to circle back to thank barmalej2 for the help he gave me after I got totally stuck trying to do this upgrade on my Zyxel NAS server. Using the steps he listed, I was able to clean out the mess I made trying to upgrade Serviio on my own to version 1.8 (and ffmpeg) on my NAS325V2 . I'm not sure what I would have done without his help. I give him multiple "thumbs up"!! I also appreciate Mr. Dino's help with the small issue I noted which did indeed not seem to be an issue.

_________________
Doug


Top
 Profile  
 
PostPosted: Sun Jan 07, 2018 3:05 pm 
Online

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2332
You are welcome.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC


Who is online

Users browsing this forum: barmalej2, Bing [Bot], Dachtus, Google [Bot], MimoKar, philippetev and 53 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group