General NAS-Central Forums

Welcome to the NAS community
It is currently Thu May 25, 2017 10:40 am

All times are UTC




Post new topic Reply to topic  [ 177 posts ]  Go to page Previous  1 ... 7, 8, 9, 10, 11, 12  Next
Author Message
PostPosted: Mon Jul 20, 2015 5:44 pm 
Online

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2231
barmalej2 wrote:
Keep in mind-windows editors are suitable to create linux script files. Use nano editor on NAS or Notepad++ on Windows OS

Accidently noticed mine dumb typing mistake. Should be like this:
Quote:
Keep in mind-windows editors are not suitable to create linux script files. Use nano editor on NAS or Notepad++ on Windows OS.
Edited original post also.

MrTumTum wrote:
I just ran into one small problem, after the first start transmission.sh, i got a permission denied warning when I tried to stop it. I found out that the execute permission was missing and after changing that I was able to get it running.

You can specify run interpreter sh to run shell scripts without executable bit set. For example:
Code:
sh /ffp/start/transmission.sh stop

P.S. I have to warn you about this old start script. It has potential security hole. Running service as root user is not recommended way on Linux.


Top
 Profile  
 
PostPosted: Thu Oct 01, 2015 6:24 pm 
Offline

Joined: Wed Dec 11, 2013 4:21 pm
Posts: 12
Could anyone help with some hints about why my transmission homepage is not loading correctly?

I have it installed in on an ffp stick about two ago years or so (nsa310); and it has run successfully ever since until about a week ago when all i could see was as in the attached picture (tried multiple devices and browsers). The download service works, i have tested with the Remote GUI and everything is file, i just can't see it correctly when connecting through the browser.

No configuration changes to the ffp stick or the nas itself have been done recently.

PS, i'm a newbie. Thanks.


You do not have the required permissions to view the files attached to this post.


Top
 Profile  
 
PostPosted: Fri Oct 02, 2015 4:55 am 
Online

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2231
This might be result of usb stick weariness. I would advise to check files consistency with gparted live usb:
http://gparted.org/liveusb.php#windows-method-a
Btw. Have you tried to clear browser's cache? Reboot NAS?


Top
 Profile  
 
PostPosted: Fri Oct 02, 2015 5:18 am 
Offline

Joined: Fri Jan 20, 2012 1:55 pm
Posts: 86
Hi,

We allready are on transmission 2.82.

_________________
NSA320 (2x) FW V4.70(AFO.1) FFP 0.7 on usb
Bunch of USB 2 & 3 external disks connected to nas.


Top
 Profile  
 
PostPosted: Fri Oct 02, 2015 5:47 am 
Online

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2231
2.82 is Zyxel's provided package-zypkg transmission version. On ffp we have latest-2.84 version.


Top
 Profile  
 
PostPosted: Tue Oct 06, 2015 7:04 pm 
Offline

Joined: Wed Dec 11, 2013 4:21 pm
Posts: 12
Thank you very much for your answers. I apologize for not being so prompt myself, but I barely have time to experiment lately.

I did thought the stick is tired and this might be the reason, so I scanned it using the option from the NSA SMART menu, it look fine there. Also tried rebooting (stick removed and then back in), clearing browser cache (IE, Chrome, FF), it's all the same. The remote GUI still works fine.

I got a bit tangled with the gparted solution, but I think I will use a different way of creating my own bootable Linux iso stick and check the usb device using it. Thanks for the idea.

Has anyone made the switch from the ffp transmission to the Zyxel transmission package? Is it worth it? A few years back when I got this black box their own torrent client was crap - this made me google and end up here, among other places.
Please don't hate me for asking :)


Top
 Profile  
 
PostPosted: Wed Oct 07, 2015 4:46 am 
Online

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2231
Quote:
The remote GUI still works fine.
Do you mean transmission remote GUI-http://sourceforge.net/projects/transgui/ ? In that case, this is not surprising, because transmission remote GUI doesn't use web files and communicates with transmission daemon service via RPC protocol.
You have an option to reinstall transmission. If it will help, then we can think, that transmission web files was damaged.
Quote:
Has anyone made the switch from the ffp transmission to the Zyxel transmission package. Is it worth it? A few years back when I got this black box their own torrent client was crap - this made me google and end up here, among other places.
It is the same transmission, just lower version-2.82. You can find differences between them in changelog: https://trac.transmissionbt.com/wiki/Changes#version-2.84
Quote:
I got a bit tangled with the gparted solution, but I think I will use a different way of creating my own bootable Linux iso stick and check the usb device using it. Thanks for the idea.
Actually, I meant file system check utility-fsck (http://www.cyberciti.biz/tips/repairing-linux-ext2-or-ext3-file-system.html), which should be on any linux distribution. I mentioned gparted live usb, because of friendly interface for MS Windows users and it is designed exactly for operations with HDD or USB: repartitioning, resizing and so on. Also it is fast.


Top
 Profile  
 
PostPosted: Thu Mar 10, 2016 12:45 pm 
Offline

Joined: Sat Jun 20, 2015 4:58 pm
Posts: 22
Transmission 2.92 // Nsa310 tested and worked (myself compiled)

Code:
wget -O transmission-2.92-arm-0.txz "https://www.dropbox.com/s/xwciidc1rto57fa/transmission-2.92-arm-0.txz?dl=1"


Code:
funpkg -i transmission-2.92-arm-0.txz


Code:
/ffp/start/transmission.sh stop


Code:
/ffp/start/transmission.sh start


Top
 Profile  
 
PostPosted: Thu Mar 10, 2016 5:23 pm 
Online

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2231
Cool work Ibere. First one and just in time.


Top
 Profile  
 
PostPosted: Sat Mar 12, 2016 3:22 pm 
Offline

Joined: Sat Jun 20, 2015 4:58 pm
Posts: 22
barmalej2 wrote:
Cool work Ibere. First one and just in time.


you can add your repo's :)


Top
 Profile  
 
PostPosted: Sat Mar 12, 2016 3:36 pm 
Offline
User avatar

Joined: Mon Dec 21, 2015 7:21 pm
Posts: 584
I also compiled Transmission 2.92 a few days ago. If anyone interested find it in my "repo". :D

_________________
Thanks nas-central the lot of help! :)


Top
 Profile  
 
PostPosted: Sun Mar 27, 2016 4:21 pm 
Offline

Joined: Sun Oct 05, 2014 10:05 am
Posts: 8
Is it possible to upgrade to the new version without uninstalling the old version? Getting: funpkg -i transmission-2.92-arm-0.txz
Skipping transmission-2.92-arm-0.txz: Already installed (found: transmission-2.84-arm-0)


Top
 Profile  
 
PostPosted: Sun Mar 27, 2016 4:31 pm 
Offline
User avatar

Joined: Mon Dec 21, 2015 7:21 pm
Posts: 584
MaCk0y wrote:
Is it possible to upgrade to the new version without uninstalling the old version? Getting: funpkg -i transmission-2.92-arm-0.txz
Skipping transmission-2.92-arm-0.txz: Already installed (found: transmission-2.84-arm-0)


Hi!

Please try
Code:
funpkg -u transmission-2.92-arm-0.txz
command. This command will update Your tm to the new one.

_________________
Thanks nas-central the lot of help! :)


Top
 Profile  
 
PostPosted: Sun Mar 27, 2016 4:45 pm 
Offline

Joined: Sun Oct 05, 2014 10:05 am
Posts: 8
MrDini wrote:
MaCk0y wrote:
Is it possible to upgrade to the new version without uninstalling the old version? Getting: funpkg -i transmission-2.92-arm-0.txz
Skipping transmission-2.92-arm-0.txz: Already installed (found: transmission-2.84-arm-0)


Hi!

Please try
Code:
funpkg -u transmission-2.92-arm-0.txz
command. This command will update Your tm to the new one.


Now when I start Transmission service I get: /ffp/bin/transmission-daemon: can't load library 'libminiupnpc.so.9'.


Top
 Profile  
 
PostPosted: Sun Mar 27, 2016 5:00 pm 
Offline
User avatar

Joined: Mon Dec 21, 2015 7:21 pm
Posts: 584
Run:

Code:
slacker -a miniupnpc


And select one at the list.

_________________
Thanks nas-central the lot of help! :)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 177 posts ]  Go to page Previous  1 ... 7, 8, 9, 10, 11, 12  Next

All times are UTC


Who is online

Users browsing this forum: barmalej2, Bing [Bot], leesspam, lucaswiersma, Majestic-12 [Bot] and 61 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group