General NAS-Central Forums

Welcome to the NAS community
It is currently Fri Aug 18, 2017 10:31 am

All times are UTC




Post new topic Reply to topic  [ 207 posts ]  Go to page Previous  1 ... 9, 10, 11, 12, 13, 14  Next
Author Message
PostPosted: Sat Nov 05, 2016 5:36 pm 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2290
There is a setting in Transmission settings.json:
Quote:
"download-dir": "/mnt/HD_a2/video",

BTW. If you are Windows user, I would recommend to try remote client-Transmission Remote GUI instead WEB UI.


Top
 Profile  
 
PostPosted: Sat Nov 05, 2016 5:38 pm 
Offline
User avatar

Joined: Mon Dec 21, 2015 7:21 pm
Posts: 597
Hi,

Try to remove browser cache. Sometimes, thats helps...

barmalej2 wrote:
BTW. If you are Windows user, I would recommend to try remote client-Transmission Remote GUI instead WEB UI.


linux users Can also install it now! :)

_________________
Thanks nas-central the lot of help! :)


Top
 Profile  
 
PostPosted: Sat Nov 05, 2016 7:21 pm 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2290
Yep. Linux and Mac OS versions are available as well. It is cross-platform client.


Top
 Profile  
 
PostPosted: Sun Nov 06, 2016 9:02 am 
Offline

Joined: Sat Jun 25, 2016 1:17 pm
Posts: 19
I've done modification to my settings.json file at the time of first instalation, and it worked fine.
Funny thing, today it works in all webbrowsers I'v got and I havent done any thing yet.

Thanks for the client idea. It's great. :D


Top
 Profile  
 
PostPosted: Tue Nov 22, 2016 2:01 pm 
Offline

Joined: Sat Jun 25, 2016 1:17 pm
Posts: 19
Hi guys.
Since last installation of Trensmission, all written files and directories are "read only", so I have to change attributes to move or delete them.
Before that attributes of dowloaded content were "777" by default.
Where can I change this back to 777?


Top
 Profile  
 
PostPosted: Tue Nov 22, 2016 5:25 pm 
Offline
User avatar

Joined: Mon Dec 21, 2015 7:21 pm
Posts: 597
Hi,

At the Transmission's settings.json file, change the umask value to zero.

Ps: make sure, before You edit the file, the Tm is stopped! Otherwise the TM will overwrite it from the in ram version.

_________________
Thanks nas-central the lot of help! :)


Top
 Profile  
 
PostPosted: Wed Nov 23, 2016 8:19 am 
Offline

Joined: Sat Jun 25, 2016 1:17 pm
Posts: 19
Thanks MrDini, that was it.
Strange... When I installed TM I've prepared settings.json and umask value was zero. Thats's why I even haven't thought of it.
Is it possible that TM Remote GUI has changed it?


Top
 Profile  
 
PostPosted: Wed Nov 23, 2016 4:01 pm 
Offline
User avatar

Joined: Mon Dec 21, 2015 7:21 pm
Posts: 597
No, the tm remote gui doesn't control the umask. I think, when You prepared the settings, the tm was running.

_________________
Thanks nas-central the lot of help! :)


Top
 Profile  
 
PostPosted: Fri Apr 07, 2017 4:43 pm 
Offline

Joined: Sun Oct 05, 2014 10:05 am
Posts: 8
Hi,

Does anyone else get bottlenecked by the CPU using a 320s? I can't get over 7MB/s average. Transmission is using over 85% of the CPU. Maybe it's time to upgrade.


Top
 Profile  
 
PostPosted: Sat Apr 08, 2017 9:25 am 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2290
Disable utp in Transmissions settings, if you want more speed.


Top
 Profile  
 
PostPosted: Sun Apr 09, 2017 2:27 pm 
Offline

Joined: Sun Oct 05, 2014 10:05 am
Posts: 8
Didn't work. :( Tried also decreasing and increasing global and per torrent peer limit and disk cache size. Then I tried using Transmission on the PC using the same port number thinking maybe the ISP is throttling but I managed to download the same Ubuntu torrent at the maximum 30MB/s speed.


Top
 Profile  
 
PostPosted: Mon Apr 10, 2017 8:26 am 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2290
Well, indeed it has no influence for current version. I remember, it was true for older versions. Comparison of low powered NAS with PC is a bit inadequate. It is like compare horse with Ferrari.


Top
 Profile  
 
PostPosted: Tue Jun 06, 2017 8:35 pm 
Offline

Joined: Tue Jan 20, 2015 9:46 pm
Posts: 21
Hello guys!

I trying to upgrade my Transmission from 2.82 to 2.92 but i have some issues.

1. I download the compile package from this location ( https://www.dropbox.com/s/xwciidc1rto57 ... 0.txz?dl=1 ) I saw this link post from a guy on this topic.

2. I install this package with ffp 0.7
3. When i try to start the tranmission.sh i receive the follows messanges:

/ffp/bin/transmission-daemon: can't load library 'libminiupnpc.so.9'
/ffp/bin/sh: line 1: /mnt/HD_a2/transmission/transmission-daemon.log: No such file or directory

I check the dependency of this package and i figure that i don't have all the library.

root@Silax-Cloud:/i-data/md0/admin/Apps# ldd /ffp/bin/transmission-daemon
ldd: can't open cache '/ffp/etc/ld.so.cache'
libminiupnpc.so.9 => not found
librt.so.0 => /ffp/lib/librt.so.0 (0x40002000)
libevent-2.0.so.5 => /ffp/lib/libevent-2.0.so.5 (0x4000d000)
libcurl.so.4 => /ffp/lib/libcurl.so.4 (0x40050000)
librtmp.so.1 => /ffp/lib/librtmp.so.1 (0x400a0000)
libssl.so.1.0.0 => /ffp/lib/libssl.so.1.0.0 (0x400ca000)
libcrypto.so.1.0.0 => /ffp/lib/libcrypto.so.1.0.0 (0x4011a000)
libdl.so.0 => /ffp/lib/libdl.so.0 (0x40273000)
libintl.so.8 => /ffp/lib/libintl.so.8 (0x4027e000)
libiconv.so.2 => /ffp/lib/libiconv.so.2 (0x4028e000)
libc.so.0 => /ffp/lib/libc.so.0 (0x40376000)
libz.so.1 => /ffp/lib/libz.so.1 (0x403db000)
libm.so.0 => /ffp/lib/libm.so.0 (0x403f8000)
libgcc_s.so.1 => /ffp/lib/libgcc_s.so.1 (0x40412000)
libpthread.so.0 => /ffp/lib/libpthread.so.0 (0x40425000)
libgnutls.so.30 => not found
libhogweed.so.4 => not found
libnettle.so.6 => not found
libgmp.so.10 => /ffp/lib/libgmp.so.10 (0x40441000)
ld-uClibc.so.0 => /ffp/lib/ld-uClibc.so.0 (0x2a000000)

Please help me to install this library. I search on all my repositories and i din't find anything.


Top
 Profile  
 
PostPosted: Sun Jun 11, 2017 12:31 pm 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2290
I uploaded Transmission 2.92 ffp package to br2 repository. Steps to install/upgrade Transmission (root priviledges is requirement):
1. # Check, if you have slapt-get package installed. If no, then proceed further else proceed from step3:
Code:
funpkg -q slapt-get

2. # If there is no slapt-get installed, then create funpkg cache dir for br2 repo in case it not exists and install new slapt-get package manager:
Code:
[ -d /ffp/funpkg/cache/br2 ] || mkdir -p /ffp/funpkg/cache/br2
cd /ffp/funpkg/cache/br2
/ffp/bin/wget -nv http://downloads.zyxel.nas-central.org/Users/barmalej2/ffp/0.7/arm/packages/slapt-get-0.10.2t-arm-2.txz
funpkg -i slapt-get-0.10.2t-arm-2.txz

3. # Update slapt-get lists and upgrade core packages:
Code:
slapt-get -u
slapt-get --upgrade

4. # Restart sshd daemon service after upgrading:
Code:
sh /ffp/start/sshd.sh restart

5. # Stop current running Transmission daemon service in case of upgrade:
Code:
sh /ffp/start/transmission.sh stop

6. # Install Transmission package with dependent packages together:
Code:
slapt-get -i transmission

7. # In case of upgrade: remove user transmission,edit start up script-/ffp/start/transmission.sh and specify path to transmission home (settings) directory, where file-settings.json is located
Code:
userdel transmission
Quote:
#!/ffp/bin/sh

# PROVIDE: transmission

name="transmission"
command="/ffp/bin/$name-daemon"
home_dir="/mnt/HD_a2/ffpdata/$name"
required_files="$command"
transmission_flags="-g $home_dir -e $home_dir/$name-daemon.log --log-error"
runas_user="transmission"
runas_group="transmission"
uid="169"
gid="169"
TRANSMISSION_HOME="$home_dir"
export TRANSMISSION_HOME
Default home (settings) directory points to /mnt/HD_a2/ffpdata/transmission

8. # Start Transmission daemon service after updating or installing package:
Code:
sh /ffp/start/transmission.sh start

# In case of fresh install-edit /mnt/HD_a2/ffpdata/transmission/settings.json file:
"lpd-enabled": true, #(enable local peers discovery)
"rpc-whitelist": "127.0.0.1,192.168.0.*", #(add local-LAN (not wan ip in any case) ip address of your computer from which you are connecting to NSA or specify local subnet as I did)
"rpc-whitelist-enabled": true,
"rpc-enabled": true,
"rpc-authentication-required": true, #(enable WebUI and others RPC clients asking for username and password)
"rpc-password": "my_login_password", #(set password for transmission WebUI and RPC clients)
"rpc-username": "my_login_name", #(set login name for transmission WebUI and RPC clients)
"trash-original-torrent-files": true, #(remove added *.torrent files-why to collect garbages?)
"umask": 0, # (sets permission of downloaded directories to 777 and files to 666. Everyone is allowed to read, write and delete downloaded content. )
"watch-dir": "/mnt/HD_a2/video", #(set directory, where to put *.torent files for autodownload)
"watch-dir-enabled": true

Others config file options are explained here:
https://github.com/transmission/transmission/wiki/Editing-Configuration-Files
# Important!!! After editing, reload daemon service to accept changes in settings:
Code:
sh /ffp/start/transmission.sh reload

9. # Enable auto start of service on boot, if desired:
Code:
chmod 755 /ffp/start/transmission.sh

Several remarks:
Default download directory is /mnt/HD_a2/ffpdata/transmission/Downloads
Log file (only errors are logged) - /mnt/HD_a2/ffpdata/transmission/transmission-daemon.log
Editing settings.json, while Transmision daemon is running, will revert all your changes back after next daemon service restart.
So, stop it before editing and run it after editing or use:
Code:
sh /ffp/start/transmission.sh reload
to save changes persistently in settings.json, while daemon is running.
Recommended remote client to control Transmission download service-Transmission Remote GUI.


Top
 Profile  
 
PostPosted: Mon Jun 12, 2017 7:29 pm 
Offline

Joined: Tue Jan 20, 2015 9:46 pm
Posts: 21
Hello barmalej2,

Thank you very much for explain to me all the steps to upgrade all my libraries .

I have I little bit issue to execute step 4, restart the sshd.sh.
When i try to restart the sshd.sh i receive the next message:

Code:
root@Silax-Cloud:/ffp/bin# sh /ffp/start/sshd.sh restart
PROCESS STATUS INFO: sshd is not running
Starting sshd...[ Fail!!! ] ERROR WARNING: sshd can not start!!!


Can you please tell me how can I figure which is the problem? Where is the location for logs file ?

I thing that this sh is not properly configure.

I attached the old sh and the new sh

Old - http://s.go.ro/lfw4k8fp

New http://s.go.ro/khyfx9vg



Thanks,
Silviu


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 207 posts ]  Go to page Previous  1 ... 9, 10, 11, 12, 13, 14  Next

All times are UTC


Who is online

Users browsing this forum: Bing [Bot] and 49 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group