General NAS-Central Forums

Welcome to the NAS community
It is currently Sun May 28, 2017 4:59 am

All times are UTC




Post new topic Reply to topic  [ 482 posts ]  Go to page Previous  1 ... 28, 29, 30, 31, 32, 33  Next
Author Message
PostPosted: Sat Apr 30, 2016 6:19 pm 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2235
Blesk01 wrote:
I can not play any video file from my library.

Plex playback on arm NAS'es totally depends on client possibilities and client plex profile, because arm plex server has no transcoding ability.
Blesk01 wrote:
And why it always download Synology package? When I have Zyxel NAS shouldn't it be Netgear package?
That is "normal" for Zyxel 5** series, because they have newer libc library than NSA3** series, so there is no issues to use Synology package.


Top
 Profile  
 
PostPosted: Thu May 26, 2016 7:30 pm 
Offline

Joined: Thu May 26, 2016 7:26 pm
Posts: 1
Hi,

after login by ssh I try to send this command but I get this:

root@KRAIZ-NAS:~# slacker -UaA mz:plexmediaserver
Updating package lists...
fetch: rsync -q 'rsync://ffp.inreto.de/ffp/0.7/arm/packages/CHECKSUMS.md5' '/ffp/funpkg/cache/s'
rsync: getaddrinfo: ffp.inreto.de 873: Name or service not known
rsync error: error in socket IO (code 10) at clientserver.c(122) [Receiver=3.0.9]
FATAL: s: No CHECKSUMS.md5


And also can you please tell me where I have to put the PlexMediaServer-0.9.16.6.1993-5089475-arm.bin file after I download it ?

Thank you so much for your help in advance!


Top
 Profile  
 
PostPosted: Thu May 26, 2016 9:47 pm 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2235
For me it seems like DNS server or gateway misconfiguration on NAS. Might be related with incorrect DHCP configuration on router.
What is output of:
Code:
ping -4 -c4 ffp.inreto.de:873
and
Code:
ping -4 -c4 $(ip route show | awk '/^default/ {print$3})'
and
Code:
rsync -v 'rsync://109.75.188.159/ffp/0.7/arm/packages/CHECKSUMS.md5' '/ffp/funpkg/cache/s'

It doesn't matter, where you want to save PlexMediaServer-0.9.16.6.1993-5089475-arm.bin. It is used only to install particular version, mostly by plexpass users, because they get updates early. For common use choose install/latest from menu.
Also take a look here.


Top
 Profile  
 
PostPosted: Thu Jun 30, 2016 8:39 pm 
Offline

Joined: Mon Dec 29, 2014 10:07 am
Posts: 6
Just to change the subject a little bit, has anyone tried to install Plex 1.0 on their NSA310? I should be clever enough to hack the script to install it but I'm not quite sure where to start .... a couple of things have changed, the binary is marked as armv6 now and the Netgear package is distributed as a .deb file rather than .bin. I can easily get the contents of the deb file using
Code:
ar -x plexmediaserver-ros6-binaries_1.0.0.2261-a17e99e_armel.deb
but then I've run out of ideas :oops: The deb file contains control.tar.gz, data.tar.gz (the main PMS files) and debian-binary.

I also quickly checked the arm differences - I used
Code:
file Plex\ Media\ Server
in the extracted Binaries folder and compared it to bash installed in /ffp/bin and the only difference I can see is Plex shows 'for Gnu/Linux-2.6.32' and the NSA310 is running only 2.6.31.8.

Does it need an update to the plexmediaserver.sh script or is it an easy fix/hack to use the .deb file?


Top
 Profile  
 
PostPosted: Fri Jul 01, 2016 9:09 pm 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 5995
Have you tried to use the script to install the package? As far as I remember the script looks at the filetype, not the extension, and Netgear always had debian packages.

But it is possible it will install, and not work, due to the needed kernel version.

Anyway, I saw that Plex changed their download page layout, so downloading the 'Latest' version using the script won't work anymore, I guess.


Top
 Profile  
 
PostPosted: Sat Jul 02, 2016 8:42 am 
Offline

Joined: Mon Dec 29, 2014 10:07 am
Posts: 6
I hadn't tried just using the .deb file but I tried this morning and it tries to install then returns "Unrecognized file. Failed!" :(

I guess we're stuck on the kernel version until Zyxel upgrade?


Top
 Profile  
 
PostPosted: Sun Jul 03, 2016 12:12 pm 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 5995
Jimbob17 wrote:
I hadn't tried just using the .deb file but I tried this morning and it tries to install then returns "Unrecognized file. Failed!" :(
The installation is basically copying the binaries directory to /ffp/lib/plexmediaserver/, and creating some environment. You already have the environment, so you can install by just copying that contents.

Quote:
I guess we're stuck on the kernel version until Zyxel upgrade?
Don't hold your breath. With exception of the 325 the whole NSA line is EOL, and won't get any upgrades anymore. For the 325 a last upgrade is planned, but I doubt if that will have a new kernel.

BTW, if you want a new kernel, then you can install Debian on your box. A suitable kernel can be found here.

I have been looking at the Plex download page, and it's not clear to me if there is any ARMv5 package left. It's not specified anywhere. Maybe the 'Netgear Arm 6' in contrast with 'Netgear Arm 6 RN2xx'. The latter is ARMv7, so the first one might be ARMv5. (It's not ARMv6, there are hardly any ARMv6 SoC's around. The only one I know is the Raspberry PI v1. I think the 6 means dedicated for Netgear firmware v6).
For the Synology there is no ARMv5 anymore.

BTW, the 'Netgear Arm 6' segfaults on my NAS520, and when I force it to use the Entware libraries it doesn't run due to missing imports.

It would be nice if Plex could provide an Entware-ng package. Anybody on speaking terms with them?


Top
 Profile  
 
PostPosted: Thu Jul 07, 2016 3:59 am 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2235
Quote:
Starting with Plex Media Server version 0.9.17.0, NAS devices that use the following processors or operating systems are no longer supported.
ARMv5 processors
◦PowerPC (PPC) processors
◦32-bit processors for unRAID
◦ReadyNAS OS 4 (ROS4) operating system

That means that Plex Media Server versions 0.9.17.0 and newer will not be available and will not run on those devices.

Note: Existing installs of older Plex Media Server versions will continue to function as they did before, but newer versions will not be available for those platforms.

Source: https://support.plex.tv/hc/en-us/articles/218212517-Which-NAS-devices-are-no-longer-supported-starting-with-0-9-17-0-server-
and https://forums.plex.tv/discussion/212842/armv5-powerpc-and-readynas-ros4-no-longer-supported-starting-with-plex-media-server-0-9-17-0

Quote:
As part of this focusing of resources, versions of Plex Media Server prior to 1.0 will no longer be available for download.
Source:https://forums.plex.tv/discussion/222559/plex-media-server-availability

Discussion, which shows opinion regarding plex on armv5 devices:
https://forums.plex.tv/discussion/212925/armv5-the-good-and-the-bad


Top
 Profile  
 
PostPosted: Sat Jul 23, 2016 6:26 pm 
Offline

Joined: Mon Mar 03, 2014 7:41 pm
Posts: 5
Does anyone have a copy of the most 'recent' plex install before it was pulled from the download servers ie plex 0.9.16.6. Thanks


Top
 Profile  
 
PostPosted: Mon Jul 25, 2016 7:41 am 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2235
Even if download links has been removed from plex website, you can still download using direct download links. Last available version for armv5 boxes:
https://downloads.plex.tv/plex-media-server/0.9.16.6.1993-5089475/PlexMediaServer-0.9.16.6.1993-5089475-arm.bin
Use Update>Local_file to install it.


Top
 Profile  
 
PostPosted: Wed Aug 17, 2016 9:18 pm 
Offline

Joined: Thu Jan 14, 2016 3:53 pm
Posts: 7
Can anyone tell me the steps I'd need to take to get Plex running again if I updated the firmware? Would it be a full re-install?

I'm running V4.70(AFK.1), but the newest release is V4.70(AFK.3)


Top
 Profile  
 
PostPosted: Thu Aug 18, 2016 9:41 am 
Offline
User avatar

Joined: Mon Dec 21, 2015 7:21 pm
Posts: 584
Hi!

If You do an fw upgrade, You don't need to redo the steps, because the fw upgrade don't damage anything at ffp.

So it will works too after an upgrade.

_________________
Thanks nas-central the lot of help! :)


Top
 Profile  
 
PostPosted: Thu Aug 18, 2016 12:34 pm 
Offline

Joined: Thu Jan 14, 2016 3:53 pm
Posts: 7
Thanks! So would it just be a matter of starting the plex media service again once the firmware update is complete and the NAS has rebooted?


Top
 Profile  
 
PostPosted: Sat Aug 20, 2016 8:04 am 
Offline

Joined: Thu Mar 20, 2014 6:28 pm
Posts: 9
Hi!

How to update Zyxel NSA-310 Plex Server?

Problem:

Image

Image

Edit: .bin file updated, no problem, all work :)


Top
 Profile  
 
PostPosted: Wed Nov 23, 2016 1:30 pm 
Offline

Joined: Wed Nov 23, 2016 1:16 pm
Posts: 1
offbeatdave wrote:
Just a quick update on my update issues on my NSA310 in case anyone else had problems with some of the recent 'available to all' versions.

0.9.12.19 (Nov 6th 2015) worked every install
0.9.14.6 (Dec 23rd 2015) failed to start
0.9.15.2 (Jan 22nd 2016) failed to start
0.9.15.3 (Feb 3rd 2016) WORKS!

Edit 1: 0.9.15.3 menu navigation seems more responsive (via RARflix on NowTV_v1 and RokuLT_v1) than 0.9.12.19
Edit 2: 0.9.15.3 playback selection seems less responsive (via RARflix on NowTV_v1 and RokuLT_v1) than 0.9.12.19

Thanks as always to everyone who makes this functionality possible on the NSA310!



Where can i get the full path to download 0.9.12.19 or 0.9.15.3 that works for NSA310? any place where I can see all arm v5 versions?
thanks


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 482 posts ]  Go to page Previous  1 ... 28, 29, 30, 31, 32, 33  Next

All times are UTC


Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 59 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group