General NAS-Central Forums

Welcome to the NAS community
It is currently Sat Oct 21, 2017 6:50 am

All times are UTC




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: Newbie tryied Recovery
PostPosted: Fri Sep 19, 2014 7:46 pm 
Offline

Joined: Fri Sep 19, 2014 7:13 pm
Posts: 2
Hi Guys, this place it's fantastic, are many days that i read here about recovery DIY, :twisted:
For first, scuse my bad fucking Eng, but i'm a very lazy boy.. :roll:

At work we had a Iomega NAS.. :oops:
...
....

The 4th disk was gone, (for smart ctl) and for a stupid guy 3 disk of 4 was been reinitialized!
:lol: :lol: :lol: :lol: :lol: :lol: :|
For first i did a DD copy for each disk to another quartet of 1Tb Disk..
And i was in this situation:

2Gb 997Gb
1) /dev/sda1 - -
2) /dev/sdb1 - -
3) /dev/sdc1 - -
4) /dev/sdd1 /dev/sdd2

With a calc in the hand and many hours with HexEditor i found the start of the data on 1,2,3 disks...
Obviusly the data start it's not the partition start.. i established that first 10mb of disk 1 2 and 3 was zero filled... :geek:
(i don't remember indexs but i'll post all my tables tomorrow)

I made same partition table for all 4 disk, cloning the structure of 4th:
2Gb 997Gb
1) /dev/sda1 /dev/sda2
2) /dev/sdb1 /dev/sdb2
3) /dev/sdc1 /dev/sdc2
4) /dev/sdd1 /dev/sdd2
Finded old dumps of mdadm i rebuilded the RAID5 from the NAS with SSH...
mdadm --create --assume-clean ecc...

I obtained a readable volume of 2.7Gb..
Mounted the RAID5 on PartedMagic..

checked with photorec and i obtained 15mb zip archives and a lot of big jpeg so i can say that RAID work very fine..
:mrgreen: :mrgreen: :mrgreen:

Now...
Searching the partition...
{... skipped all my mental masturbations on LVM group that i resolved with a loopback from the offset that i find in the system partition of the nas...}

I know that, the partition is an XFS, i found the start of the superblock :shock: :shock:
It was on 4th disk 8-)
but... :'
Recovering and trying with many programs, forcing the xfs_repair -L and ecc..
i can see only few file, that are intact, but i can't find my ISCSI disk of 5Gb...
i found another disk of 100Gb but it's not what i want..
In addiction the internal data of Virtual ISCSI disk make my life terrible with a RAW recovery...
So any suggestion?
Is there a method to restore lost XFS inode?
Knowing the start of my ISCSI Disk, can i copy it contiguously?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group