Device not registering in local DNS

Post Reply
Talegolas
Posts: 2
Joined: Sat Nov 01, 2014 9:40 pm

Device not registering in local DNS

Post by Talegolas » Sat Nov 01, 2014 9:56 pm

hi ,

I have set up the device to use DHCP and it is only using one of the eth ports. The problem is that the device does not seem to register with the DNS service. My other devices (a samsung printer and a linux mint computer) do get their hostnames register and i can ping/resolve them from any other computer connected to the network, except the ix4.

any thoughts? out of the box never did it (only windows computers can find it via name), and I have connected via ssh, and added some lines to the /etc/network/interfaces file ("hostname myname") right after the active eth line..no luck.

I also see that the dhclient.eth1.leases contain all relevant information from the DHCP server, but it does not seem to be used at all.. data such as:
option subnet-mask 255.255.255.0;
option routers 192.168.1.1;
option dhcp-lease-time 86400;
option dhcp-message-type 5;
option domain-name-servers 192.168.1.1;
option dhcp-server-identifier 192.168.1.1;
option dhcp-renewal-time 43200;
option broadcast-address 192.168.1.255;
option dhcp-rebinding-time 75600;
option domain-name "mydomain.net"

thoughts?

Thanks.

Talegolas
Posts: 2
Joined: Sat Nov 01, 2014 9:40 pm

Re: Device not registering in local DNS

Post by Talegolas » Sat Nov 01, 2014 10:19 pm

Never mind, i just found out.

the dhclient.conf file needs to be updated to send the host-name to the DHCP server.. with it, it gets registered and now i can do nslookup to it.

Post Reply