Web displays storage degraded but not which drive

Post Reply
User avatar
robwaybro
Posts: 3
Joined: Tue Jun 02, 2015 12:33 pm

Web displays storage degraded but not which drive

Post by robwaybro » Tue Jun 02, 2015 2:34 pm

Iomega StorCenter ix4-200d - ver 2.1.46.30093

The web portal indicates the storage is degraded "The Iomega StorCenter device is degraded and data protection is at risk" but when following the links/path, the drives all look fine (see attachment).

When I look at:

Code: Select all

mdadm --examine /dev/sdd1
I get:

/dev/sdd1:
Magic : a92b4efc
Version : 00.90.00
UUID : 43b97abd:c36fa8f1:205dc2dc:01ac1aa0
Creation Time : Thu Jul 30 16:47:25 2009
Raid Level : raid1
Used Dev Size : 2040128 (1992.65 MiB 2089.09 MB)
Array Size : 2040128 (1992.65 MiB 2089.09 MB)
Raid Devices : 4
Total Devices : 3
Preferred Minor : 0

Update Time : Tue Jun 2 10:23:52 2015
State : clean
Active Devices : 3
Working Devices : 3
Failed Devices : 1
Spare Devices : 0
Checksum : 725f89b6 - correct
Events : 76244


Number Major Minor RaidDevice State
this 3 8 49 3 active sync /dev/sdd1

0 0 8 17 0 active sync /dev/sdb1
1 1 0 0 1 faulty removed
2 2 8 33 2 active sync /dev/sdc1
3 3 8 49 3 active sync /dev/sdd1


What is the "faulty removed' and how can I correct it as this seems to be a problem, and maybe the problem.

Thanks in advance.
You do not have the required permissions to view the files attached to this post.

vincieh
Posts: 6
Joined: Wed May 27, 2015 12:43 pm

Re: Web displays storage degraded but not which drive

Post by vincieh » Wed Jun 03, 2015 2:22 am

I am guessing here. I don't see /dev/sda1

would it be the first drive?

If you click on storage->drive management

You should see a picture of all the drives. Does it indicate which is faulty?

User avatar
robwaybro
Posts: 3
Joined: Tue Jun 02, 2015 12:33 pm

Re: Web displays storage degraded but not which drive

Post by robwaybro » Thu Jun 04, 2015 7:23 pm

Thank you. I agree that sda1 is not shown but I am trying to determine which physical drive is defective.

I thought the picture that I attached to the initial query was the drive management you are indicating and as you can see it displays all drives in an operational status. Even when I hover over the drive the context popup also says "Disk is operating normally".

I will include the screen shot again, just in case it didn't come through right the first time.
You do not have the required permissions to view the files attached to this post.

doug80638
Posts: 8
Joined: Wed Feb 18, 2015 12:00 am

Re: Web displays storage degraded but not which drive

Post by doug80638 » Fri Jun 05, 2015 2:37 am

sda is disk 1.

Shut it down and pull disk one and reboot and you should get the same results.

There is a dependency with Seagate disk drive firmware and the NAS firmware and I'm guessing that the WD replacements don't quite mesh. I know my Toshiba drives suffer from the lack of certain firmware support.

You can use hdparm to look at each drive.

hdparm -I /dev/sda

User avatar
robwaybro
Posts: 3
Joined: Tue Jun 02, 2015 12:33 pm

Re: Web displays storage degraded but not which drive

Post by robwaybro » Fri Jun 05, 2015 2:03 pm

Thanks for the confirmation Doug, I appreciate it.

I just replaced drive 1 and the reconstruction is in progress.
doug80638 wrote:sda is disk 1.

Shut it down and pull disk one and reboot and you should get the same results.

There is a dependency with Seagate disk drive firmware and the NAS firmware and I'm guessing that the WD replacements don't quite mesh. I know my Toshiba drives suffer from the lack of certain firmware support.

You can use hdparm to look at each drive.

hdparm -I /dev/sda

Post Reply