power off problem

Post Reply
jarnox
Posts: 4
Joined: Mon Mar 03, 2014 10:18 pm

power off problem

Post by jarnox » Mon Oct 05, 2015 12:20 pm

Hello everyone,
I have a problem with turning off the nas.
I have two ix4 200d, both with the same problem.
I upgraded the hard drives, and I followed the instructions to upgrade from USB, then I upgraded to the latest firmware, all is ok.... but
when I turn it off from the web or by ssh, the hard drives stop and the symbol of shutdown appears on the display. The nas remains so. The only thing that I can do is shut down the power supply!!!
What can i do?
thanks
You do not have the required permissions to view the files attached to this post.

Mijzelf
Posts: 6207
Joined: Mon Jun 16, 2008 10:45 am

Re: power off problem

Post by Mijzelf » Tue Oct 06, 2015 1:18 pm

Does the ssh connection drop?

jarnox
Posts: 4
Joined: Mon Mar 03, 2014 10:18 pm

Re: power off problem

Post by jarnox » Tue Oct 06, 2015 2:30 pm

Yes!

Mijzelf
Posts: 6207
Joined: Mon Jun 16, 2008 10:45 am

Re: power off problem

Post by Mijzelf » Wed Oct 07, 2015 7:49 am

In that case at least the shutdown is initiated. There are 2 possibilities, either somehow the shutdown is canceled, or the kernel uses an inappropriate way to power off the box. Or due to a hardware defect the box can't be powered down.

The most effective way to debug this is by connecting a serial cable. The box sends it's console messages to the serial port, so if the last message is 'powerdown' while the box stays on, you know the kernel fails in telling the hardware to effectively poweroff. But you also know you can safely pull the plug, as all disks are flushed and unmounted.

Post Reply