General NAS-Central Forums

Welcome to the NAS community
It is currently Wed Dec 13, 2017 9:09 am

All times are UTC




Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Tue Jan 05, 2016 1:48 pm 
Offline

Joined: Tue Jan 05, 2016 1:45 pm
Posts: 6
I fear I totally bricked my ix4-200d... :shock:
Accidentally I erased the whole NAND, not only the two partiations. :oops: :oops: :oops:
Now it is no longer talking to me, not even on serial... Is there any possibility to recover it? Is there some magic way to reload uboot?


Top
 Profile  
 
PostPosted: Tue Jan 05, 2016 7:40 pm 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 6087
Maybe. AFAIK the IX4-200D runs a Kirkwood, so maybe kw-boot can help you to load a u-boot in memory, which you can use to flash another u-boot.


Top
 Profile  
 
PostPosted: Wed Jan 06, 2016 1:35 pm 
Offline

Joined: Tue Jan 05, 2016 1:45 pm
Posts: 6
Mijzelf, I am talking to my ix4 via kw-boot now!!! Great so far! But where can I get the u-boot for the ix4? Google did not report anything... Is it possible that someone would dump a NAND image of a working system? Or how can I get the correct u-boot?


Top
 Profile  
 
PostPosted: Wed Jan 06, 2016 8:31 pm 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 6087
I don't know. U-boot is GPL, so Iomega should publish the (adapted) sources. But AFAIK they don't. I downloaded the current GPL package (for ix4-300d) and it doesn't contain u-boot sources.
You can open a request. You have a box, they should provide the GPL sources.

Of course it's possible to extract u-boot from another ix4-200d (I don't have one), but I don't know if that can be used to be uploaded by kw-boot, to boot the box, as it expects to be in flash, not in ram.

Maybe you can ask the guys in the doozan forum for help.


Top
 Profile  
 
PostPosted: Wed Jan 06, 2016 9:20 pm 
Offline

Joined: Tue Jan 05, 2016 1:45 pm
Posts: 6
Where did you download the sources?
What is the site to open a request?


Top
 Profile  
 
PostPosted: Thu Jan 07, 2016 8:23 pm 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 6087
Reto wrote:
Where did you download the sources?
https://lenovo-na-en.custhelp.com/app/answers/detail/a_id/34437/
Quote:
What is the site to open a request?
Don't know. Maybe the 'Contact us' hyperlink.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group