How to update php to version 5.3+

Post Reply
Reto
Posts: 6
Joined: Tue Jan 05, 2016 1:45 pm

How to update php to version 5.3+

Post by Reto » Wed Mar 09, 2016 10:28 am

Hi,

I installed apache webserver on my StorCenter ix4-200d. My current configuration is running php 5.2 but I need php 5.3 to run OwnCloud. I used the source http://francisek.is.free.fr/downloads/q ... /fsk-armel and installed php 5.3 with "ipkg install php53". The install seems to be successful but when I try to restart apache I get the following error:

Code: Select all

[Wed Mar 09 11:25:42 2016] [crit] Apache is running a threaded MPM, but your PHP Module is not compiled to be threadsafe.  You need to recompile PHP.
Pre-configuration failed
How can this be fixed?


Thanks,

Reto

Post Reply