StorCenter ix4-200d system recovery

Posts: 1
Joined: Sat Aug 18, 2012 6:53 am

Re: StorCenter ix4-200d system recovery

Post by donpedro » Sat Aug 18, 2012 7:10 am

Hi jeanpat007,

I have the same trouble.
Do you find a boot image for cloud edition restore?

Upgrade by standart manner (upload new image to the ix4-200d and apply update) doesn't work, i have message "You have version, this update should be applied on the version and later"

I find comments that no upgrade available from standart edition to cloud edition for ix4, but the reason is BIOS & hardware incompatibility.
for our case this is not a problem, we have HW & bios for cloud edition.

if you resolve this - let me know

Posts: 2
Joined: Sun Jul 29, 2012 8:27 am

Re: StorCenter ix4-200d system recovery

Post by jeanpat007 » Thu Aug 23, 2012 9:02 pm

Hello donpedro,
not yet, I always look without finding the solution.
I have even to try to recompile an update 3.xx without success.

We need absolutly a copy of the system files of the Cloud edition...
;) Would have somebody on this forum there to realize a copy of its own files??? for us

ladiko perhaps ..... :roll:

Posts: 1
Joined: Fri Aug 31, 2012 9:26 am

Re: StorCenter ix4-200d system recovery

Post by ThirtyOne34 » Fri Aug 31, 2012 9:40 am

I've got an ix4-200d without disks and I'm trying to install it with one disk. When I plug the power cord, the Iomega boots automatically (I can't shut it down without unplugging the power cord). It boots with the Iomega logo on the display and after some time there are a USB key and a Network displayed on the LCD screen of the NAS (like in the first post). I've already tried with 3 USB sticks to boot the NAS with the instructions provided by ladiko and masteroid, but without success... (It just does the same as without a USB stick connected). The one disk I have is a 2 TB Western Digital Caviar Green EARX disk, which I formatted with Knoppix like instructed by ladiko

Has anyone with the same problem succeeded to solve this? I've read this topic several times and tried again and again, but I'm not succeeding :(
ronald123 wrote:Hello

i have a question i have 4 x ix4 200D al the iomega drive's have no hard disk en i have a question

run this thiks also with one drive.

And can i also do the systeemrecovery.

this is waht the iomega ix4 do

when i power op the ix4 it's direct blikt the whith led en powerd op the lcd display abouwt a 45 sec in the lcd display i get a netwerk en a Batterij???? symbol.

i hope you can help my with this thinks.
Ronald, this seems the same problem as mine. Have you already found a solution?
EDIT: And if it's allowed on this forum, you can reply in Dutch to me (I think you speak Dutch :p), or with a PM.

Posts: 1
Joined: Sun Jan 20, 2013 3:08 pm

Re: StorCenter ix4-200d system recovery

Post by krys69 » Sun Jan 20, 2013 4:01 pm

Hi all, I hope you're well

I've got an ix4-200d too after several freeze and raid rebuild when i would like to copy a group of files or a file largest than 2gb. I tested the 4 disks without any error found. I decided to use a similary process that described in this post without success. In the process to prepare the disks, it was indicated to alterate partition table, so i did it (without backup of my disks, i'm so stupid i know).

Now the nas is bricked, i tried to speak with iomega support without success too. All process to recovery os with firmware usb stick failed.

Recovery the disk with testdisk or another soft failed too. With tesdisk i could see some partitions one of them have files similar to os linux the part size is 2gb and files size is 800 mb but i can't recover the partition because i use "none" type. I can only recover files and folder one by one. When i want to prepare the disk with mdadm, i cannot make partion at the first cylinder like is mentionned in this process for a ix2 ( ... ement.html)

I have two questions :

For several of you the usb stick process is functional, somebody can tell me how it's possible, in the firmware "emctools" there isn't a linux os, the size is around 100 mo and the ix4 os seems to be around 800mb ?

One of you can indicate to me exactly the partition table of one disk used by the iomega ix4 (with cylinder start and end), please ?

oh another things can help me, if somebody can make an image of the os partition and upload it or peer it.

Any advises or help will be appreciated.

Thanks for your feedback.

Sorry if my english is not correct i am a poor french guy

Posts: 1
Joined: Sun May 05, 2013 10:52 am

Re: StorCenter ix4-200d system recovery

Post by rafroad » Sun May 05, 2013 11:38 am

Thanks a lot :)

My Iomega is now rebuilding and hoping for the best.

Posts: 13
Joined: Sat Sep 03, 2011 1:35 pm

Re: StorCenter ix4-200d system recovery

Post by ladiko » Sat May 18, 2013 2:36 pm

I followed my own instructions to update my ix4-200 with 4x WDC WD20EARS 2TB. I did 2 major mistakes:

1) I didnt press the Reset-Button on the back of the device with a pen while switching it on (instead i just tried to press the power button for 30sec)
2) I didnt properly inserted the HDDs so they didnt connect to the SATA/Power-Port

After i figured out these novice mistakes, it just worked as described, it wasnt even necessary to delete the disks or partions before.

Posts: 1
Joined: Tue May 28, 2013 11:39 pm

Re: StorCenter ix4-200d system recovery

Post by sevenace » Tue May 28, 2013 11:46 pm

Thanks for everybody's post.
It's been helpful in isolating the issues I'm having with a couple of our StorCenters ix4-200d's.
Special Thanks to zzwdup - I wasn't aware you can bump up the capacity for the NAS to handle 2TB drives.
Appreciate your help.

In case your NAS motherboard gets fried - I was able to recover my NAS using UFS RAID Recovery ver. 5.8.1 (or later) and a desktop that can handle 4 x USB-to-SATA devices to reconstruct a virtual RAID.

There were unrecovered fragments but most of the files (95%) were recovered.

Posts: 1
Joined: Sat Jun 01, 2013 6:21 pm

Re: StorCenter ix4-200d system recovery

Post by styxlord » Sat Jun 01, 2013 6:39 pm

I had an old ix4-200d sitting around that had previously been upgraded from 500G drives to 2T drives (by swapping out one drive at a time and letting it rebuild). After doing something else with the 2T drives I put the old 500G drives in but it was bricked and had been sitting on a shelf.

I followed the instructions to wipe the drives and build a USB stick and it appears to have revived it :D

Notes of things that I encountered that might help others:
  • I wiped the drives using an external USB drive dock. If you have lots of hard drives lying around, these things are really handy.
  • I initially formatted the USB stick on a mac and put the files in the right spots but that didn't work. It booted up, looked at the drive then just went to the "please plug me into something" screen.
  • Curiously the USB stick that was setup on the mac was readable on a Linux VM which thought that it was FAT32 and could see the files.
  • I fired up a Windows XP VM and connected the USB stick to that which claimed it wasn't formatted, so I reformatted it there and copied the files on inside the VM. This seems to have made a difference when it came to the device being able to read the USB stick.
  • My device was in a state where plugging in the power cable started it, so I held down the reset button whilst plugging in the power, waited (a brief eternity) and eventually the USB stick started reading.
  • After a while of reading the USB stick the unit powered itself off.
  • I hit the power button on the front of the device. It started up, initialized the disks which took only a minute or so and currently doing "Data protection is being reconstructed" which looks like it'll take a few hours to complete.
  • I can get into the web site on the device and have set it up so all looks well.

Posts: 13
Joined: Sat Sep 03, 2011 1:35 pm

Re: StorCenter ix4-200d system recovery

Post by ladiko » Sun Aug 18, 2013 9:33 am

Good to here my solution worked again - seems like the ix4s are unbrickable, if you know how to fix it :)

Posts: 1
Joined: Mon Sep 30, 2013 2:02 am

Re: StorCenter ix4-200d system recovery

Post by sickiggy » Mon Sep 30, 2013 2:08 am

I've been able to format the drives, get the flash stick formatted w/ the recovery firmware, get the x4-200d to read the flash drive... but then it just sits like this:

What will a successful "fix" display?

Any info or insight would be appreciated :)


After using some patience I let it get back to the 'brick' screen (would take 2 or 3 minutes to end up here), held down the reset button again with just the emctools USB stick and it seemed to recover fine. Much like the post above me, the unit turned itself off after completing some type of task (it displayed a progress bar).

Posts: 13
Joined: Sat Sep 03, 2011 1:35 pm

Re: StorCenter ix4-200d system recovery

Post by ladiko » Mon Sep 30, 2013 9:00 am

Usually people don't press the reset button as described, that was my fault, too, when i replaced the 4x 500GB HDDs with 4x 2000GB. After going through the thread again, it worked like a charm.

Posts: 1
Joined: Sun Nov 24, 2013 12:31 pm

Re: StorCenter ix4-200d system recovery

Post by likecapf » Sun Nov 24, 2013 12:41 pm


Posts: 13
Joined: Sat Sep 03, 2011 1:35 pm

Re: StorCenter ix4-200d system recovery

Post by ladiko » Sun Nov 24, 2013 1:02 pm


Posts: 1
Joined: Sat Jan 25, 2014 7:15 am

Re: StorCenter ix4-200d system recovery

Post by Jonathan98011 » Sat Jan 25, 2014 7:49 am

Thanks all bee for this thread... I pulled a real brain-dead stunt with my px4-200d. It kept erroring out on one of the drives and I was just using it for VM sandboxing... I had a bunch of WD 2TB blacks laying around and one night I decided to tear down the NAS and make it an 8TB unit... No problem right?

Threw the new drives in and went to bed only to find out that I created a nice black brick... Well its been sitting in a heap of junk in the bottom of an old rack in my garage for almost a year because initial efforts to get useful info from Iomega was more time than I had to kill.

For no particular reason I decided to do a little searching and found this thread a couple of hours ago and the system is rebuilding as we speak :).

Thank you so much for the excellent insight... I operate 8 PX4's in the field primarily as backup san devices for disaster recovery and a couple desktop versions that are being recycled for home use. I like Ultrastor RS*-IP4's for production... Good bang for the buck... It is refreshing to know if I cant get insight from iomega/Lenovo that there is a good group here with variety of experience.

I basically downloaded the archive

Created the USB

Booted the NAS as prescribed.

It got to 75% and shut off... I powered it back up (did not hold reset on second power up).

The system made it all the way to full boot and indicated it was rebuilding.

NOTE: no format on the drives. New out of the package WD 2TB black server grade sata. (WD2003FYYS-02W0B)

I checked the IP and logged in remotely.

COOL! Reconstruction at 4% and I started reading this blog 2 hours ago.

Showing 5.5TB of free space and I was about ready to pull the drives and toss it.

Posts: 32
Joined: Fri Mar 14, 2014 9:46 pm

Re: StorCenter ix4-200d system recovery

Post by Qesc » Fri Mar 14, 2014 10:53 pm

Hi all,

I bricked my ix4-200d 4x1To, by upgrading to Cloud edition.. now it reboot continully, cannot go to "usb" stage so I cannot recovery with a USB key, and the button "reset" in the back does not work neither..

could anyone tell me what to do to de-brick it , please?

Post Reply