General NAS-Central Forums

Welcome to the NAS community
It is currently Sun Dec 17, 2017 11:52 am

All times are UTC




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: LGNAS N1A1 hard disk
PostPosted: Thu Dec 08, 2016 10:40 pm 
Offline

Joined: Thu Dec 01, 2016 5:27 pm
Posts: 2
My NAS drive worked fine for 3 years, then last week I could no longer see it on any of my computers.
All the front panel lights seem fine the ethernet connection looks fine.
I suspect the hard drive so can I replace it with any 3.5 inch sata HD ?


Top
 Profile  
 
 Post subject: Re: LGNAS N1A1 hard disk
PostPosted: Sat Dec 10, 2016 3:39 am 
Offline

Joined: Sat Dec 10, 2016 3:36 am
Posts: 1
I am trying that very thing right now... If anyone knows any tricks, I would very much appreciate them!


Top
 Profile  
 
 Post subject: Re: LGNAS N1A1 hard disk
PostPosted: Sat Dec 10, 2016 9:36 am 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 6091
Some time ago I bought a 2nd hand diskless dual bay LG NAS, can't remember the exact type. This model had it's OS on disk, and so it didn't boot with only a random disk inserted. It happened that the bootloader in flash had support to install new firmware on disk, for this you need a special tool which accesses the bootloader over network. One of the firmware downloads from LG happened to contain this tool (Windows only, I'm afraid). When I remember well the procedure was: start the tool, power up the NAS, which is connected to the same wired network, and wait.


Top
 Profile  
 
 Post subject: Re: LGNAS N1A1 hard disk
PostPosted: Mon Dec 12, 2016 10:04 am 
Offline

Joined: Thu Dec 01, 2016 5:27 pm
Posts: 2
I decided to remove the NAS hard drive and connect it to my computer.
So now both the Device manager and the Bios recognize the drive ( Hitachi 1 TB).
No problem indicated.
So can I assume the drive is okay ?
If so then the problem is with the NAS bay itself.
All the LED's are looking fine. Are there any more checks I can do ?
Thanks.


Top
 Profile  
 
 Post subject: Re: LGNAS N1A1 hard disk
PostPosted: Mon Dec 12, 2016 11:39 am 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 6091
cullenbc wrote:
So can I assume the drive is okay ?
Look at it's SMART values. If they are OK, the disk is probably OK.
Quote:
If so then the problem is with the NAS bay itself.
Not necessarily. When the disk is OK, the filesystem containing the OS still can be corrupted. In which case the box doesn't boot.
Quote:
All the LED's are looking fine. Are there any more checks I can do ?
A few.
  • You can boot your PC from a Linux Live USBstick, and see if you can mount the partitions of that disk. If some small partition (100MB~2GB) fails to mount due to filesystem errors, you can try to repair that.
  • Connect to the serial port on the NAS, to look at the bootlog. But that's not trivial. Here is some documentation about another LG.
  • Connect your PC directly to the NAS, use Wireshark to monitor the network port, and power on the NAS. Wireshark will tell if any network access is present.
  • Do a portscan to see if anything is active.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group