bricked after FW-update?

Posts: 777
Joined: Wed Mar 18, 2009 11:13 pm

Re: bricked after FW-update?

Post by fvdw » Sat Dec 27, 2014 8:10 pm

yes this capacitor could be the problem, it seems to have been leaking. This type has this problem see here
These capacitors can go bad after period of time. Hopefully the stuff that came out has not damaged the board itself.

You could try to replace it, nothing to loose on a board that won't boot. But be careful with replacing, the board contains surface mount parts, (very tiny electronic components) if you heat the board up too much then they could fall off.
But as this a capacitor which is rather big it should be not big of a problem with nice small soldering tool and careful operation

Posts: 134
Joined: Wed Dec 16, 2009 9:57 pm

Re: bricked after FW-update?

Post by andreus » Sun Dec 28, 2014 10:42 am

Hum, my hardware skills are ... how will i say this ... zero. :lol:
Everything i touched at that level ... broke up :D
Since now i know what is needed, i will try to see if someone with hardware skills can repair it for a small price.

Posts: 7
Joined: Mon Dec 22, 2014 9:56 am

Re: bricked after FW-update?

Post by Fonzman » Sun Dec 28, 2014 6:35 pm

Yes!! My improvised PSU works like a charm, and my 5Big is up and running again! And now I see, that the firmware-update was actually successful ;-)
I thank all of you for your advice and ideas - I'll never again underestimate the power(lessness) of a power supply! :mrgreen:

andreus, just a quick word about your capacitor.
Some years ago I repaired 2 or 3 pc-mainboards myself by changing broken capacitors with fresh ones. I used a cheap soldering iron, and I didn't care too much about heating up the board .. even if pc-mainboards are 4 to 6 layered, in the end everything worked fine for another couple of years :-)
So I don't think you could do so much wrong. Changing a capacitor is quite straight forward .. heat up one of its legs, and pul the capacitor out the other side .. if the first leg is loose, heat up the other one, and pull the thing out fully. Normally most of the solder goes out with the legs, so you are left with two empty holes. Push the replacement capacitor (take care, that you mount it right! The black or white line with the arrows needs to be on the same side as before!) into these holes, and put some solder to the legs. voilá - repaired :-)

I recommend a capacitor with the same µF but a little more volts .. that makes it more durable in the future.

Posts: 1
Joined: Mon Dec 19, 2016 10:43 am

Re: bricked after FW-update?

Post by astennu87 » Mon Dec 19, 2016 11:18 am

I have a very similar problem.
I had a fully working Lacie 5Big Network2 NAS, completely empty (visible on the network, could access dashboard via browser, leds indicated working status). As I need to configure it as a MAC time machine, I figured I start with a firmware update. I had version, wanted to update to the newest - it finished at 100% but displayed an error message that it timed out, please restart the browser. After I did, the device completely disappeared from the network and could never access again ever since.
Now I am trying it in a test environment, NAS and laptop connected to a router (DHCP) but it does not assign IP to it.
Contacted support, they suggested to take out all the drives, connect them to a PC with SATA - USB cable or dock and carry out a cleaning using the diskpart command line tool. I did so, now all the drives are empty (not formatted) I guess there is no OS on them or even RAID config. Lacie Network Assistant not able to see it, Recovery mode does not work (I gave up after waiting over 24 hours). Tried IP address scanning, so maybe I can find it somewhere on the network (looked for APIPA adress) but sadly no luck. I have tried with different hard drives, router, adding switch, changed cables, notebook... whatever I could imagine but nothing worked.
A few quotes from LaCie Support:
The casing should have a version of the OS in a zip file and but following the instructions for putting them the casing as clean drives it should initialize and install the version of the OS that is in the casing.
It sounds like the OS that is embedded in the firmware of the casing is corrupted and not able to do the install. You can try other disks, these units have in the passed had both Hitachi and Western Digital in them, I cannot guarantee they will work but the shouldn't do any harm.
I have access to their FTP site so i can download capsules with earlier versions as well, but everything is pretty much pointless until the NAS is accessible.
Let me know if you found any solutions that could help my case, THANK YOU!!

Posts: 6251
Joined: Mon Jun 16, 2008 10:45 am

Re: bricked after FW-update?

Post by Mijzelf » Mon Dec 19, 2016 2:33 pm

If you only deleted the partition table, you should be able to recover the partition table using TestDisk, in which case you have your old installation back.

I never looked at the NBig NAS insides, so I don't know how the partitions are arranged. On older boxes it used a layered filesystem, a r/w partition is mounted on top of an r/o partition. The r/w partition contains all updates and patches, and the r/o partition the 'factory default' firmware.

So if the NBig NAS is build the same, you could delete all files on that r/w partition, and so reset it to factory. Unless there was also a kernel update, in which case some partition has to wiped.

If you can restore the partition table, and can post a partition layout, maybe I can tell you which partition to erase.

Posts: 777
Joined: Wed Mar 18, 2009 11:13 pm

Re: bricked after FW-update?

Post by fvdw » Mon Dec 19, 2016 5:48 pm

Assuming this is really a 5big network2 than you need to know (and lacie support also) that there are two version. 1 that has been sold without disks, and 1 sold wirh disks. The first, diskless version has indeed firmware installed in flash memory and can initialize new disks. The vesion sold with disk has no firmware in flash and cannot initialize new disks. To find out which version you have you could use our fvdw-sl console to load a special kernel that runs from RAM and let you investigate your disks.
All can be found on including our alternative firmware that can be used on the 5big2 as well.
Ps There is no need to install our firmware if you want to use our standalone kernel to investigate your nas

Post Reply