5big2 doesn't wake up from deep sleep mode

Post Reply
xut
Posts: 5
Joined: Wed Jul 08, 2015 1:16 pm

5big2 doesn't wake up from deep sleep mode

Post by xut » Wed Jul 08, 2015 2:26 pm

Hello,

I upgraded my 5big2 from OS 1.2 to the last official OS. The update was successfull. To shut it down, I enabled the deep sleep mode and my 5big2 has never start up with LNA or the front button.

I tried several times a factory reset without erasing datas: power on the 5big2 and simultaneously push on the front button until it becomes red. The front LED has never been red. But something was happening because I lost my static IP address. It has now a dynamic address. When I power on the 5big2, the front LED is always flashing blue during hours and hours and the disks are working but why? Only 2 ports are opened: http and https. If I connect myself on the http server. I can read "the device may be starting up. please wait a few minutes." and that's all!

First, I would like to save my datas (if I always have them). Can I connect my 5 disks to a linux box with sata/USB converters? Does the mdadm package installed on this linux recognize the RAID5?

Second, how I can do to start up the 5big2?

Thank you in advance.

xut
Posts: 5
Joined: Wed Jul 08, 2015 1:16 pm

Re: 5big2 doesn't wake up from deep sleep mode

Post by xut » Thu Jul 09, 2015 10:57 am

Finally to someone interesting by my discovers:

I remove all disks and connected them to a linux box with mdadm, lvm, xfs.

The linux bos recognized sevral raids. There is no LVM. I mounted the big one (all the seconds disk's partitions). I can read its contains. But as I used my Lacie as an iscsi device, my datas are in a single file "/mounted point>/images/1". It has the same size than my single data partition.

So, how can I mount this file to access its contains???

Do you have an idea?

Thanks.

Mijzelf
Posts: 6199
Joined: Mon Jun 16, 2008 10:45 am

Re: 5big2 doesn't wake up from deep sleep mode

Post by Mijzelf » Thu Jul 09, 2015 12:20 pm

You can probably loopmount it.

Code: Select all

mkdir /tmp/mountpoint
mount -o loop /<mounted point>/images/1 /tmp/mountpoint

xut
Posts: 5
Joined: Wed Jul 08, 2015 1:16 pm

Re: 5big2 doesn't wake up from deep sleep mode

Post by xut » Mon Jul 13, 2015 7:26 am

Hello,
You are right but I used kpartx is simpler.

Before I verified my partition,
root# parted /<mounted point>/images/1
GNU Parted 2.3
Using /mnt/sda1/images/1
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) unit
Unit? [compact]? B
(parted) print
Model: (file)
Disk /mnt/sda1/images/1: 3992172109824B
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number Start End Size File system Name Flags
1 17408B 3992172092927B 3992172075520B ext3 primary

(parted) quit

And I mounted the image device
root# kpartx -a -v /<mounted point>/images/1
add map loop0p1 (253:0): 0 7797211085 linear /dev/loop0 34
root# ls -la /dev/mapper/
total 0
drwxr-xr-x 2 root root 80 Jul 10 18:32 .
drwxr-xr-x 14 root root 3440 Jul 10 18:32 ..
crw------T 1 root root 10, 236 Jul 10 2015 control
lrwxrwxrwx 1 root root 7 Jul 10 18:32 loop0p1 -> ../dm-0
root# mount -t ext3 /dev/mapper/loop0p1 /mnt/lacie/ (my partition was formated in ext3 verify before)

... you can access to your files and copy them.

To umount the partition/device
root# umount /dev/mapper/loop0p1
root# kpartx -d /<mounted point>/images/1
loop deleted : /dev/loop0
# umount /<mounted point>/

Post Reply