Unable to delete directories on Lacie D2 Network

Post Reply
Posts: 1
Joined: Wed Jan 09, 2013 6:11 pm

Unable to delete directories on Lacie D2 Network

Post by FedjK » Wed Jan 09, 2013 6:54 pm

Hello all,

First of all, thanks for making this community alive and happy new year to all readers !

I have a "LaCie d2 Network (2.2.8)" and I access it through windows 7. Recently, I decided to reorganize datas (because backup time were too long) to thin one big active partition by moving some big (size+nb files+nb dir) archives that would not change to a new archive partition.

So I copied datas by a copy and paste command from explorer to a newly created partition. After that, I tried to delete old files, but I had a surprise : +7000 files could not be deleted, cause beeing the properties of Unix User\root. I precise that I am admin of my machine and I checked also that all users of the NAS had full access read and write in the admin interface.

As I noticed that files could be moved freely in explorer to another directory, I started to gather them that way, opened a javascript scrapboard, and build a dirty piece of code to check automatically all files displayed in the admin interface. I could then push the delete button and kill plenty of files I one shoot. It happend that I could after that kill the directories with explorer.

That was bothersome but it would have led to the result ...

BUT : it appears that some of the file cant be moved (OK I could kill them in the admin interface, and so I did) AND some directories (the ones in wich thoses files were) can't get killed from explorer. And that's a problem (for me) because the admin interface doesn't provide any function to kill directories !

I tried to get the propertie of the directories under explorer, but it seems I don't have the right (again the Unix User\root restriction). I tried to connect (with connect a network drive in explorer) with my Lacie admin account, I can't. I tried to look in the code if I would notice something like a "deldir" function, but couldn't find it. So I'm stuck with my rubbish dir.

Unfortunatly, I don't know Unix and if I can understand a bit of javascript when I see it, it is not enough for me to write a code from scratch.

Would anyone know a solution ? For instance :
- a way to reappropriate the rights under windows 7
- or, a javascript that would browse through a named directory and delete everything inside (subdirectories included).
- or, a javascript that would browse through a named directory and modify the rigth for every objects (subdirectories included) so I could kill them.
- or, a magic tool that would enable me to be some kind of superuser on my LacieD2 in windows.
- or ... ?

I tried to ask the support, but they where not of great help for this ... I tried the forums, but with no success.

So, I'd be very pleased if you could help me ...

Thanks in advance

Post Reply