New kernel(Kernel 3.12.6) & Debian wheezy for HMNHDCE...

hellpoet
Posts: 20
Joined: Wed Sep 24, 2014 10:27 am

Re: New kernel(Kernel 3.12.6) & Debian wheezy for HMNHDCE...

Post by hellpoet » Fri Oct 03, 2014 7:31 am

I checked and as you have foreseen i saw logical blocks of 4k. I ordered a new cable...

hellpoet
Posts: 20
Joined: Wed Sep 24, 2014 10:27 am

Re: New kernel(Kernel 3.12.6) & Debian wheezy for HMNHDCE...

Post by hellpoet » Wed Oct 08, 2014 1:21 pm

the logic sector size was the issue. With the esata cable i made again the partition table and now everything works!

Thanks a lot
Carlo

hellpoet
Posts: 20
Joined: Wed Sep 24, 2014 10:27 am

Re: New kernel(Kernel 3.12.6) & Debian wheezy for HMNHDCE...

Post by hellpoet » Wed Oct 08, 2014 7:18 pm

here i am again... the filesystem is readonly...
I formatted in ext4 as in the guide.. stuck again
here the log extract of the mount error:

Begin: Running /scripts/local-premount ... done.
[ 10.252067] EXT2-fs (sda1): error: couldn't mount because of unsupported optional features (240)
[ 10.262691] EXT4-fs (sda1): couldn't mount as ext3 due to feature incompatibilities
[ 10.299223] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
Found bootable rootfs in /dev/sda1
[ 10.368901] EXT2-fs (sda1): error: couldn't mount because of unsupported optional features (240)
[ 10.379571] EXT4-fs (sda1): couldn't mount as ext3 due to feature incompatibilities
[ 10.397639] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
System will boot from usb driver: /dev/sda1
Begin: Running /scripts/local-bottom ... done.
done.
Begin: Running /scripts/init-bottom ... done.

INIT: version 2.88 booting

[[36minfo[39;49m] Using makefile-style concurrent boot in runlevel S.
mount: only root can do that (effective UID is 999)
[....] Starting the hotplug events dispatcher: udevd[ 12.140759] udevd[292]: starting version 175
[?25l[?1c7[1G[[32m ok [39;49m8[?25h[?0c.
[....] Synthesizing the initial hotplug events...[?25l[?1c7[1G[[32m ok [39;49m8[?25h[?0cdone.
[....] Waiting for /dev to be fully populated...[?25l[?1c7[1G[[32m ok [39;49m8[?25h[?0cdone.
mount: only root can do that (effective UID is 999)
[....] Setting parameters of disc: (none)[?25l[?1c7[1G[[32m ok [39;49m8[?25h[?0c.
[....] Activating swap...[?25l[?1c7[1G[[32m ok [39;49m8[?25h[?0cdone.
mount: only root can do that (effective UID is 999)
[....] Cleaning up temporary files.../etc/init.d/checkroot-bootclean.sh: 22: /etc/init.d/checkroot-bootclean.sh: cannot create /tmp/.clean: Read-only file system
mount: only root can do that (effective UID is 999)
mount: only root can do that (effective UID is 999)
mount: only root can do that (effective UID is 999)
mount: only root can do that (effective UID is 999)

xtronets
Posts: 15
Joined: Tue Sep 18, 2012 10:25 am

Re: New kernel(Kernel 3.12.6) & Debian wheezy for HMNHDCE...

Post by xtronets » Tue Oct 28, 2014 9:45 am

Ok who is linux hacker and compile to me kernel 3.17 ;) ?

ptelleria
Posts: 86
Joined: Wed Jan 29, 2014 6:03 pm

Re: New kernel(Kernel 3.12.6) & Debian wheezy for HMNHDCE...

Post by ptelleria » Fri Oct 31, 2014 6:53 pm

Hi
I have finally given this project a go...
I had the HMNHDCE running OMV0.5 (with stefan seidel's kernel), and went for the "Update from Iomega..." route (no SATA drives) and prepared the USB stick. Plugged it in, fired up the HMNDHCE....
but boot stops at:

Code: Select all

[   52.972070] Code: e5933000 e3530000 e5902370 0a000020 (e5921000)
[   52.978275] ---[ end trace 6c194c9a4be4993f ]---
/etc/init.d/nfs-common: line 105:  1717 Segmentation fault      modprobe -q "$1"

Any hints??

If I start without the USB, it stops at

Code: Select all

Begin: Running /scripts/local-premount ... done.
modprobe: module ext3 not found in modules.dep
mount: mounting /dev/sda1 on /tmp/usb failed: Device or resource busy
umount: can't umount /dev/sda1: Invalid argument
mount: mounting /dev/sda1 on /root failed: Device or resource busy
Begin: Running /scripts/local-bottom ... done.
done.
Begin: Running /scripts/init-bottom ... mount: mounting /dev on /root/dev failed: No such file or directory
done.
Target filesystem doesn't have requested /sbin/init.
No init found. Try passing init= bootarg.
modprobe: module i8042 not found in modules.dep
modprobe: module uhci-hcd not found in modules.dep
modprobe: module ohci-hcd not found in modules.dep


BusyBox v1.20.2 (Debian 1:1.20.0-7) built-in shell (ash)
Enter 'help' for a list of built-in commands.
I can access the device, but can't do much, and I'm not linux expert.

ptelleria
Posts: 86
Joined: Wed Jan 29, 2014 6:03 pm

Re: New kernel(Kernel 3.12.6) & Debian wheezy for HMNHDCE...

Post by ptelleria » Sat Nov 01, 2014 12:52 pm

Hi!
I repeated the steps again (it seems I skiped copying the TGZs and the flush command to the HMNHD!) and voilá!!
You do not have the required permissions to view the files attached to this post.

ptelleria
Posts: 86
Joined: Wed Jan 29, 2014 6:03 pm

Re: New kernel(Kernel 3.12.6) & Debian wheezy for HMNHDCE...

Post by ptelleria » Sat Nov 01, 2014 4:04 pm

Hi again!!

Well...the screenshot was booting from USB...when following steps to make HD bootable...I bricked device, so I had to format it, and start fresh install.

Now I boot from HD. However:

1-mdadm program is not installed in the wheezy..(?)..strange, that is why I bricked device as I could not undo de raid array (no lvchange command)
2-should I delete the file "boot.from.here" that is in the root of the HD?? (I guess so, as its for USB booting, but I don't want to screw up again)...it thinks its booting from USB...
3-the 2 white ligts are on (?)
4-I only extracted the wheezy.20140112.tgz...I also extracted the "hmnhdce-modules.20140115.tgz" afterwards, but this renders the system unbootable (?)

help appreciated...in the meantime, to install OMV, DLNA, glacier iface....

Edit: OMV1.0.29 running...now to solve how to mount data partition...but I'd like opinion on issue #2 (and #3, is it normal?)

Edit: having the same issue as @paq85

Code: Select all

[root@NAS:/]$.dmesg | tail

[ 1398.556697] EXT4-fs (sda2): acl option not supported
when mounting with OMV.

But...can mount in /media/xxxx with CLI...but then can't share folder in OMV, as no volume appears...
Last edited by ptelleria on Mon Nov 03, 2014 3:07 pm, edited 2 times in total.

ptelleria
Posts: 86
Joined: Wed Jan 29, 2014 6:03 pm

Re: New kernel(Kernel 3.12.6) & Debian wheezy for HMNHDCE...

Post by ptelleria » Sun Nov 02, 2014 5:52 pm

@lonixlon:

extracted your TGZ, did depmod, plugged FAT32 USB...and it works !!:

Code: Select all

[root@NAS:/]$.df
Filesystem     1K-blocks   Used Available Use% Mounted on
rootfs           8125880 931056   6759012  13% /
udev               10240      0     10240   0% /dev
tmpfs              25412    624     24788   3% /run
/dev/sda1        8125880 931056   6759012  13% /
tmpfs               5120      0      5120   0% /run/lock
tmpfs              50820      0     50820   0% /run/shm
/dev/sdb1        7550228  93232   7456996   2% /media/usb
[root@NAS:/]$.blkid
/dev/sda1: UUID="1ac5c530-c092-498d-9a21-c20daefd9abd" TYPE="ext4"
/dev/sda2: UUID="abd590d7-a0c7-433d-a990-6100d28fbea7" TYPE="ext4"
/dev/sdb1: LABEL="KINGSTON" UUID="4B40-09A8" TYPE="vfat"
but still same issue with not able to mount FS EXT4 due to ACL not supported :oops:

Edit: can mount EXT2 or NTFS, but ACL is not supported by this kernel. @olderzeus could you comment? you did great job ! fyi: i didn't do anything with hmnhdce-uImage.20140115, as its not in the instructions, perhaps its the answer?

ptelleria
Posts: 86
Joined: Wed Jan 29, 2014 6:03 pm

Re: New kernel(Kernel 3.12.6) & Debian wheezy for HMNHDCE...

Post by ptelleria » Sun Nov 23, 2014 7:38 pm

Hi...talking to myself :roll: , but just in case!
it seems /dev/rtc is not created (it doesn't exist, as pointed by hdclock --debug), so when rebooting the time is lost...

BTW: sorted the mounting of EXT4 device. Problem was with trying to do so from OMV, as it adds by default options for quotas in /etc/fstab. just adjust the file appropiately, and it works ! (but no quota support in this kernel)

see http://forums.openmediavault.org/index. ... #post58099

theluke79
Posts: 17
Joined: Fri Jan 02, 2015 10:18 pm

Re: New kernel(Kernel 3.12.6) & Debian wheezy for HMNHDCE...

Post by theluke79 » Fri Jan 02, 2015 11:20 pm

Hi all, I am going to revamp my 2TB HMNHDCE with OMV and Debian Wheezy, I am now running the latest original IOMEGA firmware and I am not happy with it.

The box becomes not responsive and I cannot schedule the On / Off time.

If I got it right, I need to install DEB Wheezy and AFTER the OMV, right?

I know I will loose data etc, all the backps are done, so no probs.

Ubuntu laptop and SATA Box are available.

Please point me in the right direction
Last edited by theluke79 on Sat Jan 10, 2015 10:35 am, edited 1 time in total.

ptelleria
Posts: 86
Joined: Wed Jan 29, 2014 6:03 pm

Re: New kernel(Kernel 3.12.6) & Debian wheezy for HMNHDCE...

Post by ptelleria » Sat Jan 03, 2015 7:18 pm

If I got it right, I need to install DEB Wheezy and AFTER the OMV, right?
yes

theluke79
Posts: 17
Joined: Fri Jan 02, 2015 10:18 pm

Re: New kernel(Kernel 3.12.6) & Debian wheezy for HMNHDCE...

Post by theluke79 » Mon Jan 05, 2015 5:12 pm

Hi!
I think I need a bit of help ...

I duly followed the guide here:

http://downloads.iomega.nas-central.org ... MNHDCE.txt

Everything seemed just fine, no errors whatsover, BUT after repackaging everything and starting the device, I can see it accessing the drive for few seconds, than it just remains stuck with both the power and "warning" led lights solid white.

I had the 2 TB version of HMNDCE.

What can I check?

ptelleria
Posts: 86
Joined: Wed Jan 29, 2014 6:03 pm

Re: New kernel(Kernel 3.12.6) & Debian wheezy for HMNHDCE...

Post by ptelleria » Tue Jan 06, 2015 7:08 pm

retry all steps (without extracting hmnhdce-modules.20140115.tgz), and make sure all are done correctly (I did one mistake, and of course, it didn't work)
if it doesn't, access the device with a serial to usb device and post the bootlog
just today mspector got it working viewtopic.php?f=269&p=91225

theluke79
Posts: 17
Joined: Fri Jan 02, 2015 10:18 pm

Re: New kernel(Kernel 3.12.6) & Debian wheezy for HMNHDCE...

Post by theluke79 » Tue Jan 06, 2015 7:52 pm

Well well...
Looks like I am lucky and found help!
I am to blame, I completely skipped the modules tgz and I can't find reference for the 'flush'... What is it ?
Finally.... Tell me please inform do not need the usb2serial just for the lan.... does dhcp work ?

ptelleria
Posts: 86
Joined: Wed Jan 29, 2014 6:03 pm

Re: New kernel(Kernel 3.12.6) & Debian wheezy for HMNHDCE...

Post by ptelleria » Wed Jan 07, 2015 9:45 am

I can't find reference for the 'flush'... What is it ?
its a script that comes with the tgz, execute as written
with regards to serial to usb, i do recommend it, in case you don't get access to the system, or you need to debug the boot process, but its not an absolute requirement.
DHCP works, but for the first time I'd recommend to go for fixed IP, until you get the system fully operational.
before putting back to enclosure, edit /etc/netowrk/interfaces following viewtopic.php?&f=269&p=91209#p91209

Post Reply