New kernel(Kernel 3.12.6) & Debian wheezy for HMNHDCE...

theluke79
Posts: 17
Joined: Fri Jan 02, 2015 10:18 pm

Re: New kernel(Kernel 3.12.6) & Debian wheezy for HMNHDCE...

Post by theluke79 » Sat Jan 10, 2015 10:30 am

OK, big thanks, I am trying now...

Modules Extracted

tar -xvf of the TGZ archive to the root of the mounted disk

I am using an external SATA enclosure

Looking for the "flush"... which I cannot find :(

I went through all the steps once again, no errors, the device appears to do "something" once the power is applied, but still, I can't find it on the network.

I will try with the USB to serial... which I need to buy... frustrating.

Are there any more checks I can do before buying extra cables?

Mijzelf
Posts: 6199
Joined: Mon Jun 16, 2008 10:45 am

Re: New kernel(Kernel 3.12.6) & Debian wheezy for HMNHDCE...

Post by Mijzelf » Sat Jan 10, 2015 12:37 pm

Have a look in the /var/logs directory. It might contain the information you are searching for.

theluke79
Posts: 17
Joined: Fri Jan 02, 2015 10:18 pm

Re: New kernel(Kernel 3.12.6) & Debian wheezy for HMNHDCE...

Post by theluke79 » Sat Jan 10, 2015 12:52 pm

Ok, thanks! Which log do I need to look for?

I see

bootstrap.log (empty)
faillog
btmp
wtmp

the last 3 files have no extension

I still cannot find the "flush" script, nor the instructions to use it :( I looked in all the folders in the "modules tgz" archive

the network interface file was edited and locked to static IP

UPDATE
I can ping it, but no SSH and still it does not show up in the network device list

ptelleria
Posts: 86
Joined: Wed Jan 29, 2014 6:03 pm

Re: New kernel(Kernel 3.12.6) & Debian wheezy for HMNHDCE...

Post by ptelleria » Sun Jan 11, 2015 3:43 pm

the flushsd.sh is in bootsectors.tgz (just checked it)

if it isn't in /tmp/boot it means that you haven't done this correctly:

Code: Select all

mkdir /tmp/boot
tar -C /tmp/boot -zxf BootSectors.tgz
in any case, the script flushsd.sh is:

Code: Select all

#!/bin/sh

if [ "$1-" = "-" ]; then
	echo "You must choose a device!"
	exit 1
elif [ -e $1 ]; then
	dd if=bootrom.warpped of=$1 bs=512
	dd if=stage1.wrapped of=$1 seek=34
	dd if=u-boot.sd.wrapped of=$1 seek=154
	dd if=u-boot.sd.env of=$1 seek=558
	dd if=uImage.wrapped of=$1 seek=1290
	dd if=initrd.wrapped of=$1 seek=16674
	dd if=serial.warpped of=$1 seek=57080
	dd if=stage1.wrapped of=$1 seek=57088
	dd if=u-boot.sd.wrapped of=$1 seek=57208
	dd if=uImage.wrapped of=$1 seek=58344
	sync
	exit 0
else
	echo "$1 not exists"
	exit 1
fi

theluke79
Posts: 17
Joined: Fri Jan 02, 2015 10:18 pm

Re: New kernel(Kernel 3.12.6) & Debian wheezy for HMNHDCE...

Post by theluke79 » Sun Jan 11, 2015 4:52 pm

Good evening ptelleria!
Glad you're back.

So, if the flushsd script is the one mentioned in the instructions, than I am fine, I did it when I went through the instructions to set up everything.

Write boot sectors data to HDD;
command:
cd /tmp/boot
./flushsd.sh /dev/sdX


There is a flushmd.sh script as well....did you mean the latter?

So, do you think you can give me some more help in how to troubleshoot why i can ping the static IP given to the box, but i cannot do anything else?

I am stil in the same situation, put a fixed IP, I can ping the machine, but no SSH into it.
nmap command says that only port 111 tcp is open

Thanks a million

ptelleria
Posts: 86
Joined: Wed Jan 29, 2014 6:03 pm

Re: New kernel(Kernel 3.12.6) & Debian wheezy for HMNHDCE...

Post by ptelleria » Sun Jan 11, 2015 7:31 pm

;) theluke!
I'm no expert, perhaps mijzelf can also chip in
first of all, i'd order the UART-USB adapter (chip CP2102, its around 2-5$, so go get it). look in http://iomega.nas-central.org/wiki/Seri ... _Media_CE) for pinout connection (remember tx-rx and rx-tx). you will be able to access your device directly (no ssh) and troubleshoot.

otherwise...you're left out currently from the machine...so i'd redo the process (again!). what is a bit weird is that you said the flushsd.sh was not there, but you actually executed it. Many times (it also happened to me) one skipped step (or a wrongly written one) ends in bad results.

alternatively, take out from enclosure, plun into linux VM, and:

cat /var/log/boot

cat /var/log/syslog

and post the relevant section (wherever this is something that looks weird/error)

theluke79
Posts: 17
Joined: Fri Jan 02, 2015 10:18 pm

Re: New kernel(Kernel 3.12.6) & Debian wheezy for HMNHDCE...

Post by theluke79 » Sun Jan 11, 2015 8:06 pm

Hi Ptelleria!

Look, first of all thank you, I am getting the USB-UART right away.

The infamous script is present and running, only thing is, it was in the bootxxx.tgz file and not in the modulesxxx.tgz file, as you said.

So, now, back to the log, I will post asap.

Mijzelf
Posts: 6199
Joined: Mon Jun 16, 2008 10:45 am

Re: New kernel(Kernel 3.12.6) & Debian wheezy for HMNHDCE...

Post by Mijzelf » Sun Jan 11, 2015 8:28 pm

Seeing the contents of your /var/log directory, I think the box didn't boot in Linux, or it couldn't mount the rootfs. Else there would have been more.

As you can ping the box, something is alive. Port 111 is from portmap, but I can't image portmap to start without a trace of logging. So I guess it's u-boot which is running some daemon for remote fimrware installation.

ptelleria
Posts: 86
Joined: Wed Jan 29, 2014 6:03 pm

Re: New kernel(Kernel 3.12.6) & Debian wheezy for HMNHDCE...

Post by ptelleria » Sun Jan 11, 2015 9:35 pm

I said
ptelleria:the flushsd.sh is in bootsectors.tgz (just checked it)
theluke79:The infamous script is present and running, only thing is, it was in the bootxxx.tgz file and not in the modulesxxx.tgz file, as you said.
I suggest you start process again. I suspect a step hasn't been done right. Remeber one of the tgzs shouldn't be extracted ( as well as the openWRT)
ptelleria:I also extracted the "hmnhdce-modules.20140115.tgz" afterwards, but this renders the system unbootable (?)
but
theluke79: OK, big thanks, I am trying now...

Modules Extracted
is it hmnhdce-modules.20140115.tgz?

theluke79
Posts: 17
Joined: Fri Jan 02, 2015 10:18 pm

Re: New kernel(Kernel 3.12.6) & Debian wheezy for HMNHDCE...

Post by theluke79 » Mon Jan 12, 2015 9:56 pm

Hi all,
I got the USB cable, will arrive next wk.
In the meantime....to the TGZ...

I use this file for the process:

http://downloads.iomega.nas-central.org ... MNHDCE.txt

From what I read here:

hmnhdce-modules.20140115.tgz (there is no explanation on what to do with this file, ptelleria you told me to extract it, right? )
hmnhdce-openwrt-rootfs.tgz (did not touch this one)
hmnhdce-uImage.20140115 (did not touch this one)
wheezy.20140112.tgz extracted to the tmp mydisk folder

ptelleria
Posts: 86
Joined: Wed Jan 29, 2014 6:03 pm

Re: New kernel(Kernel 3.12.6) & Debian wheezy for HMNHDCE...

Post by ptelleria » Mon Jan 12, 2015 10:48 pm

Thats the problem!
Don't extract the hmnhdce-modules.20140115.tgz . When I did I bricked the device. (The modules I extracted where others from lonixlon, for mounting USB)
Redo only extracting the bootsectors and wheezy tgzs
Fingers crossed

theluke79
Posts: 17
Joined: Fri Jan 02, 2015 10:18 pm

Re: New kernel(Kernel 3.12.6) & Debian wheezy for HMNHDCE...

Post by theluke79 » Tue Jan 13, 2015 7:38 am

Gr8!
So what I am to do with that file?
Shall I just ignore it?

theluke79
Posts: 17
Joined: Fri Jan 02, 2015 10:18 pm

Re: New kernel(Kernel 3.12.6) & Debian wheezy for HMNHDCE...

Post by theluke79 » Tue Jan 13, 2015 7:55 am

BAAAAAAAAAAAAANG!
That was it!
Ignored the modules.tgz
Fixed IP
AND IT WORKS!

Now to OMV

hellpoet
Posts: 20
Joined: Wed Sep 24, 2014 10:27 am

Re: New kernel(Kernel 3.12.6) & Debian wheezy for HMNHDCE...

Post by hellpoet » Mon Jan 19, 2015 5:21 pm

Hello everyone! After a long journey i installed some months ago wheezy and openmediavault kralizec.
Now weird thing, i tried to clone the hdd with dd to exactly give my working copy to a friend with the same iomega cloud 2tb edition.
I connected with esata cable and cloned with:
dd if=/dev/sdx | gzip -c > /mnt/sda1/hda.img.gz
but it doesn't work the copy finishes without errors but on restore not all the files and the correct partitioning are in place..

Any thoughts?

Thanks
Carlo

theluke79
Posts: 17
Joined: Fri Jan 02, 2015 10:18 pm

Re: New kernel(Kernel 3.12.6) & Debian wheezy for HMNHDCE...

Post by theluke79 » Thu Jan 22, 2015 9:57 pm

It runs now, looooooooong time to figure out issues.
Now I had to reformat EXT4 the data partition

Post Reply